
NEWSLETTER #74 - January 2019

Happy New Year! After introducing Excel 2019 last time out, we welcome 2019 this month.  There’ll be 
some big SumProduct celebrations at the end of the year, but that’s a story for another time…

In this month’s newsletter we look at an Excel icon in an instance (that’s two items, not one!) and announce a new 
home in Sydney.  We’ve even a new series starting for 2019: Power Pivot Principles – check it out below.  There’s 
also our regular series on Power Pivot, Power Query, Power BI Updates, VBA, Keyboard Shortcuts and the ever-
accumulating A to Z of Excel Functions to keep you informed as the New Year beckons.

We wish you all the best for 2019.

It’s been six years since Microsoft last changed its icon set – about the 
same time our first newsletter launched!  Whilst Liam may refuse to 
change the photo on the front page to show how time has ravaged him, 
Microsoft has been more honest.

Strong colours have always been at the core of the Office brand, and 
Microsoft has gone on record that these new icons are a chance to evolve 
their [colour] palette.  The new icons are intended to be “…bolder, lighter 
and friendlier — a nod to how Office has evolved…”.

The latest designs separate the letter and the symbol in the icons into two 
panels to add depth, for better 3D imagery.  Further, prior Office icons had 
a spreadsheet outline for Excel, which has now been replaced by individual 

cells for Excel.  The aim is to apparently focus on the content rather than 
any specific format, which is the direction the software is heading.  That’s 
right, Microsoft is using its icons for a soft cell (groan – Ed.).

The letter-to-symbol ratio has changed as well.  Traditionally, the letter 
occupied two-thirds of the icon, and the symbol took up one-third.  This 
has been modified to emphasise the symbol because while the letter 
represents the tool itself, the symbol is intended to spark user creativity.

It’s not just about Excel.  There’s a whole new icon set that will begin 
rolling out across platforms in the coming months, starting with mobile 
and web.  You have been warned!

New Excel Icon
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Some “personal” news this month – we’ve changed addresses in Sydney!  
We have now moved into  larger premises in order to provide bigger and 
better training and to accommodate our expanding team.  Please make 
a note of the new address.

Melbourne’s main address changes for 2019 too, but this is more 
administrative in nature.  We request all mail correspondence should go 
to our Collins Street address (Level 9, 440 Collins Street, Melbourne, VIC 
3000) rather than our registered office address.

Picture the scene.  2018 has just finished, you’ve just installed Excel 2019 
and you need to compare the last two years’ results before you can take 
a well-earned New Year break.  With deadlines galore, you suddenly 
have that annoying “blue circle of death” on a whited-out screen.  For 

example, you could be running a long macro, manipulating large volumes 
of data or are refreshing Power Query / Get & Transform.  During an 
intensive task in one spreadsheet, other spreadsheets cannot be used – 
because the resources are all tied up.  You want to go home…

That’s because you are using what is known as the same instance of 
Excel.  But it doesn’t have to be this way.  In fact, you may not be familiar 
with the term, but you are probably aware of a workaround already.  Let 
me explain.

Working with multiple screens has been with us for many years as 
they have become cheaper to purchase and make it easier for us to 
do our work.  However, Excel didn’t necessarily keep up with the price 
reductions.  If you worked with Excel, all of your files had to be displayed 
on one screen (unless you were very inventive) – because they were 
all running from the same initiation of the program – an instance.  To 
circumvent this, you opened Excel again et voila! you could have Excel 
omnipresent across your display surfaces.

With the advent of Excel 2013, we forgot this trick.  Microsoft made our 
lives easier by allowing you to put Excel on two or more screens from 
the same instance.  You could link to sheets on other screens (something 
you cannot do with multiple instances.  All was good in the world again.

However, Excel 2013 onwards never ignored its origins.  You could still 
open a separate instance: you just had to do it differently.  And there 
were more ways to do it too.  So, if you find yourself stuck with Excel 
running a resource-intensive task, here’s how you can open a second 
independent Excel application in an instance (get it?).  

I offer you no less than four alternatives.

New Year, New Addresses

ALTernative Excel in an Instance
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Right click on the Excel icon in the taskbar.  As the menu appears, hold down the ALT key and left-click on the ‘Excel’ menu option (Excel 2016 pictured).

You can use the Run window, by clicking on ‘Start’ (depending upon which version of Windows you have and entering ‘Run’ or by right-clicking on that

Windows icon in Windows 10 and selecting ‘Run’.  Then you type in ‘Excel.exe /x’ and press ENTER viz.

In fact, if you have Cortana, you can even just type the text directly in:

However you do it, a new Excel instance will open.

Continue to hold down the ALT key until the below window pops up.  Press ‘Yes’ to open a new instance.

In fact, you can also hold down the ALT key, hover your mouse over the Excel icon in the taskbar and click your scroll-button.  This has the same effect 
and takes even less clicks for those that are scared they might tire themselves out unnecessarily.

1. An ALTernative Experience

2. Run Away with Excel
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For those so inclined, you can write a macro in Visual Basic for Applications (VBA).  Simply run the code below to open a second Excel instance. 

You can force Excel to open a new instance by default.  I show this for 
completion, but be very careful working with the registry.  It’s a great 
way to make friends with your local IT department and learn how to re-
format your hard drive.  However, whilst this approach is inherently the 
most dangerous / complex, it’s the only one where you can make Excel 
open a new instance each time.

Having said that, this method only works when you use the Excel icon to 
open a new spreadsheet.  When opening a new spreadsheet from within 

a file  from File Explorer or by using File -> Open in Excel, the file still 
opens in the current Excel instance. 

Never edit the registry without creating a backup.  Adjusting the wrong 
entries may cause serious problems (no, I don’t mean “opportunities”).  
Therefore, to create a backup:

Click ‘Start’ (or the Windows key), then type ‘Regedit’ and finally click on 
‘Regedit’ in the search results:

Do note, this method does not show a pop-up dialog to indicate you have initiated a new instance.

You can just type ‘regedit’ in the ‘Run’ dialog as well:

3. Using VBA

4. Most Dangerous: Use the Registry

Sub OpenNewExcelInstance()
 
Dim xlApp As Excel.Application
Set xlApp = New Excel.Application
xlApp.Workbooks.Add
xlApp.Visible = True
Set xlApp = Nothing
 
End Sub
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Press File -> Export -> Select Export Range ‘All’ -> Save the backup in a safe location:

Now you may wreak havoc. To edit the registry:

	 •	 close all instances of Excel
	 •	 open the Registry Editor (as explained in the backup step)
	 •	 go to HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Excel\Options (this is for Excel 2016; for Excel 2013,  
		  use HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Excel\Options)
	 •	 click ‘Edit’ in the menu, press ‘New’, and select ‘DWORD (32-bit) Value’ (this seems to be what you must do even if you are using 64-bit Excel)

	 •	 name the entry ‘DisableMergeInstance’, press ENTER
	 •	 right-click the entry DisableMergeInstance, and select ‘Modify’
	 •	 in the ‘Value’ data box, enter 1 and click OK.

Next time you open a new Excel window using the taskbar icon, it will open in a new instance.

In all instances (sorry, I couldn’t resist the pun), use CTRL+ TAB to switch you from one file to the next file within the same instance. 

Word to the Wise

It’s not all about the Power Tools, you know.  We thought we’d run a “basic” series going through the rudiments of Visual Basic for Applications (VBA) 
as a springboard for newer users.  This month, we actually at the VBA Editor.

Using the ‘View Macros’ option is one way to get to the VBA Editor.  However, it is also accessible from Excel via the ‘Developer’ tab in the Ribbon.  
Under the ‘Code’ category on the ‘Developer’ tab, clicking on the ‘Visual Basic’ button will take us directly into the VBA Editor:

Visual Basics

mailto:contact@sumproduct.com
http://www.sumproduct.com


contact@sumproduct.com  | www.sumproduct.com  | +61 3 9020 2071 

Alternatively, ALT + F11 is the keyboard shortcut to enter the Microsoft Visual Basic for Applications editor (known as the “VBA Editor”).

Let’s review the Visual Basic Editor and familiarise ourselves with the different components.

Many of these terms are self-explanatory but let me go through some of them.

	 •	 The Code Window is where procedures appear, i.e. macros that have been recorded and stored are also displayed here.  The code window is 	
		  also where we can write code for our macros

	 •	 The Procedure List is visible at the top-right of the Code Window.  From this list, navigation to any procedure in the active module is quick  
		  and 	easy.  Also notice the view options at the bottom of the screen.  When we have several macros in a module, it can be helpful to view  
		  them one at a time

	 •	 Full Module View allows us to switch between viewing the ‘Full Module view’ and single procedure view with just a click of a button

	 •	 The Immediate Window is used to debug and evaluate expressions, execute statements, print variable values etc.  It allows us to enter 	
		  expressions to be evaluated or executed by the development language during debugging

	 •	 Project Explorer is where we see the list of all VBA projects that are currently open or loaded.  All open documents, as well as open or loaded 	
		  document templates, appear here, regardless of whether they contain macros or not.  They can be easily collapsed or expanded to view the 	
		  modules and objects that it contains

For modules, the Properties Window is generally used only to edit the module name.  Module naming rules are the same as macro naming rules – no 
spaces or special characters and the name must begin with a letter.  However, for some object types (such as UserForms), the ‘Properties Window’ 
becomes extremely important because it's populated with many settings that we can edit directly in that window, like the height and width of a 
UserForm or the value to display on a form control.

More next month.
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A New Year, a new series.  We’ve been running the Power Query / Get & Transform series in our newsletter for some time now, so we thought it might 
be worth commemorating the start of 2019 with a new serial on its sister feature, Power Pivot…

Want to create a PivotTable where formatting “sticks” and data may be referenced from a myriad of various sources at the same time?  Want to 
analyse PivotTable outputs but frustrated with the limitations of calculated fields or the GETPIVOTDATA function?  If so, then Power Pivot is for you!

In this series, we will be sharing with you how to use Power Pivot, as well 
as some little tips and tricks here and there about the tool.  So, to start it 
all off, we take a look this month at what is Power Pivot.

Power Pivot is a COM add-in tool in Excel which may be used to transform 
large volumes of data into sophisticated data models, allowing you to 
perform powerful data analysis.  

Power Pivot offers several features unavailable in “standard” Excel.  One 
such feature is the ability to compile data from multiple sources and 
combine them into one interrelated database.  Another useful feature 
is it can create calculations called a ‘measure’.  Measures calculations 
are used in data analysis, with some of the more common measures 
being sums, averages or counts.  Simple and more complex calculations 
may be created using Data Analysis eXpressions (DAX) formulae.   

Measures may be developed and stored locally in a file to create 
summaries, forecasts and insights. 

Power Pivot also possesses the ability to compress the data in Excel as 
an internal database – known as the “Data Model” – where you may 
store millions of rows of data.  The small file sizes make it easier to share 
workbooks with colleagues, with the added benefit of isolating the 
external database to prevent corruption.  And what’s more, it’s easy to 
use! 

Hopefully, we have piqued your interest in Power Pivot, with its features 
and utilities.  Stay tuned for next month’s article on which versions of 
Excel Power Pivot is actually compatible with – because it changed a 
while back... 

Power Pivot Principles

Each month we’ll reproduce one of our articles on Power Query (Excel 2010 and 2013) / Get & Transform (Excel 2016) from www.sumproduct.com/blog.  
If you wish to read more in the meantime, simply check out our Blog section each Wednesday.  This month, we look at extracting start and end dates. 

For those following the series, past articles have often dipped into the expense accounts of (fictional) salespeople.  For today’s scenario, we will 
extract the start and end date of the employees’ expense period to show how easy it is when we use the grouping functionality in Power Query. 

The sheet below was created using a combined expense query, previously derived in this newsletter series, viz.

Power Query Pointers
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We already have the ‘Expenses’ query, so let’s begin by double clicking on the query to get into the ‘Query Editor’ screen:

Previously, we looked at using grouping to simplify data, and here we’ll be using a similar technique.  On the ‘Transform’ tab, let’s choose ‘Group By’.  
Since we are looking for the period for each person, the grouping will be driven by my Name column.  We’ll need to find the start and end date for their 
expense period.  We’ll begin by entering the first grouping level, naming the column ‘Start Date’ and making it a minimum of the date:

So far so good, so what?  Now we need to get the end date, so let’s create another grouping level using the ‘Add aggregation’ button.  This will also act 
on the Date column, this time taking the maximum value:
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Now all we need to do is click ‘OK’ to see what happens.

It all looks good, so I have a result which can be loaded into an Excel sheet. 

More next month!

Clearly, there were Christmas parties to go to and New Year celebrations.  Consequently, the list of December updates was a little smaller than usual.  
We’re not complaining – it takes me less time to write it!  Here’s the updates for December:

Report

	 •	 Smart guides for aligning objects on a page
	 •	ArcGIS Maps for Power BI updates
	 •	 Fields list accessibility support
	 •	 Set tab order for objects on a page
	 •	 Tooltips for button visuals
	 •	Updated icons for “Visual interactions”

December Updates for Power BI Desktop
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Analytics

	 •	 Live Connect support for Q&A (Preview)

Modelling

	 •	DAX formula bar updates
	 •	Data view accessibility support

Custom visuals

	 •	 BIpm: Interactive directed flow graph

Data connectivity

	 •	 AtScale connector (Beta)
	 •	Oracle Essbase connector (Beta)

Data preparation

	 •	 Fuzzy merge - support for Top N best matches

Other

	 •	High contrast support for all panes and report footer
	 •	Updated keyboard shortcuts dialog.

Let’s go through each new feature in turn.

Smart guides for aligning objects on a page

Similar to PowerPoint, you’ll now see smart alignment guides when moving objects on your report page to help you align everything on your page.  
These smart guides will appear any time you drag or resize something on your page.  When you move an object near another one, it will snap into a 
position aligned with the other object.

If you decide you don’t want the smart guides, you can turn them off in the ‘Report settings’ page of the ‘Options’ dialog.
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There are several updates to ArcGIS Maps for Power BI, which offers enhanced mapping and analysis capabilities, demographic data and visualisations.  
These include:

	 •	 Find locations with similar attributes: The ‘Find Similar’ tool can identify important locations in your data.  You start by selecting one or more 	
		  points of interest, or reference locations, defining up to five dimensions that you want to use in analysis, and then ‘Find Similar’ will calculate 	
		  the 10 locations on your map that are most like the reference locations you defined.  You can then use Infographics cards to learn more about 	
		  the demographics around each of your results, create drive time areas to get a sense of what is within driving distance of each of these 	
		  locations, or even use the ‘Find Similar’ tool itself to filter your report and gain more insights.  Most importantly, all of the calculations are 	
		  performed on your machine, so you can be sure your confidential data remains protected
	 •	Boundary Data for over 130 countries: The ‘Location type’ tool allows you to create maps using standard administrative boundaries for over 	
		  130 countries.  To improve the accuracy of your data analysis, there is now more boundary data available.  For example, you can now find 	
		  boundary data for not only seven, but also 11-digit SLA codes for Australia
	 •	Better user interface: You can now just hover over the selection tool icon to see the entire toolbar.  What’s more, tabs in the side pane scroll 	
		  so you can see the entire text easily.

Should you be an ArcGIS Maps for Power BI Plus user, there’s more features:

	 •	 Infographic Data for over 130 countries: The ArcGIS Maps for Power BI Plus subscription unlocks access to a lot more Esri-curated geographic 	
		  content, including infographic data on income, expense, race, education, health and other demographics
	 •	 Pin maps with up to 5000 addresses: ArcGIS maps for Power BI lets you geocode up to 1,500 addresses per map, but with a Plus subscription 	
		  you can do even more with your data and add up to 5,000 addresses to every map.

The ’Fields list’ pane is now fully accessible.  You may navigate around the pane using just your keyboard and a screen reader and use the context 
menu to add fields to your report page.

The following keyboard shortcuts can also be used in the ‘Fields list’:

	 •	Move focus along the pane: TAB
	 •	 Select a field: ENTER / SPACE
	 •	 Collapse all tables: ALT + SHIFT + 1
	 •	 Expand all tables: ALT + SHIFT + 9
	 •	 Collapse a single table: Left Arrow key
	 •	 Expand a single table: Right Arrow key
	 •	 Open a context menu: SHIFT + F10 or Context key

Microsoft has also added new options to the context menu to add the field to the report page, to the different filter buckets, and the drillthrough 
bucket.  With these updates, all the panes are now fully accessible. 

ArcGIS Maps for Power BI updates

Fields list accessibility support

The default tab order for objects on a page is the 
creation order.  However, you might wish to change 
that.  You can now set your own custom tab order 
for the report page.  To set the tab order, open the 
‘Selection’ pane and switch the from the default 
‘Layer Order’ to the ‘Tab Order’. 

You can drag and drop the fields to reorder the  
‘Tab Order’.

Set tab order for objects on a page
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Things that are currently hidden are also dimmed in this view, since things that are hidden are automatically skipped.

You may also mark something that should be skipped in the tab order by hovering over the number and clicking the ‘Skip’ icon.  Once you mark 
something to be skipped, it will never be in the ‘Tab Order’, even if it is visible on the report.  If you have a lot of shapes on your report for purely 
decorative reasons, it might be a good idea to skip these items.

If you’ve used the button visuals to add navigation, Q&A or information to your report, you might wish to customise the tooltip for the button.  To do 
this, look in the ‘Action’ card of any button visual and you will see a ‘Tooltip’ option.  This lets you put in text that will be used in place of the ‘CTRL + 
Click here to follow link’ tooltip you see by default.

If you’ve used the ‘Visual Interactions’ feature to control whether selecting items in a visual cross-filters or cross-highlights other charts, you’ll notice 
changes have been made to the icons that are visible when in ‘Edit interactions’ mode:

You can now use Q&A with Live Connect.  All Q&A functionality, including Q&A to create visuals and the Q&A explorer, will work for most Live 
Connect scenarios.  The only situations that Q&A will still be disabled are:

These should make it clearer whether the currently selected visual is filtering or highlighting other charts, particularly with last month’s Preview of 
the new on-visual filter restatement.

Tooltips for button visuals

Updated icons for “Visual interactions”

Live Connect support for Q&A (Preview)
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	 •	 Live Connecting to the Power BI service
	 •	 Live Connecting to a multidimensional AS on-prem
	 •	 Live Connecting to Analysis Services with versions earlier than SQL 2016 RTM V 13.0.1601.5 or a model with compatibility level less than 1103.

Do note that this is a Preview feature, so you’ll first need to turn it on in the ‘Options’ dialog. 

The DAX formula bar has had several updates in this release.  The first is that you can now zoom on the formula bar, using either CTRL + / - keys or 
the CTRL + Mouse Wheel.  This is great if the font size is too small or you need to present the DAX to a large group. 

The ‘Data’ view is now fully accessible.  You can navigate around areas of the ‘Data’ view using CTRL + F6.  The data grid region also supports table 
style navigation, namely arrow keys to move around, PgUp / PgDn support, Home / End and CTRL + Home/ CTRL + End support.  You can also trigger 
the context and filter menus with the keyboard.  The ‘Data’ view also supports screen readers and high contrast.

The BIpm: Interactive directed flow graph 
custom visual (by Mohammad Reza Harati 
Nik) shows an interactive direct flow graph.  
This visual is meant to help you better 
understand the process model of the data, 
especially for event logs.

You can download this custom visual from AppSource (download from https://appsource.microsoft.
com/en-us/product/power-bi-visuals/WA104381928?src=office&tab=Overview).

The second update is that you can now use a much larger view of the DAX formula bar.  When expanding the DAX editor, the formula bar new takes 
up almost the full height of the Power BI Desktop, instead of the static 11 lines that was used previously. 

DAX formula bar updates

Data view accessibility support

BIpm: Interactive directed flow graph
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This update provides a new connector that enables you to connect to AtScale as a multidimensional source.  This new connector, which Microsoft has 
developed in collaboration with AtScale, allows you to build Import and DirectQuery-based reports on top of AtScale’s data.

The new AtScale connector can be found under the ‘Databases’ category within the ‘Get Data’ dialog:

Another new data connector in this update, the Oracle Essbase connector allows you to connect to Oracle Essbase and build Import reports.
The new Essbase connector can be found under the ‘Databases’ category within the ‘Get Data’ dialog:

This connector is currently only available in Power BI Desktop.  Microsoft has stated that support for it in the Power BI Service “…is expected to 
become available in a few months…”. 

AtScale connector (Beta)

Oracle Essbase connector (Beta)
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Again, this connector is currently only available in Power BI Desktop and similar to the AtScale connector, support for it in the Power BI Service is 
expected to become available in a few months’ time.  It’s also notes that support for Direct Query is also planned in a future release. 

Back in October, Microsoft introduced a Public Preview of the new Fuzzy Matching capabilities within the ‘Merge Queries’ transformation.  This 
update enhances this feature to provide support for returning the Best N Matches, allowing you to specify a maximum number of matches to return.

All the panes in Power BI Desktop, the page switcher, and their contents are now compatible with high contrast modes. 

That’s definitely better for my eyes.

There are further capabilities planned (such as returning the ‘Similarity Score’ for each match) in future releases, so stay tuned.

Fuzzy merge - support for Top N best matches 

High contrast support for all panes and report footer

mailto:contact@sumproduct.com
http://www.sumproduct.com


contact@sumproduct.com  | www.sumproduct.com  | +61 3 9020 2071 

Microsoft continues to improve the overall experience for navigating around Power BI Desktop using a keyboard, and this update adds some more 
shortcuts for getting around the panes, visuals etc.  You can press ‘?’ to open this cheat-sheet – a revamped shortcut dialog:

In fact, just for those who like that sort of thing, here’s the current list of keyboard shortcuts as cited by Microsoft in various locations.  We’re not 
saying it’s exhaustive but we cannot find a better list:

Improved keyboard shortcuts dialog

Shortcut Action

ALT + Click Insert cursor in DAX Editor

ALT + Down Arrow key Move line down in DAX Editor

ALT + ENTER New line starting from first of line in DAX Editor (no indent)

ALT + I Restart intellisense

ALT + SHIFT + A To comment / uncomment (toggle) a portion of code

ALT + SHIFT + Down Arrow key Copy line down in DAX Editor

ALT + SHIFT + F10 Move focus to ‘Visual’ menu

ALT + SHIFT + F11 Show data

ALT + SHIFT + Right Arrow key Select nearest word and expand selection in DAX Editor

ALT + SHIFT + Up Arrow key Copy line up in DAX Editor

ALT + Up Arrow key Move line up in DAX Editor

CTRL + ALT + Down Arrow key Enter multiple lines of code at once in DAX Editor

CTRL + ALT + Up Arrow key Enter multiple lines of code at once in DAX Editor

CTRL + C Copy

CTRL + D
Highlight the current word, CTRL + D again to find / highlight the same next word.  
Continue pressing CTRL + D to find / highlight all same words, then start typing to replace 
all words at once
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Shortcut Action

CTRL + DELETE Delete a word in the DAX Editor

CTRL + ENTER Insert line below in DAX Editor

CTRL + F2 Select all occurrences of current word in DAX Editor

CTRL + F6 Move focus between sections

CTRL + G Go to line number in DAX Editor

CTRL + I Select current line in DAX Editor

CTRL + K + C Comment multiple lines in DAX Editor

CTRL + K + U Uncomment multiple lines in DAX Editor

CTRL + Right Arrow key Interact with a Slicer

CTRL + SHIFT Multi-select

CTRL + SHIFT + B Move an object down in the layering (‘Selection’ pane)

CTRL + SHIFT + ENTER Insert line above in DAX Editor

CTRL + SHIFT + F Move an object up in the layering (‘Selection’ pane)

CTRL + SHIFT + K Delete multiple lines in DAX Editor

CTRL + SHIFT + L Select all occurrences of current selection in DAX Editor

CTRL + SHIFT + S Hide / show (toggle) an object (‘Selection’ pane)

CTRL + SHIFT + \ Jump to matching bracket in DAX Editor

CTRL + SPACE Multi-select objects

CTRL + V Paste

CTRL + ‘+’ Comment / uncomment all lines including a desired word

CTRL + [ Outdent line in DAX Editor

CTRL + ] Indent line in DAX Editor

CTRL + / Comment multiple lines in DAX Editor

CTRL + \ Uncomment multiple lines in DAX Editor

ENTER Select or de-select an object

F6 Activate ‘Selection’ pane

Left Arrow key Collapse a single table

Right Arrow key Expand a single table

SHIFT + ENTER Creates line break with auto-indent

SHIFT + F10 Open a context menu

SHIFT + TAB Move focus backward in section or decrease indent (context specific)

SHIFT + ? Show keyboard shortcuts

SPACE Select or de-select an object

TAB Move focus forward in section

Windows Context Key + F10 Open a context menu

That’s it for this month.  Microsoft has announced that the next update will only be a Power BI Desktop for Report Server update as they have a break 
to see in the New Year too.  We can’t argue with that.  More anon.

One of the most common questions we get here at SumProduct HQ is, “why haven’t I got the latest function / feature / Power Query Editor / ad lib to 
fade?”.  Sometimes, your particular set-up doesn’t allow you to have the latest and greatest (sorry Mac users), but there are ways you can optimise 
your set-up by ensuring you know hoe to update Office / Windows for your machine.

Now we appreciate many readers will be held ransom by their IT department’s policies and procedures, but for those of you with more leeway, please 
find below how to make sure your update settings are optimised.

Update Update
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If you purchased Office from the Microsoft Store app on your Windows device, you can update Office from the same place:

	 1.	 Exit all Office apps
	 2.	 Open the Microsoft Store app by typing ‘Microsoft Store’ into the taskbar search and press ENTER

	 3.	 Click on the                   icon and make sure you're signed into the Microsoft account associated with your Office license

	 4.	 Click on the                   icon and choose ‘Downloads and Updates’
	 5.	 Click ‘Get Updates’.

	 1.	 Open any Office app, such as Excel (obviously!), and create a new document
	 2.	 Go to File > Account (or ‘Office Account’ if you opened Outlook by mistake)
	 3.	 Under Product Information, choose Update Options > Update Now.  Note: You may need to click ‘Enable Updates’ first if you don't see the 	
	 	 Update Now option right away

	 1.	 Open any Office 2013 application, such as Excel, and create a new document
	 2.	 Click File > Account (or ‘Office Account’ if you opened Outlook 2013)
	 3.	 Under Product Information, choose Update Options
	 4.	 Click Enable Updates if the option is available

	 4.	 Close the ‘You're up to date!’ window after Office is done checking for and installing updates
	 5.	 You can also use the ‘Update Options’ button to ‘Disable Updates’ or to ‘View Updates’ that were previously installed.

Office from the Microsoft Store

Other Office Versions Later than Office 2013

Office 2013

MICROSOFT OFFICE
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	 5.	 Choose Update Now to manually check for and install Office updates
	 6.	 Close the ‘You're up to date!’ window after Office is done checking for and installing updates.

	 1.	 Open any Office 2010 application, such as Excel 2010, and create a document
	 2.	 Go to File > Help > Check for Updates
	 3.	 Choose Install Updates or Check for Updates.  If neither option is available, follow the additional steps provided in the pop-up window that 	
	 	 appeared after you chose Check for Updates.

You’re joking, right?  Microsoft no longer supports Excel 2007 and earlier.  Assuming you don’t want multiple emails sent by mates asking for help 
stranded in countries you have never heard of, you might wish to consider upgrading to a newer version of Office.

	 1.	 Open any Office application, such as Excel
	 2.	 On the top menu, go to Help > Check for Updates.  If you don't see Check for Updates on the Help menu, you will need to download the 	
	 	 latest version of the Microsoft AutoUpdate tool first

	 3.	 Under ‘How would you like updates to be installed?’, select Automatically Download and Install

Office 2010

Office 2007 and Earlier

Office for Mac
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	 4.	 Select Check for Updates.  If an update is available for your version of Office, you'll see a link to a website with more information about the 	
	 	 update.

	 1.	 Open ‘Windows Update’ by choosing Start > Settings > Update and security

Windows 10

MICROSOFT WINDOWS
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	 2.	 Choose Advanced options
	 3.	 Under Choose how updates are installed, choose the options that you want, including checking the Give me updates for other Microsoft 	
		  products when I update Windows box so you can get Office updates. 

	 1.	 Open Control Panel by pressing the Windows Logo key + X to see a list of commands and options, and then click Control Panel 

Windows 8 / 8.1
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	 2.	 Choose System and Security

	 2.	 3.	Choose Windows Update 

	 4.	 Choose Change settings and choose or change the settings you want.  Be sure to select the Give me updates for other Microsoft products 	
		  when I update Windows box so you can get Office updates.  Also, remember that your computer has to be turned on at the time you 	
	 	 selected to install these new updates.

	 1.	 Close all open programs
	 2.	 Choose Start > Control Panel
	 3.	 Choose System and Security (which you see when you view Control Panel by Category)

Windows 7

mailto:contact@sumproduct.com
http://www.sumproduct.com


contact@sumproduct.com  | www.sumproduct.com  | +61 3 9020 2071 

	 4.	 Choose Windows Update

	 5.	 In the left-hand pane, choose Change Settings
	 6.	 Under Important Updates, choose Install updates automatically, and under Microsoft Update check the Give me updates for Microsoft 	
		  products and check for new optional Microsoft software when I update Windows box to get the Office updates.  Your IT department 	
	 	 might set automatic updates for you.  If they do, you'll see the message in the yellow bar, and you won't be able to use the Important 	
	 	 Updates list or Set dates and times, like so:

	 7.	 Select any other options, and remember your computer has to be on at the time you selected to install new updates.  Some other tips you 	
	 	 might wish to consider:
	 	 o	 If you view the items in ‘Control Panel’ by their icons instead of categories, you choose System > Windows Update > Change Settings
	 	 o	 You'll receive updates for Office, Windows, and other products like Zune (really!?)
	 	 o	 Updates come in three categories: ‘Important’, ‘Recommended’ and ‘Optional’.  You'll only receive the ‘Important’ updates unless you 	
	 	 	 select the second option Give me recommended updates the same way I receive important updates
	 	 o	 It's a good idea to install the ‘Recommended’ updates.  The ‘Optional’ updates may be things you don’t need, like the ability to change 	
	 	 	 the language in your Office programs.  It doesn't hurt to install them, but you have to get those updates manually.

Do make sure you have enough power left in your elastic bands that power your wind-up PC, if you are using this…  To turn on automatic updates in 
Windows Vista:

	 1.	 Choose Start, point to All Programs, and then choose Windows Update
	 2.	 Do any of the following:
		  o	 If updates need to be installed, choose Install updates
		  o	 To start checking for updates, choose Check for updates
		  o	 For more information, choose View available updates.

Windows Vista
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In the Windows Update dialog box, you can choose the links to make changes or learn more about the update process:

	 •	 Check for updates: search for available updates
	 •	 Change settings: select options for how your computer receives updates from Microsoft
	 •	 View update history: view what has been installed and the status of those installations
	 •	 Restore hidden updates: hide updates from your computer and install them later
	 •	 Updates: frequently asked questions: learn more about the update process.

To turn on automatic updates in Windows XP, find a grandparent who remembers what the password was for that machine first.  Then:

	 1.	 Choose Start > Control Panel
	 2.	 Choose Performance and Maintenance, and then double-click System
	 3.	 In the ‘System Properties’ dialog box, choose the Automatic Updates tab.  If you are using the ‘Classic’ view, double-click System and then 	
		  click the Automatic Updates tab
	 4.	 Choose the settings you want to use
	 5.	 Choose Apply > OK.

Good luck!

Windows XP

Earlier Versions of Windows

This function returns the cumulative interest paid (“cumulative interest payment”) on a loan between a designated start_period and end_period given 
a constant periodic discount rate.

The CUMIPMT function employs the following syntax to operate:

CUMIPMT(rate, nper, pv, start_period, end_period, type)

The CUMIPMT function has the following arguments:

	 •	 rate: this is required and represents the interest rate
	 •	nper: this is also required and represents the total number of payment periods
	 •	pv: this is required and represents the present value of the amount under finance
	 •	 start_period: this is required and represents the first period in the calculation.  Payment periods are numbered beginning with 1
	 •	end_period: this is required and represents the last period in the calculation
	 •	 type: this is required and represents the timing of the payment.

The A to Z of Excel Functions: CUMIPMT
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It should be further noted that: 

	 •	 you ensure that you are consistent about the units you use for specifying rate and nper.  If you make monthly payments on a four-year loan at 	
		  an annual interest rate of 10%, use 10%/12 for rate and 4*12 for nper.  If you make annual payments on the same loan, use 10% for rate and 4 	
		  for nper
	 •	 if rate ≤ 0, nper ≤ 0, or pv ≤ 0, CUMIPMT returns the #NUM! error value
	 •	 if start_period < 1, end_period < 1, or start_period > end_period, CUMIPMT returns the #NUM! error value
	 •	 if type is any number other than 0 or 1, CUMIPMT returns the #NUM! error value.

Please see our example below: 

Other key points:

	 •	 to get a monthly rate, divide the interest rate by 12 (the number of months in a year) and multiply the years the money is paid out by 12 in 	
		  order to get the number of payments
	 •	 in Excel Online, to view the result in its proper format, select the cell, and then on the ‘Home’ tab and in the ‘Number’ group, click the arrow 	
		  next to ‘Number Format’ and select ‘General’.

This function “partners” CUMIPMT and returns the cumulative principal repaid on a loan between a designated start_period and end_period given a 
constant periodic discount rate.

The CUMPRINC function employs the following syntax to operate:

CUMPRINC(rate, nper, pv, start_period, end_period, type)

The CUMPRINC function has the following arguments:

	 •	 rate: this is required and represents the interest rate
	 •	nper: this is also required and represents the total number of payment periods
	 •	pv: this is required and represents the present value of the amount under finance
	 •	 start_period: this is required and represents the first period in the calculation.  Payment periods are numbered beginning with 1
	 •	end_period: this is required and represents the last period in the calculation
	 •	 type: this is required and represents the timing of the payment.

The A to Z of Excel Functions: CUMPRINC
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It should be further noted that: 

	 •	make sure that you are consistent about the units you use for specifying rate and nper.  If you make monthly payments on a four-year loan at 	
		  an annual interest rate of 12 percent, use 12%/12 for rate and 4*12 for nper.  If you make annual payments on the same loan, use 12% for rate 	
		  and 4 for nper
	 •	 if rate ≤ 0, nper ≤ 0, or pv ≤ 0, CUMPRINC returns the #NUM! error value
	 •	 if start_period < 1, end_period < 1, or start_period > end_period, CUMPRINC returns the #NUM! error value
	 •	 if type is any number other than 0 or 1, CUMPRINC returns the #NUM! error value.

Please see the example below: 

Other key points:

	 •	 you divide the interest rate by 12 (the number of months in a year) to get a monthly rate, and you multiply the years the money is paid out by 	
		  12 to get the number of payments
	 •	 in Excel Web App, to view the result in its proper format, select the cell, and then on the ‘Home’ tab and in the ‘Number’ group, click the arrow 	
		  next to ‘Number Format’ and select ‘General’.

More Excel Functions next month…

Upcoming SumProduct Training Courses

Location Course Date Duration

Sydney Power Pivot, Power Query and Power BI 21 - 23 Jan 2019 3 Days

Melbourne Power Pivot, Power Query and Power BI 29 - 31 Jan 2019 3 Days

Sydney Excel Tips & Tricks 4 Feb 2019 1 Day

Sydney Financial Modelling 5 - 6 Feb 2019 2 Days

Brisbane Excel Tips & Tricks 11 Feb 2019 1 Day

Brisbane Financial Modelling 12 - 13 Feb 2019 2 Days

Melbourne Excel Tips & Tricks 19 Feb 2019 1 Day

Melbourne Financial Modelling 20 - 21 Feb 2019 2 Days

Perth Excel Tips & Tricks 25 Feb 2019 1 Day

Perth Financial Modelling 26 - 27 Feb 2019 2 Days

Melbourne Power Pivot, Power Query and Power BI 11 - 13 Mar 2019 3 Days
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contact@sumproduct.com
www.sumproduct.com
+61 3 9020 2071

Sydney Address:	 SumProduct Pty Ltd, Suite 803, Level 8, 276 Pitt Street, Sydney NSW 2000 
New York Address:	 SumProduct Pty Ltd, 48 Wall Street, New York, NY, USA 10005
London Address:	 SumProduct Pty Ltd, Office 7, 3537 Ludgate Hill, London, EC4M 7JN, UK
Melbourne Address:	SumProduct Pty Ltd, Level 9, 440 Collins Street, Melbourne, VIC 3000
Registered Address:	SumProduct Pty Ltd, Level 6, 468 St Kilda Road, Melbourne, VIC 3004

Link to Others
These newsletters are not intended to be 
closely guarded secrets.  Please feel free 
to forward this newsletter to anyone you 
think might be interested in converting to 

“the SumProduct way”.

If you have received a forwarded 
newsletter and would like to receive 
future editions automatically, please 

subscribe by completing our newsletter 
registration process found at the foot of 
any www.sumproduct.com web page.

Any Questions?
If you have any tips, comments or queries 
for future newsletters, we’d be delighted 
to hear from you. Please drop us a line at 

newsletter@sumproduct.com.

Our Services
We have undertaken a vast array of 
assignments over the years, including:
· 	 Business planning
· 	 Building three-way integrated 		
	 financial statement projections
· 	 Independent expert reviews
· 	 Key driver analysis
· 	 Model reviews / audits for internal 		
	 and external purposes
· 	 M&A work
· 	 Model scoping
· 	 Power BI, Power Query & Power Pivot
· 	 Project finance
· 	 Real options analysis
· 	 Refinancing / restructuring
· 	 Strategic modelling
· 	 Valuations
· 	 Working capital management
If you require modelling assistance of any 
kind, please do not hesitate to contact us 
at contact@sumproduct.com.

Training
SumProduct offers a wide range of 
training courses, aimed at finance 
professionals and budding Excel experts. 
Courses include Excel Tricks & Tips, 
Financial Modelling 101, Introduction to 
Forecasting and M&A Modelling. 

Drop us a line at training@sumproduct.com 
for a copy of the brochure or download  
it directly from
http://www.sumproduct.com/training.

Check out our 
more popular 
courses in 
our training 
brochure:

There are over 540 keyboard shortcuts in Excel.  For a comprehensive list, please download our Excel file a
www.sumproduct.com/thought/keyboard-shortcuts. Also, check out our new daily Excel Tip of the Day feature on the 
www.sumproduct.com homepage.

Key Strokes
Each newsletter, we’d like to introduce you to useful keystrokes you may or may not be aware of.  This month, it’s time we realise we 
started this month’s newsletter with ALT so we thought we had better finish with that same useful key too – and perhaps invite it to a 
function…

Keystroke What it does

ALT + F1 Insert Chart as an Object

ALT + F2 Save As

ALT + F4 Close Application

ALT + F5 Refresh

ALT + F6 Switch to VBA Integrated Development Environment (IDE) (if open already)

ALT + F8 Run Macro

ALT + F11 Show VBA Integrated Development Environment (IDE)


