
Excel will now let you deselect cells or a range of cells from your current 
selection.  Microsoft has just rolled this out for PC and Mac subscription 
users of Office 365.  

To "unselect" (it's a new word, look it up!) a selected cell, hold down the 
CTRL button (or Command on a Mac) key and click on the cells you want 
to deselect.  To unselect a range of selected cells, hold down the CTRL 

(or again, the Command for Mac) key and drag the range you want to 
deselect, starting from within the selected range.

Don’t get confused with the cell in the top left-hand corner of the range 
selected remaining white!  You can have fun experimenting what that 
looks like when it is de-selected...

NEWSLETTER #64 - March 2018

We have Summit to talk about this month…   
In fact, there’s plenty of summits – the MVP Summit, the Amsterdam Excel Summit and of course, our very own Unlock Excel  
one too.  There’s lots of updates as well – Power BI (Desktop, Service and Mobile), Power Query and even Excel (remember that?).
With a refresher on formats versus styles, there’s the usual regular features such as Power Query Pointers, the A to Z of  
Excel Functions (this month, COMBIN and COMBINA make a killer combination) and more Keyboard Shortcuts.  
Hopefully, something for everyone!
Until next month.

Deselect Cells from Selected Ranges in Excel 2016

Yes, this is the only photo ever taken at the summit...

Due to Non-Disclosure Agreements being in place the Microsoft 
Most Valuable Professional (MVP) Summit may not be “summit 
we can talk about” in general.  However, March heralds the 2018  
get-together of Most Valuable Professionals (MVPs) [as accredited 
by Microsoft] to network and discuss the latest developments in their 
area of expertise – in our case, Excel.  SumProduct has two MVPs in its 
rank presently – Tim Heng and Liam Bastick – although only Liam will be 
attending the event on this occasion, due to prior work commitments.  

Scheduled for early March at Redmond, we also get a chance to ask our 
questions to the developers.  Therefore, if you have a question you’d like 
us to ask, drop us a line at contact@sumproduct.com.

MVP Summit
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Just like buses, you miss one and then three come along at once…  MVPs Jan Karel Pieterse and Tony de Jonker have just announced the fifth annual 
Amsterdam Excel Summit.  Presently, details are scant although we can confirm:

 • SumProduct’s own Liam Bastick will be presenting (don’t let that put you off though – Ed.)
 • The date of the summit is June 7
 • There will be a post-conference Masterclass on June 8
 • The event will be held in, er, Amsterdam!

More details as we get them, but we hope to see some of you there!  In the meantime, you can keep up to date by checking out topexcelclass.com/
index.php/amsterdam-excel-summit/.

The CPA Australia / Microsoft / SumProduct Unlock Excel event for Australia and New Zealand will soon be upon us.  However, even 
more soon, the Early Bird pricing (where you can save 15% plus on pricing) will soon end: last day of the offers commence Tuesday 13 
March (depending upon location).  If you are thinking of going, don’t pay more than you have to!

The events are as follows:

 • MELBOURNE 9-10 April
 • SYDNEY 12-13 April
 • BRISBANE 16-17 April
 • WELLINGTON 19-20 April

Check out the official website at www.cpaaustralia.com.au/training-and-events/conferences/unlock-excel.  Hope to see you there!

Unlock Excel Summit – Early Bird Pricing Ends Soon!

Now here is some truly exciting news.  Office 365 is looking to bring in Artificial Intelligence (AI) initiatives into three of its core products: Excel, 
Outlook and Word.  Here at SumProduct, obviously we were most interested in the Excel initiative: Insights.

Amsterdam Excel Summit
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Most Excel users are familiar with the importance of presentation in their spreadsheets.  But do you know how to make changes quickly and 
throughout your workbook?  No?  Well here’s a trick to make such hassles a thing of the past.
Take the illustration below.  How easy is it to find the key data, or see which cells should be changed to facilitate updated information?  Have you ever 
noticed that spreadsheets built by colleagues do not look like your own?  How easy are these things in your own spreadsheets?

Two key qualities of good spreadsheet design which we ramble on and on about here all of the time are consistency and transparency.

 • Examples of consistency:
   o formulae are copied without amendment across rows
   o cells with a common purpose (for example, inputs that are assumptions, such as inflation rates) are formatted similarly
   o titles are positioned in the same cells in different worksheets
   o assumption cells (cells containing data that can be changed by the user to affect model outputs) are unlocked, where all other cells are  
    locked, so that only these cells can be changed

  • Examples of transparency:
   o assumptions are formatted to be instantly recognisable
   o key outputs (for example, totals) can be identified immediately, with their derivation made obvious.

Excel’s ‘Styles’ features can assist with both transparency and consistency.

Formats vs. Styles
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These terms, often used interchangeably, but they are not the same thing.  To see this, select any cell in Excel and apply the shortcut keystroke  
CTRL + 1.  This shortcut brings up the ‘Format Cells’ dialog box:

Excel has six format properties: Number, Alignment, Font, Border, Patterns and Protection.  A style is simply a pre-defined set of these various 
formats.  With a little forethought, these styles can be set up and applied to a worksheet cell or range very easily.

Formats and styles
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Creating your own styles is straightforward with Excel’s Style dialog box: simply go to the Home tab, click the arrow in the bottom right corner and 
then select ‘New Cell Style…’ (ALT + H + J + N):
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Let’s create an assumption format for entering data in dollars.  First, select a cell or range of cells.  Then, call up the above dialog box.  The dropdown 
box (highlighted above) can be edited.  We’ll change the name to ‘Dollar Assumptions” and click the ‘Format’ button.  The ‘Format Cells’ dialog box 
reappears:

	 •	Number: select the Currency category, with zero decimal places and apply the ‘$’ symbol
	 •	Alignment: Horizontal – Right (Indent) with zero indent
	 •	 Patterns: select an ‘easy-on-the-eye’ colour such as pale green
	 •	 Protection: uncheck the Locked check box (allows the cell to be changed in a protected worksheet)
 • Click ‘OK’ to return to the ‘Style’ dialog box.

Note that no formats have been ascribed for Font or Border in this example.  We don’t want the style to control (that is, overwrite) these properties, 
so the ‘Style includes’ check boxes for these two format properties should be unchecked:

By clicking ‘OK’ or ‘Add’, the cell or range has now been formatted with the ‘Dollar Assumptions’ style.  Now that this style has been added, you simply 
select the range and then click on the style in the ‘Styles’ gallery on the ‘Home’ tab. 

Easy!

Example
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The difference between Formats and Styles becomes obvious when you 
realise you want to change (update) a style.  Just select one of the cells 
that the style is attached to and call up the ‘Style’ dialog box in the usual 
way (or right-click on the Style and select ‘Modify…’), modifying the style 
as required.  Click ‘OK’ when finished.  Note that every cell in the open 
workbook that uses this style has automatically updated.  Once you start 
using styles, you will never look back!

You will only want to set up styles once.  When you’re finished, simply 
save the file as a template using File-->Save As (you may wish to delete 
or remove formatted cells first so that you have a blank workbook).  
Using File-->New will call up your saved styles.

 Makes a difference, don’t you think?

Updating and Retaining Styles

Before Styles After Styles

Each month we’ll reproduce one of our articles on Power Query (Excel 
2010 and 2013) / Get & Transform (Excel 2016) from www.sumproduct.
com/blog.  If you wish to read more in the meantime, simply check out 
our Blog section each Wednesday.  Last month, we looked at row level 
operators and simplifying bulky code.  This month, we combine two list 
functions to show one method to achieve a running total.
One point before starting: there really should be a straightforward way 
to create a running total in Power Query.  Hopefully, this approach will 
be obsolete shortly, but at the time of writing, there is no single function 
in Power Query to create a running total. 

Previously, we have looked at formulae available when creating a 
custom column, and particularly the ‘Learn about Power Query formulas’ 
option on the ‘Custom Column’ screen.  Clicking on this option initiates a 
journey through the Microsoft help pages, where you can find out about 
lots of functions.  One way to extract a running total (there are others, 
have fun finding out kiddies), is to use a combination of List functions, 
namely the List.Range and List.Sum functions. The idea is to get a list 
of all the amounts so far that are to be totalled, and then to add them 
up. The List.Range function has some parameters that I will need to set.  
Microsoft explains List.Range as follows:

About:	 Returns a count items (sic) starting at an offset.

Syntax: List.Range(list as list, offset as number, optional	count as number) as list  

Arguments: list – the list to check

 offset – the index (position) to start at

 optional	count – count of items to return

Example: List.Range({1..10},	3,	5) equals {4, 5, 6, 7, 8}  

For our illustration, let’s add a running total of Amount to the ACCT_Order_Charges_with_Group query created previously. 

To use the List.Range function, we will need a way of sequentially identifying the rows containing the amounts so that they form a list.  Then, we will 
then need to tell the function to look at this list, where to start from and (in this case) where to stop. 
To assign a number to each row, let’s add an index column, making sure we start from 1 and not 0 (the default).  On the ‘Add Column’ choose to ‘Add 
Index Column’ and select ‘From 1’ on the dropdown.
We can then create a column that holds the amounts so far in a list. Still in the ‘Add Column’ section, choose to ‘Add Custom Column’. The formula 
should be:

 =List.Range(#"Added Index"[Amount],0,[Index])

Here, we are looking at the amounts sequentially by row number starting at the first row and ending with the index for the row that the formula is 
on, i.e. each amount up to the current row.  The column that is created looks a little odd, as it just contains the word ‘List’ for each row (see below).  
However, if we click in the column next to (but not on) the word ‘List’ then the contents appear at the bottom left of the screen under the title ‘List’:

Power Query Pointers
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Having gathered all the amounts needed, the next step is to add them all up.  This is where List.Sum comes into play.  It would be overkill to list the 
arguments and example for this one as it is so simple – the only argument required is a list, which we definitely have.  List.Sum would return an error 
if given an empty list, but this is not an issue here.  So, let’s create another custom column, and enter the following formula:

=List.Sum(List.Range(#"Added Index"[Amount],0,[Index]))

Give the new column the descriptive name Running_total_amount, and it does display the running total of the amount for each row.  We no longer 
need the first custom column; it was created purely to show what the list would contain.  Therefore, we can select and remove the ‘Added Custom’ 
step, and then close and load to see my new running total in the spreadsheet.  With more than 30,000 rows in this table (and list calculations in the 
background), the load is by no means instantaneous.  This is another reason why Power Query should have a purpose-built function to calculate 
running totals; it would be much more efficient!  

In the screenshot of my worksheet below, the other columns have been hidden to allow the Running_total_amount to be easily compared with the 
Amount value.

More next month.
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The Power BI Desktop updates keep coming.  And coming at a pace for that matter.  Here’s the list of February additions: 

Reporting

 • Multi-select data points across multiple charts
 • Sync slicers across multiple pages of your report
 • Numeric range slicer improvement: whole number snapping (Preview)
 • Faster geocoding for Bing maps (Web Preview)
 • Overflow data labels for bar and column charts
 • Search the ‘Formatting and Analytics’ pane

Analytics

 • Mark custom date table
 • Quick measures are now generally available
 • UTCNOW() and UTCTODAY()

Custom visuals

 • Organizational custom visuals (Preview)
 • Network Visualization and Filter
 • Slope Chart by MAQ Software
 • Filter by List
 • as Timeline
 • as T-Accounts

Data connectivity

 • Improvements to DirectQuery over SAP HANA (Preview)

Other

 • DirectQuery performance improvements
 • Open and save performance improvements
 • “Show items with no data” improvements
 • Persistent filters control for upcoming Power BI Service feature
 • Consulting Services quick link.

Let’s take a look at each of these in turn.

Multi-select data points across multiple charts

This release sees another highly requested feature: you may now CTRL + CLICK on data points in multiple charts and have the cross filters applied to 
your entire report.  As you select data points across multiple charts, Power BI Desktop will apply both those filters together.  For example, if you select 
‘Computers’ in a column chart and ‘Regular’ in a pie chart, then all the charts on your report page will be filtered to products that are computers and 
regular.  It would be nice to see an ‘OR’ capability here at some point in the future too.

February Updates for Power BI Desktop
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Sync slicers across multiple pages of your report

Slicers may now be applied to multiple pages.  To do this, note the new 
‘Sync slicers’ pane that will let you select slicers to stay in sync across 
multiple pages.  For instance, selecting ‘Red’ on a product colour slicer 
on page 1 will be reflected in the product colour slicer on page 2 if the 
two pages are synchronised.  You may access the ‘Sync slicer’s pane from 
the ‘View’ tab.

 
Once you’ve opened the pane, select a slicer to see the options.  You can 
quickly make the slicer apply to every page by clicking the ‘Add to all’ 
link.  A hidden slicer will be put on every page, synced to the currently 
selected slicer.  You can also use the right column to pick if the slicer is 
visible on each page or not.

Numeric range slicer improvement: whole number snapping (Preview)

There is also a minor improvement to the numeric slicer preview visual.  Now if you create a range slicer using a whole number column, it will snap 
to rounded values and not apply decimal filters:

Overflow data labels for bar and column charts

By default, Power BI will hide your data labels if you place them inside the data points and they don’t fit.  From this update, Microsoft has added a 
formatting option that lets the data label overflow past the edge of the data point, similar to the treatment adopted in Excel.  Note that Power BI 
Desktop will still automatically hide data labels that would collide with others to prevent overlapping text.

Faster geocoding for Bing maps (Web Preview)

Starting from February, Microsoft has developed a faster way to 
geocode map data.  This new method can have up to a 6x improvement 
on geocoding speed, depending upon the amount of data analysed.  
While you shouldn’t notice any changes to the actual location results 
you are getting back, the results will come back much faster. To ensure 
this feature works, Microsoft is “flighting” this feature.  In non-nerd  

 
speak, this means they will be releasing it to a small group of users and 
will over time slowly increase the number of users getting the feature.  
When we flight features, they only affect the Power BI service, not your 
Desktop reports, but Microsoft wanted to share the feature details here 
so everyone is aware of the changes.
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Search the ‘Formatting and Analytics’ pane

There are becoming so many options now in the ‘Formatting and Analytics’ pane that it can sometimes be hard to find the option you are looking for.  
To help with this, this update adds a search box that will filter down the options to only those that match your search terms.

Mark custom date table

Until this update, you could only bring your own date tables by importing from Excel (using Power Pivot) or through LiveConnect (SSDT).  Now in 
Power BI, you can mark a table as a date table.  This will enable date hierarchies and time intelligence for the selected table.

In order for a table to be marked as a date table, it must contain at least one column of type 'Date', or 'Date/Time'.  Any attendees of our training 
courses will know we advocate Calendar[Date] and leave your brain at home.  You can mark your own table as a date table either through right-
clicking on the desired table or using the Ribbon button.

When marking a table as a date table, you must select a date column to be used as a primary date column.  Make sure that the column you pick for this:

 • Contains no null values
 • Contains unique values
 • Contains contiguous date values (from start to end)
 • If it is a date / time column, the timestamp must be the same across each value.

When a table is marked as a date table, all the built-in date tables associated with this table will be removed.  If you later un-marked it as a date table, 
the built-in date tables will be re-created for the date columns in the table.
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Quick measures are now generally available

The Quick Measures feature is now generally available and no longer requires the Preview feature switch to be turned on.  Additionally, thanks to the 
above feature to mark your own custom data table, you no longer need to use Power BI's date hierarchy for the time intelligence quick measures.  You 
can use the date field from your own calendar date table in any quick measures.

UTCNOW() and UTCTODAY()

Two new DAX functions have been added in this update that help if you're working with date-time data across time zones.  DAX has long supported 
the NOW() and TODAY() functions that return time and date in the time zone that the function's being used - so if a .pbix file is passed to someone in 
a different time zone they'll see different results.  UTCNOW() and UTCTODAY() will always return the current time or date in UTC so you can guarantee 
consistent results wherever you are (and also when you upload the workbook to the Power BI service).

Organizational custom visuals (Preview)

Custom visuals enable developers and users to visualise their data in the 
way that best helps them understand the data and gain insights from 
it.  Often, these visuals are specific to the organisation's needs and the 
way that it runs its business.  The organisation typically doesn’t want to 
publish the visual to the public.  Nevertheless, there is a real need to get 
those visuals into the hands of data analysts inside the organisation, the 
ones that build and maintain the analytics reports and dashboards.  It’s 
especially important that it’s easy for them to discover the appropriate  

 
visuals and to know they don’t need to maintain and update these visuals 
to use them.

Your organisation’s Power BI admin team can deploy specific visuals as part 
of your organisational repository.  This means you’ll see these deployed 
visuals under a new section of the Power BI custom visual store integrated 
into Power BI Desktop called My organization.  

This feature is currently in Preview, so you’ll need to enable it from the ‘Options’ menu (File -> Options and settings -> Options -> Preview features).

If you are a Power BI administrator, you can add new custom visuals to this part of the store by going to the ‘Admin’ portal in the Power BI Service 
and selecting the ‘Organization visuals’ tab.  From there, you can click the ‘Add a custom visual’ button and upload the .pbiviz file for the custom 
visual you want.
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Network Visualization and Filter

The Network Chart by ZoomCharts has the ability to visualise data as a 
network structure and filter data through a variety of gestures and smart 
touches on all devices.  The network structure lets you have multiple 
vertice types (more than two), making it possible to see the connections  

 
among many categories.  The box select feature lets you easily select 
multiple nodes within the chart to filter your other visuals.  Visualising the 
data as a network structure lets you see the implied connections in data 
making important decision making more efficient and obvious.

Slope Chart by MAQ Software

Slope Chart by custom chart regulars MAQ Software allows you to analyse trends in data at a glance.  This visual is useful for comparing interactions 
between two data points based on time or another user-chosen parameter.  A slope chart is most useful if there are notable changes to highlight or for 
showing comparisons between groups.

Some practical use cases of the interactive Network Chart and Filter visual are:

 • Customer segmentation
 • Cost and revenue analysis
 • Log / event analysis.

There are two versions of this chart.  The free version is available on Microsoft AppSource and the customisable, paid version can be purchased from 
the ZoomCharts website.

Features of the free Network Chart visual include:

 • Fully depict data as a network structure with the ability to filter the data from within the visual
 • Smooth connecting visuals
 • Cross-category filtering
 • Dynamic force feedback layout
 • Expanding/collapsing vertices
 • Hide/Unhide vertices
 • Select one or multiple vertices
 • Category-coded colours for vertices (non-configurable)
 • Inner and outer labels for vertices (non-configurable)
 • Dynamic radius for vertices (non-configurable).

Paid features include:

 • Legend control
 • Customisable vertices
 • Support for images inside vertices
 • Value-based gradient colours for vertices and edges
 • Inside / outside label configuration
 • Configurable dynamic radius for vertices
 • Configurable dynamic width for edges
 • Edge decorations
 • Up-to nine categories.
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Some key features of the visual include:

 • Quick comparison of indicator growth or loss across categories
 • Easy interaction with many data points using zoom functionality
 • Quickly download an image of the chart with the capture image widget.

Filter by List

The Filter by List visual lets you bulk apply filter values for a report.  Currently if you want to filter a report with a large number of categories, such as 100 
products, you’d need to check each box in the filter pane one by one.  With this visual you can do this immediately by pasting the entire list of products 
into the slicer visual.

as Timeline

This visual helps you find overlaps and gaps of dates in your data.  This is useful for showing things such as team vacation schedules or project plans.

as T-Accounts

T-accounts are used by most accounting professionals to understand difficult accounting journal entries and with this visual you can now create 
T-accounts in Power BI directly.
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Improvements to DirectQuery over SAP HANA (Preview)

Power BI has long supported SAP HANA, both for import and DirectQuery.  
However, the DirectQuery support largely treated SAP HANA as a 
relational source, meaning that care had to be taken to ensure that 
measures aggregated correctly when dealing with non-additive SAP 
HANA measures like Counters or ratios and to ensure that the reports 
had good performance.
There is now a preview of a new approach to SAP HANA that will treat 
it as something known as a multi-dimensional source by default, in a 
similar manner to SAP Business Warehouse or Analysis Services.  You’ll 
need to turn on the ‘New SAP HANA connector’ Preview feature switch 
under File -> Options and Settings -> Options -> Preview features.
When connecting to SAP HANA using this approach, a single analytic 
or calculation view is selected and all the measures, hierarchies, and 
attributes of that view will be available in the field list.  As visuals are 
created, the correct aggregate data will always be retrieved from SAP 
HANA.
It is still possible to use the old approach to DirectQuery over SAP HANA.   

 
This is controlled by selecting File -> Options and settings and then 
Options -> DirectQuery, then selecting the option ‘Treat SAP HANA as a 
relational source’.  Check this option to create a DirectQuery report over 
SAP HANA using the old approach.
Note that this option controls the approach that will be used for any 
new connections created.  It has no effect on any existing SAP HANA 
connections in the current report, nor on connections in any other 
reports that are opened.  This means that any reports connecting to SAP 
HANA that were created prior to February 2018 will continue to treat 
SAP HANA as a relational source.
Given the completely different behaviour between the two approaches, 
it’s not possible to switch an existing report from one approach to the 
other.
While in Preview, reports created using the new multi-dimensional 
approach can’t be published to the Power BI Service.  Doing so will result 
in errors when opened within the Service.

Open and save performance improvements

There’s been improvements made to Power BI Desktop’s performance when opening and saving files, especially when your files are quite large.  In 
some cases, you can see between a 40% and 60% performance improvement.

“Show items with no data” improvements

Work has been undertaken to improve the ‘Show items with no data’ feature.

DirectQuery performance improvements

This latest update includes a large number of improvements to the performance of reports using DirectQuery.  Microsoft expects some improvement 
to many queries and substantial improvement in particular cases.  The key performance improvements are:

 • Combining additive and non-additive aggregates into single query.  Power BI will now combine both additive aggregates (e.g. SUM, MIN) and  
  non-additive aggregates (e.g. DISTINCTCOUNT) into a single SQL query to the underlying source, rather than sending two queries.  This will  
  improve the performance of any visual containing both DISTINCTCOUNT and another additive aggregate
 • Improved handling of queries with a large number of literals.  The performance of any query involving a large number of literals has been  
  improved, such as queries that involve measure filtering, TopN filtering, or bi-directional relationships
 • Use of a single SQL query rather than multiple for some visuals and calculations.  Power BI used to send several SQL queries using   
  DISTINCTCOUNT for certain kinds of visuals and calculations.  For example, this could occur when using bi-directional relationships, or using  
  a quick measure, or in a measure using CALCULATE of DISTINCTCOUNT.  Now, a single SQL query is sent, resulting in an order of magnitude  
  improvement in some cases
 • Optimised queries to reduce post-aggregation.  In some scenarios, Power BI used to send SQL queries at a lower granularity than needed  
  for the visual and perform post-aggregation locally.  Now, it pushes all the joins and post-aggregations down to the underlying source,  
  improving performance.  For example, this applies to any visual where the underlying measure column is directly related to only a subset of  
  the columns being grouped by (and there is some non-trivial filtering), and most quick measures
 • Optimised use of TREATAS in calculations.  Power BI will optimise common patterns for the use of TREATAS in calculations to combine into a  
  single query.  For example, a visual containing the following two measures:
  CALCULATE(SUM(Table1[Col1], TREATAS(VALUES(Table2[Col3]), Table1[Col3])) and CALCULATE(MIN(Table1[Col2],    
  TREATAS(VALUES(Table2[Col3]), Table1[Col3])) would previously have resulted in two separate SQL queries, but will now result in just one
 • Fewer SQL queries are sent when there is multi-column tuple filtering.  For example, if Include or Exclude is used to filter out data items based  
  on multiple columns, e.g. to exclude the items (“USA”,”Old”) and (“France”,”Young”) from a visual.
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Some visible improvements you’ll see are:

 • For visuals that have ‘Show items with no data’ enabled, you’ll see major performance improvements for visuals with columns or filters  
  directly related in the model (as in they have one to many relationship).  On average performance has been improved by 100%
 • Filters related to columns that have ‘Show items with no data enabled’ now respect model bidirectional cross filtering.

Persistent filters control for upcoming Power BI Service feature

Alright, so this one is really for Power BI Service, but it’s worth noting 
that Microsoft is planning to release a new feature for reports in the 
Power BI service very soon where Power BI will persist filters, slicers and 
other data view changes as your report consumers last left them.  This 
will be unique to each of them, so they will no longer need to spend their 
valuable time setting up or filtering the reports on every visit.  Instead,  

they can pick up right where they left off.  Now that will be cool!
In order to give you more control over this feature when it does get 
released in the Service, Microsoft has added a new option under Report 
settings called “Persistent Filters” in this month’s release.  The feature is 
on by default, but you can choose to disable it here.

Consulting Services quick link

You can bet your bottom dollar we are looking into this one!  From the new ‘Consulting Services’ resource on the ‘Help’ Ribbon, you can now explore 
a wide variety of curated fixed price, fixed scope and fixed duration consulting services.  Sign SumProduct up!  We’re up for this!

More next month, no doubt.

It’s not just Power BI Desktop that gets a fresh lick of paint.  The Power BI Service and Mobile Apps have had updates too.  These revisions include:

 • Share and Favorite (sic) Power BI reports
 • OAuth2 and DirectQuery single sign-on support for Azure SQL Database and Data Warehouse
 • In-region auditing
 • General Availability of SharePoint online report web part
 • Custom visuals admin control
 • Scheduled refresh support for Azure Analysis Services
 • January update for On-premises gateway
 • Improved hyperlink support on Mobile.

Let’s look at each in turn.

February Updates for Power BI Service and Mobile Apps
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Share and favorite (sic) Power BI reports

Dashboards and reports provide two distinct ways of presenting information in Power BI, each with their own advantages.  Since the product was 
launched, dashboards have been the primary way to share content with others in the service.  However, this has now been extended to encompass 
reports.
The feature works just like its dashboard sharing counterpart.  All you have to do is simply head to any report, look for the ‘Share’ option in the top 
bar and select it to launch sharing.

In-region auditing

Commencing this year, dataset owners can now choose to use AAD 
OAuth credentials when connecting the Power BI service to Azure SQL 
databases.  With this update, Power BI can leverage all the security 
features of AAD when connecting to Azure SQL – including multi-
factor authentication, when it has been duly configured.  The OAuth  

 
authentication method is supported when connecting for both import 
and DirectQuery.  In addition, when connecting to these data sources via 
DirectQuery, the Power BI service can now be configured to connect to 
the data source with the end users’ credentials, allowing the service to 
respect the security settings configured at the data source level. 

After you share a report, it will appear in their ‘Shared with me’ page and they will also receive an e-mail provided you have selected that option.
In addition, the latest updates have simplified finding and accessing Power BI content by allowing you to mark-up selected reports as “favorites” (sic), 
paralleling the functionality in existing dashboards.  To create such reports, choose the ‘Favorite’ option with the star on the top bar of a report and 
it should immediately appear in your ‘Favorites’ content list.  This also applies to the Power BI mobile app too.   

Commencing this year, dataset owners can now choose to use AAD 
OAuth credentials when connecting the Power BI service to Azure SQL 
databases.  With this update, Power BI can leverage all the security 
features of AAD when connecting to Azure SQL – including multi-
factor authentication, when it has been duly configured.  The OAuth 

authentication method is supported when connecting for both import 
and DirectQuery.  In addition, when connecting to these data sources via 
DirectQuery, the Power BI service can now be configured to connect to 
the data source with the end users’ credentials, allowing the service to 
respect the security settings configured at the data source level. 

OAuth2 and DirectQuery Single Sign-on Support for Azure SQL Database and Data Warehouse

Microsoft has now announced the General Availability of embedding 
interactive Power BI reports in SharePoint Online.  This feature enables 
SharePoint authors to easily embed Power BI reports directly on their 

page without any code.  Since the introduction of this feature almost a 
year ago, significant improvements have been made apparently based 
upon user feedback (so keep sending them feedback!!).

Announcing General Availability of SharePoint Online report web part

IT administrators will now have more control over 
whether users in their organisation may view reports 
containing custom visuals.  However, as at the time of 
writing, this setting cannot be limited to specific groups; 
choices made will apply to the entire organisation. 

Custom visuals admin control
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There’s another update for Get & Transform this month — albeit just the one.   This update is available as part of an Office 365 subscription.
One of the most frequent requests from users using the Azure SQL Database and Azure SQL Data Warehouse connectors in Excel has been to leverage 
Azure Active Directory Authentication in order to connect to Azure services.
With this update, Microsoft introduced its own "Microsoft Account" option within the Credentials dialog for the Azure SQL Database and Azure SQL 
Data Warehouse connectors, allowing you to authenticate using their Azure Active Directory account credentials.

Are you often COMBIN the Excel functions to see how many subsets you can make?  This function returns the number of combinations for a given 
number of items (i.e. the number of distinct subsets of items where order is unimportant).  You should use COMBIN to determine the total possible 
number of groups for a given number of items.

The COMBIN function employs the following syntax to operate:

COMBIN(number, number_chosen)

The COMBIN function has the following arguments:

 • number: this is required and represents the number of items
 • number_chosen: this is also required.  This denotes the number of items in each combination.

It should be further noted that: 
 • numeric arguments are truncated to integers
 • if either argument is nonnumeric, COMBIN returns the #VALUE! error value
 • if number < 0, number_chosen < 0, or number < number_chosen, COMBIN returns the #NUM! error value
 • a combination is any set or subset of items, regardless of their internal order.  Combinations are distinct from permutations, for which the  
  internal order is significant
 • the number of combinations is as follows, where number = n and number_chosen = k:

where:

and n! denotes n x (n-1) x … x 2 x 1.

February Update for Get & Transform (Excel 2016) / Power Query (Excel 2010 
and Excel 2013)

The A to Z of Excel Functions: COMBIN
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Upcoming SumProduct Training Courses
Location Course Date Duration

Sydney Visual Basic for Applications 12 Mar 2018 1 day

Sydney Power Pivot, Power Query and Power BI 19 - 21 Mar 2018 3 days

Adelaide Financial Modelling 5 - 6 Apr 2018 2 days

Sydney Excel Tips & Tricks 23 Apr 2018 1 day

Sydney Financial Modelling 26 - 27 Apr 2018 2 days

Melbourne Excel Tips & Tricks 30 Apr 2018 1 day

Melbourne Financial Modelling 1 - 2 May 2018 2 days

Melbourne Power Pivot, Power Query and Power BI 7 - 9 May 2018 3 days

Auckland Financial Modelling 21 - 22 May 2018 2 days

Please see our example below: 

This function returns the number of combinations (with repetitions) for a given number of items.  If this sounds a little confusing, think of it this 
way: you have a number of balls in the bag, each with a different number on it.  You take one ball out at random, record its number, then replace 
it.  You do this number_chosen times.  Ignoring the sequence of the numbers selected, COMBINA deduces the number of different combinations.  
Since there is replacement, number_chosen may exceed the number too.

For example, the selecting three numbers from a bag of balls numbered 1 to 4 would have the following 20 combinations:

111, 112, 113, 114, 122, 123, 124, 133, 134, 144, 222, 223, 224, 233, 234, 244, 333, 334, 344 and 444.

The COMBINA function employs the following syntax to operate:

COMBINA(number, number_chosen)

The COMBINA function has the following arguments:

 • number: this is required and must be greater than or equal to zero.  Microsoft states that number must be greater than or equal to  
  number_chosen but this requirement does not seem to hold in practice (see my examples below)
 • number_chosen: this is also required and Must be greater than or equal to zero too
 • non-integer values for both arguments will be truncated.

It should be further noted that: 

 • If the value of either argument is outside of its constraints, COMBINA returns the #NUM! error value
 • If either argument is a non-numeric value, COMBINA returns the #VALUE! error value
 • The following equation is used:

 

 • In the equation above, N is number and M is number_chosen.

Please see more examples below: 

The A to Z of Excel Functions: COMBINA
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Link to Others
These newsletters are not intended to be 
closely guarded secrets.  Please feel free 
to forward this newsletter to anyone you 
think might be interested in converting to 

“the SumProduct way”.

If you have received a forwarded 
newsletter and would like to receive 
future editions automatically, please 

subscribe by completing our newsletter 
registration process found at the foot of 
any www.sumproduct.com web page.

Any Questions?
If you have any tips, comments or queries 
for future newsletters, we’d be delighted 
to hear from you. Please drop us a line at 

newsletter@sumproduct.com.

Our Services
We have undertaken a vast array of 
assignments over the years, including:
·  Business planning
·  Building three-way integrated   
 financial statement projections
·  Independent expert reviews
·  Key driver analysis
·  Model reviews / audits for internal   
 and external purposes
·  M&A work
·  Model scoping
·  Power BI, Power Query & Power Pivot
·  Project finance
·  Real options analysis
·  Refinancing / restructuring
·  Strategic modelling
·  Valuations
·  Working capital management
If you require modelling assistance of any 
kind, please do not hesitate to contact us 
at contact@sumproduct.com.

Training
SumProduct offers a wide range of 
training courses, aimed at finance 
professionals and budding Excel experts. 
Courses include Excel Tricks & Tips, 
Financial Modelling 101, Introduction to 
Forecasting and M&A Modelling. 

Drop us a line at training@sumproduct.com 
for a copy of the brochure or download  
it directly from
http://www.sumproduct.com/training.

Check out our 
more popular 
courses in 
our training 
brochure:

Key Strokes
Each newsletter, we’d like to introduce you to useful keystrokes you may or may not be aware of.  This month we focus on the Right 
Arrow key (I hope we are right):

There are over 540 keyboard shortcuts in Excel.  For a comprehensive list, please download our Excel file a
www.sumproduct.com/thought/keyboard-shortcuts. Also, check out our new daily Excel Tip of the Day feature on the 
www.sumproduct.com homepage.

Keystroke What it does

Right Arrow Move right one cell

ALT + Right Arrow Forward (hyperlink navigation)

CTRL + Right Arrow Select the last cell in the area right

SHIFT + Right Arrow Extend selection right one cell

CTRL + ALT + Right Arrow Intel Chipset: Turn screen -90 degrees; else: move active cell to next non-adjacent area 
within selection

CTRL + SHIFT + Right Arrow Extend selection down to last cell in area right

SHIFT + ALT + Right Arrow Group

Wellington Financial Modelling 24 - 25 May 2018 2 days

Darwin Financial Modelling 4 - 5 Jun 2018 2 days

Sydney Power Pivot, Power Query and Power BI 18 - 20 Jun 2018 3 days

Sydney Financial Modelling 25 - 26 Jun 2018 2 days

Melbourne Excel Tips & Tricks 2 Jul 2018 1 day

Melbourne Financial Modelling 3 - 4 Jul 2018 2 days

Melbourne Power Pivot, Power Query and Power BI 17 - 19 Jul 2018 3 days

Sydney Excel Tips & Tricks 13 Aug 2018 1 day

Sydney Financial Modelling 15 - 16 Aug 2018 2 days

Brisbane Excel Tips & Tricks 27 Aug 2018 1 day

Brisbane Financial Modelling 28 - 29 Aug 2018 2 days

Sydney Power Pivot, Power Query and Power BI 10 - 12 Sep 2018 3 days

Perth Financial Modelling 17 - 18 Sep 2018 2 days

Perth Power Pivot, Power Query and Power BI 19 - 21 Sep 2018 3 days
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