
•	 With the demise of Excel’s Chart Wizard post-Excel 2003, the fastest way to set up a chart in Excel is to highlight the data and press the F11 	
	 function key (see last month’s Key Strokes) and then make further changes using the ‘Design’ and ‘Format’ tabs from the Ribbon (and ‘Layout for 	
	 Excel 2007 and 2010) or use ALT + F1 to add the chart to the current sheet

•	 To change the colours and font of all text in the chart, simply select the entire chart and then make your choices on the ‘Home’ tab of the Ribbon 	
	 (do note though that all text will resize consistently)

•	 Include chart data in a Table (i.e. put chart data together first, then highlight the data and Insert Table (ALT + N + T)).  Creating a chart from this 	
	 Table will allow you to add or remove entries such that the dependent chart will automatically update

•	 For Excel 2003 and earlier versions, to stop charts “dropping off a cliff” for missing data type in #N/A – Excel won’t plot these ‘errors’, viz.

•	 Sometimes you may wish to hide the chart data.  With Excel’s default settings, charts will appear blank if data is hidden.  To counter this issue, 	
	 right-click on the chart data points, select ‘Select Data…’ from the shortcut menu and then press the ‘Hidden and Empty Cells’ button

NEWSLETTER #57 - August 2017

Are you charting the unknown with your 
graphing skills? Well, we thought there was just so much Power BI last month it was time to get  
back to basics.  Everyone loves a chart.  So how about a good hard look on charts this month and next?  Well, that’s exactly what we 
decided to do!

It’s not all about pretty pictures though.  We provide a half-term report on Excel UserVoice and we still have our Power 
Query Pointers, more Power Query / Power BI updates and our continuing series of Keyboard Shortcuts and the A to Z of 
Excel Functions (have we BIT off more than we can chew?).  There’s even time for a Reader’s Question.

Until next month.
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•	 Then, in the second dialog box, check “Show data in hidden rows and columns”:

•	 If you need to copy charts, the easiest way is to put the chart data and the chart on the same separate worksheet and then copy the worksheet.  	
	 Once enough copies are made, cut and paste the charts and chart data back to where you require them in the rest of the workbook and delete 	
	 any surplus worksheets.  This method avoids a few glitches otherwise prevalent in chart copying.

This newsletter is intended to simply introduce some simple charting tricks.  But these are the tips of the iceberg.  For more advanced 
tips and charts, why not visit our website, e.g.

Waterfall charts	  				    www.sumproduct.com/thought/waterfall-charts 

Tornado charts	  				    www.sumproduct.com/thought/tornado-charts 

Dynamic charts	  				    www.sumproduct.com/thought/onset-of-offset 

Hyperlinking to chart sheets	  			   www.sumproduct.com/thought/hyperlinking-chart-sheets

Advanced Charting Tips
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Many analysts and accountants need to keep a rolling budget going (we have written about the way to do this a few times), but few articles seem 
to exist about to make charts automatically update for the latest information.  We keep getting asked if there are non-VBA solutions and the simple 
answer is, of course there are!  And here’s one…

Before starting though, let’s back up a step and give you a general tip about chart data.  Consider you had some financial data similar to the following:

Highlighting the data (here, cells B2:C9) and using the keyboard shortcut ALT + F1 produces a quick and dirty chart, viz.

Believe it or not, that’s not the chart tip (because we’ve already mentioned it in this newsletter!), although many people are impressed when they 
see that for the first time.  However, the novelty starts to wear off, when you add the next period’s data and nothing happens:

Chart Data and Tables
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Most of us have been there and bought that t-shirt.  Therefore, with a heavy heart, you right-click on the chart and choose ‘Select data…’

and from the resulting dialog box you update the date and sales references:

Surely there is a better way?  Yes there is – and don’t call me Shirley…

Let’s back up.  After entering the data and before creating the chart, convert the data range to a Table (CTRL + T, or from the ‘Insert’ tab on the 
Ribbon, choose ‘Table’ from the ‘Tables’ section):
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Ensure the ‘My table has headers’ check box is ticked in the ensuing dialog box:

Now add a chart as before, but this time, when additional data is added the chart automatically updates:

How good a trick is that?  Therefore, I have a rule with chart data: always put it in a Table before creating the chart.  It just makes life easier.

A “rolling” chart is just like a rolling budget: it displays the last x months (typically, the past 12 months), but keeps up to date automatically.  The idea 
is similar, but not quite the same, as we do not wish to extend the range, simply keep moving the 12 months along the time axis.

To do this, you still create a Table (mine is labelled ‘Chart_Data’):

Rolling Charts
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Then, calculate the latest date in the formula by typing =MAX( and then highlighting cells F11:F28 in my example.  This gives the formula

=MAX(Chart_Data[Date])

(the syntax will be slightly different if you are still using Excel 2007).  The great thing about this formula expressed in this way is as the dates extend, 
the range will update automatically.  Let’s use this formula in the final row of a second table (check out cell L22 in the image below):

To populate the rest of the data in column L, in cell L21 I write the following formula

=EDATE(L22,-1)

This generates the same day of the month one month earlier.  I then copy this formula into cells L11:L20.  Finally, I use a LOOKUP formula to derive 
the Sales data.  For example, the formula in the final period here is

=LOOKUP(L22,Chart_Data)

Here, the LOOKUP formula will always look for the date in the first column of Chart_Data and return the value in the final (second) column.  You 
should note that this chart data table is always 12 rows deep for a 12-month look-back.  If you need a rolling budget for a different duration, simply 
amend the number of rows accordingly.  It is this table that populates the chart:

Pretty cool, eh?

From Left Using Second Table

Want to know an easy way to filter your PivotTable report without having to use the drop-down lists to find items you want to filter?  Slicers are easy-
to-use filtering options that contain a set of buttons that enable you to quickly filter the data in a PivotTable report.  Multiple slicers can be linked to 
a PivotTable report with the filters clearly defined so that the data is easily identifiable. 

Using Slicers with Charts
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Let’s have a look at using slicers with some examples.

The first thing to do is create a PivotTable from your data.  For example:

Select the fields you would like to see in the PivotTable and drag them into the area boxes below the fields.  In this example, I’ve dragged ‘Customer 
Name’ into the ‘Rows’ area, ‘Product Category’ into the ‘Columns’ area and ‘Amount’ into the ‘Values’ area:

The PivotTable appears as follows:
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With the cursor in the PivotTable (as pictured), you can add a slicer to filter the data based on another selection available in the data.  All you have 
to do is select the ‘Slicer’ option in the ‘Insert’ tab:

A list of available slicers ensues:

Having selected ‘Cust Area’, a slicer will now appear next to you PivotTable as follows:

Note that this field does not have to be in the 
PivotTable – this provides you with more ways to 
‘slice’ your data and a chart can be made from 
the resulting table.

It doesn’t have to be just one slicer.  You can 
repeat the above process and add another, such 
as ‘Cust Group’:
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Using the ‘Cust Group’ slicer you can select ‘Pharmacy’ which will update the PivotTable to show only customers that are in the ‘Pharmacy’ category.  
You can use the ‘Cust Area’ slicer simultaneously to view the ‘SA’ Pharmacy sales.

The idea can be extended further.  As well as using multiple slicers with one PivotTable we can also have multiple PivotTables being filtered with one 
or more slicers.  Let’s see how this might work.

First, add another PivotTable based on the same data source (shared data).  Then, consider adding in a PivotChart by selecting ‘PivotChart’ on the 
‘Insert’ tab too:

A selection of charts will appear, e.g.
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In seconds, you can create a chart such as the following:

At this stage, you will notice that the slicer is not connected to either the second PivotTable or PivotChart.  We need to ensure that the slicer is 
interacting with both PivotTables.  To do this, right-click on the slicer and select ‘Report Connections’:

This will bring up a list of PivotTables and PivotCharts in your workbook, albeit labelled rather randomly.  Select the PivotTables you have just created 
– you can see which ones they are based on the ‘Sheet’, or you can find out the table name by clicking on the ‘Analyze’ tab on the Ribbon.  The table 
name will be shown under the ‘PivotTable’ section:

Selecting ‘OK’ allows your PivotTables and PivotChart to interact with the slicer.  You can continue; it doesn’t take much more effort to add a 
‘Timeline’ which will allow you to view your data based a selected date – simply select ‘Timeline’ which is shown under the ‘Insert’ tab on the Ribbon:

Select ‘Date’ and ‘OK’:
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You should now have a timeline and a slicer that are interacting with two PivotTables and a PivotChart viz.

With a little rearranging and formatting, you can have a very powerful interactive dashboards in minutes.

The website www.excel.uservoice.com has been around a while now and it is clearly becoming effective.  The idea was that regular Excel users could 
suggest improvements to the world’s second-best software for anything and, if you get enough votes in the bag, Microsoft would sit up and take 
notice.  The first six months of 2017 has had some great successes we thought we would share with you:

Excel User Voice Finding its Voice

Personalise the default PivotTable layout (votes at time of printing: 561)

Excel 2007 introduced the new Compact Form of PivotTables and made the default for all future PivotTables.  This went down about as well as a case of 
the mumps. Users asked whether they could personalise their default settings rather than let Redmond rule the roost.

Microsoft listened and there are now two ways you can adjust the layout settings for the PivotTable defaults.  One way is to simply click the newly added 
‘Edit Default Layout’ button under the File -> Options menu to display the Edit Default Layout dialog.  Here you can make changes to your layout options 
and it also includes all of the settings in the ‘PivotTable Options’ dialog viz.

You can also import a layout from a PivotTable already in your workbook and customise the layout from this base.  This is particularly useful if you have 
a layout you’d like to use all the time: simply open the ‘Edit Default Layout’ dialog, click anywhere within a PivotTable in your workbook and then click 
the ‘Import’ button.
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Copy-Paste Clipboard Persistence (224 votes)

When copying a cell (CTRL + C), if you started typing in another cell in 
Excel, this would cancel the copy, i.e. there would be nothing to paste.  
Therefore, you would have to go back to the item to re-copy it – but not 
so anymore.
Starting with the Excel releases available in June, Excel “kept” your copied 
items for longer.  Now you can copy your cells, and before you paste, you 
can still do other tasks like typing, inserting cells or running a bath.
Based on customer feedback, the dotted “Marquee” (the so-called  

“dancing ants”) stay active for much longer so that you can type, add  
formatting or many other things before the paste operation.  Microsoft has 
also made both the ‘Insert’ and ‘Insert Copied Cells’ commands available 
after the copy operation.  
Just as an aside, if you want the Marquee to disappear, you can use the 
ENTER key to perform the paste operation, or after the paste, you can 
press the ESC key to cancel the copy.

Add Superscript and Subscript Icons (372 votes)

Users noted that Word has had direct access (with icons) on the Ribbon for subscripting and superscripting characters for some time, but Excel can do 
so only via the Home -> Font menu item. Given scientists, engineers and people with good eyesight need to use subscript and superscript characters, a 
request was made to have these available so that they may be added to the ‘Customize QAT’ feature.

Co-authoring (215 votes)

In Word and PowerPoint, it’s been possible to collaborate from the desktop as well as online.  However, in Excel, whenever anyone opens a document, 
others get locked out of editing and can only view the file. 

Microsoft claims to have done this and indeed they are in build 1705, although we note for builds 1706 onwards (i.e. for those of you that keep your Excel 
up to date), they appear to have vanished again.  Microsoft knows though – and we are sure this will be fixed soon!

We mentioned in May’s newsletter that Microsoft had announced that it is enabling co-authoring in Excel on Windows desktops for Office Insiders Fast.  
This allows you to know who else is working with you in a spreadsheet, see where they’re working and view changes automatically within seconds.  It 
is still being tested, so Microsoft encourages early adopters to continue using feedback channels to improve the experience before making it available 
more broadly.  Co-authoring is already available in Excel Online, Excel on Android, too.  

To use co-authoring in Excel on Windows desktops, you must:

	 •	 Be an Office 365 subscriber and opted into the Fast level of the Office Insider program 
	 •	Have Version 8017.1000 or later installed
	 •	 Save your file to SharePoint Online, OneDrive or OneDrive for Business
	 •	Work with another user who is on a co-author enabled platform
	 •	 Share your file with others in the Insiders program.

It should be stressed that you do not require the updated OneDrive for Business sync client (that will be a relief to all of those who have absolutely no 
idea what I am talking about).  As long as the file lives in the Cloud, co-authoring will work.  It does not matter if you are using a sync client or not.  If you 
load from your local sync folder instead, Excel will still realise it comes from the Cloud and co-authoring should still work.  (When we say “Cloud” by the 
way, we mean SharePoint Online, OneDrive or OneDrive for Business.)

Furthermore, you can co-author with others not in the Insiders program.  However, they will not be able to take advantage of co-authoring on Excel on 
Windows desktop and must use another supported version (Excel Online, Excel on Android or Windows Mobile) instead.
As mentioned above, AutoSave is critical to this functionality.  In Excel 2016 for Office 365 subscribers, you may have noticed AutoSave in the upper-left 
corner.  AutoSave is enabled when a file is stored on OneDrive, OneDrive for Business, or SharePoint Online.  It automatically saves your changes to 
the cloud as you are working, so be careful.  The idea is that if other people are working on the same file, AutoSave lets them see your changes in just a 
matter of seconds.
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To use AutoSave in Excel in this way, you must:

	 •	 Be an Office 365 subscriber and opted into the Fast level of the Office Insider program
	 •	Have Version 8017.1000 or later installed (as above)
	 •	Use .xlsx, .xlsm, or .xlsb files. If your file isn’t in this format, open the file and then click File > Save As > Browse > Save as type.   
		  You should change the format to .xlsx, .xlsm, or .xlsb for this to work
	 •	 Save your file to a shared location.

In Excel on Windows desktops, Office 365 subscribers might notice an 
AutoSave option in the upper-left corner.  AutoSave is enabled when a file 
is stored on the Cloud.  It automatically saves your changes to the cloud as 
you are working.  If other people are working on the same file, it lets them 
see your changes almost instantly.  When co-authoring with other people, 
AutoSave will save every few seconds (that’s a little scary…).  This time may 
vary depending upon what you are working on.

To get started, upload a workbook to a supported, shared Cloud location 
such as SharePoint Online, OneDrive or OneDrive for Business.  Then, you 
will need to share your workbook with others.  If you clicked the ‘Share’ 
button, people will receive an email message inviting them to open the 
file.  They can click the link to open the workbook, a web browser will 

open, and the workbook will open in Excel Online.  To use co-authoring in 
Excel on Windows desktop, click Edit Workbook > Edit in Excel. However, 
these users will need a version of Excel that supports co-authoring too. 

At the time of writing, co-authoring is currently supported for all customers 
in Excel Online, Excel on Android and Excel Mobile on Windows.  Co-
authoring is currently available in Excel on Windows desktops for Office 
365 subscribers in the Fast level of the Office Insider program only.  It’s 
also available in Excel on iOS for Office Insiders too.  If the people you are 
collaborating with you do not have a supported version of one of these 
apps, they can co-author using Excel Online by clicking Edit Workbook > 
Edit in Browser instead.

Pictures in the Header or Footer in Excel for Mac (698 votes)

Mac users will know this is just about the only thing you haven’t been able to do on a Mac (er, just kidding!).  Clearly, this has been a bone of contention 
with so many votes.  As of the 11 July update (version 15.36), you can now insert images in the headers and footers on Excel for Mac.

Page Break Preview in Excel for Mac (42 – yes, that’s right, 42 – votes)

Douglas Adams said that the answer to the meaning of life, the universe and everything is 42.  It would seem so for Excel.  Just to show it’s quantity not 
quality that gets ideas across, page break preview is now available for the Mac.  You can now find the ‘Page Break Preview’ button next to the ‘Page 
Layout View’ button on both the Ribbon and in the status bar.  Thanks to B. Gates who suggested this one (I’m joking…).

Create and Modify Freeze Panes in Excel Online (161 votes)

The ability to Freeze Panes, Freeze Top Row, Freeze First Column has been available since May.

Select All in Excel Online (175 votes)

It’s amazing to think what we take for granted in the desktop version of Excel.  In February, Excel Online began to allow you to ‘Select All’ cells in a range, 
a table, or sheet by using CTRL + A or by clicking the triangle at the top left corner of the grid.
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Format Painter in Excel Online (154 votes)

This elementary feature became part of the furniture in February’s updates too.

Find and Replace in Excel Online (333 votes)

Still couldn’t find what you’re looking for?  It was only at the beginning of this year that you could actually find and replace items in Excel Online (although 
‘Find’ has been around a while).

Add Support for Shapes in Excel Online (68 votes)

Another with a smaller number of votes, it’s been recognised that Excel Online has not allowed you to view or edit shapes.  As of 30 June, shapes may 
now be viewed; editing and inserting will be coming to a theatre new you soon too.

Apple Pencil with Excel for iPad and iPhone (17 votes)

Now we are getting to the popular stuff.  The Apple Pencil (the iPencil?) is not just a drawing tool.  It should also be used as a pointy thingy for those of 
us with fat fingers.  Microsoft agreed with the July 11 update. 

New Excel 2016 Functions to be included in Excel for iPad and iPhone (3 votes)

Three votes!!  Busy times at Redmond High.  Yes, you can now use the six new functions CONCAT, IFS, MAXIFS, MINIFS, SWITCH and TEXTJOIN on your 
iPhone.  Be very aware if you start writing IFS functions on any platform, we are coming to kill you.

Add a Number Keypad in Excel for Android (24 votes)

Surprise, surprise, more people use Excel on Android devices than iPhones.  New to the late June update, Microsoft has added a virtual persistent 10-key 
pad (that’s the numbers 0 to 9 for us less tech savvy people) that stays visible on the screen until it is disengaged deliberately.

Remember this?  Microsoft doesn’t – well not yet anyway.  30 times more popular than adding new functions to an iPhone, will Microsoft please take a 
look?  This UserVoice item was instigated by our very own Liam Bastick – but please don’t hold that fact against this good idea.  

To facilitate co-authoring, Microsoft has decided that AutoSave must be switched on by default.  We don’t have an issue with that.  We just want a 
master switch to be able to turn it off, given having AutoSave switched on will cause problems for those of us who like to experiment.  If you agree, please 
vote for it here.  Let’s hope we can report on this fix in our next roundup!

One Last Thing: AutoSave (90 votes)

You can check these functions out in our March 2016 newsletter or else in the ‘Thought’ section of our website at www.sumproduct.com/thought/
excel-2016-functions-and-features.
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How can I obtain just the last few words in a sentence typed into an Excel cell?

Each month we’ll reproduce one of our articles on Power Query (Excel 
2010 and 2013) / Get & Transform (Excel 2016) from www.sumproduct.
com/blog.  If you wish to read more in the meantime, simply check out 
our Blog section each Wednesday.  This month we look at extracting 
metadata.

So far in this series, we have concentrated on how to use Power Query as 
a standalone tool. It’s clearly a useful ETL (Extract, Transform and Load) 
tool.  Well thought-out features allow data to be filtered, manipulated 
and merged.  So far, our examples have been loaded into an Excel 
worksheet, but loading to the Excel data model instead allows further 
modelling and analysis by Power Pivot.   

Power Pivot can fine tune the Excel data model and then perform 
calculations so that the data is ready to be displayed in PivotTables, charts 
or grids, or in a visualisation tool like Power View or Power BI.  Power 
Pivot can create relationships between tables, and create formulas and 
KPI’s (Key Performance Indicators).  

Let’s try an example to demonstrate the interaction.  

A quick glance at the drop down from the ‘From Database’ tab in Power 
Query reveals a large selection of different kinds of databases that can 
be accessed in order to extract data:

Reader’s Question: Famous Last Words

Power Query Pointers

Advice

It is easy to extract characters from a string if you know the precise number of characters to extract.  LEFT, RIGHT and MID are just some of the functions 
you might use.  The problem is, how do you extract the last x words from a sentence when the length of each word is variable?  

Let’s consider the following examples:

Cell C2 in the example above contains the following formula:

=TRIM(RIGHT(SUBSTITUTE(A2," ",REPT(" ",LEN(A2))),B2*LEN(A2)))

So how does this work?

	 •	 LEN(A2) calculates the length of the text string as a number of characters
	 •	REPT(" ",LEN(A2)) repeats the space “ “ so that it is the same length as the sentence (LEN(A2))
	 •	SUBSTITUTE(A2," ",REPT(" ",LEN(A2))) replaces all of the spaces in the text string and inserts a block of spaces equal to the length of the original 	
		  text string in cell A2.  This has the effect that if you separate out the original sentence into blocks of characters with the same numbers as the 	
		  original sentence you will have one and only one word in each block – the rest of the characters will be spaces
	 •	RIGHT(SUBSTITUTE(A2," ",REPT(" ",LEN(A2))),B2*LEN(A2)) therefore takes the last B2 number of blocks, where B2 represents the number of 	
		  “last words” to be captured.  In effect, this takes the last B2 words with lots and lots of spaces
	 •	TRIM(RIGHT(SUBSTITUTE(A2," ",REPT(" ",LEN(A2))),B2*LEN(A2))) then removes all of the excess spaces leaving you with the final B2 words.  	
		  Success!

Easy when you know how – and now you do…
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Choosing the ‘From Access Database’ option allows us to browse for the database.  Having selected the intended file, the navigator screen lists all of 
the tables in that database.  Therefore, we can choose to preview ‘ACCT_Order_Charges’:

The table could be loaded as is, but instead let’s elect to ‘Edit the ACCT_Order_Charges’ query.  The Query Editor should be familiar to regular 
readers, and it allows us to remove data – so let’s “discount” the ‘Discount’ column. 

In order to do this, either select the ‘Discount’ column and right-click to find the ‘Remove’ option, or else use the ‘Remove Column’ option on the 
‘Home’ tab viz.

Then, you can use the ‘Close and Load’ option from the ‘File’ tab or the ‘Home’ tab, but in either case make sure to tick the ‘Add to data model’ box.  
Also, choose the ‘Connection Only’ option, which is also useful for merging tables / queries – as in this case we don’t need to see the table in the 
workbook.
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In Power Pivot, go to the Manage (data model) option; ‘ACCT_Order_Charges’ is visible in the ‘Workbook Queries’ pane:

Choosing to ‘Manage’ allows us to view the ‘ACCT_Order_Charges’ table in detail, ready to refine the data further by adding calculated columns and 
creating and managing relationships with other tables in the model.

So does this really mean we can edit the table in Power Query and Power Pivot, or are there any problems to look out for?  Let’s explore.

Having started to refine the Excel model in Power Pivot, you are likely to find that changes to the model are necessary to facilitate the features that 
you want to add.  The good news for users of Excel 2016 is that since Power Query has been fully integrated into the ‘Get & Transform’ section, there 
is no choice between using Power Pivot or Power Query. In earlier versions of Excel 2013, and in Excel 2010, it is possible to corrupt the Excel model 
by making some types of changes in Power Pivot. The current version of Excel 2013 stops us from making these changes in Power Pivot.  And that is 
a good thing.

Returning to the example, let’s change the table name to make it more user friendly:
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So, having received the message in the screen shown above, we are 
directed back to Power Query in order to rename the table.  The reason 
that we are stopped from changing the name here is that in previous 
versions of Excel 2013 and 2010 users could change the name in Power 
Pivot which then broke the link between Power Query and Power Pivot.  
Therefore, there are some actions to be avoided in Power Pivot if the 
Excel model has been created in Power Query:

	 •	Do not change a table name in Power Pivot
	 •	Do not rename an imported column in Power Pivot
	 •	Do not delete an imported column in Power Pivot

Any of these actions could result in a broken link between Power Query 
and Power Pivot.

It therefore makes sense to clean up data as much as possible in 
Power Query, renaming and deleting as required.  Although merging 
some tables and queries in Power Query can be useful to avoid having 
unnecessary tables (more on this next week), don’t try to flatten all the 
data into one huge table.  One of the features of Power Pivot is the ability 
to manage relationships between tables, allowing keys to be constructed 
as required.  This is vital in creating accurate calculations and useful new 
columns to aid analysis of data.  As with most relationships, Power Query 
and Power Pivot work well together when they are allowed to do what 
they are best at.  

More next time!

July saw in the usual myriad of new updates for Power BI: it's clear the Power BI Desktop train is not slowing down anytime soon.  There were many 
updates to reporting and data connectivity.

In summary, the following updates have been released:

July 2017 Updates for Power BI Desktop

Report View:

	 •	New table and matrix visuals are now generally available 
	 •	 Renaming fields in visuals 
	 •	 Custom visuals store integration 
	 •	 Relative date filters 
	 •	 Responsive layout for visuals (preview) 
	 •	New waterfall chart option - breakdown 
	 •	 Custom visual updates:
	 	 	 o	 Drilldown Choropleth 
	 	 	 o	 Drilldown Cartogram 
	 	 	 o	 Drilldown Player 
	 	 	 o	 Certified custom visuals

Analytics and Modelling:

	 •	Quick Measures from the community
	 •	 Star rating
	 •	 Concatenated list of values
	 •	 Bidirectional cross filtering for DirectQuery is now generally available

New table and matrix visuals are now generally available 

The recent table and matrix visuals that were previously released in preview are now generally available.  These new visuals support cross-highlighting 
and drilling, as well as many new formatting capabilities including data bars and word wrapping. 

Now that the visuals are generally available, you’ll only see the icons for the new table and matrix visuals.  If you have a report that is still using the 
previous table and matrix visuals, you’ll be greeted by Power BI Desktop upon opening to upgrade your visuals to take advantage of all of the new 
features. 

Data Connectivity:

	 •	 Snowflake connector general availability

Query Editing:

 	 •	 Add Column from Examples further enhancements.

Let’s take a look at each of these in turn.
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There’s three more improvements to table and matrix visuals this month:

	 1.	The drill experience has been updated to make it easier to drill on either the rows or columns
	 2.	The default style for the table and matrix visual has been updated.  The new style makes it easier to read your visual and is based on Microsoft’s  
		  best practices whitepaper.  You can always go back to the “None” option in the formatting pane if you prefer the old appearance

	 3.	There’s another update to word wrapping.  Microsoft now honours new lines in content, either when it’s in the data you load from your source 	
	 	 or if you specify it in a DAX function, e.g.

	 	 Measure with newline = "This is the first line" & UNICHAR(10) & "This is the second line"

Renaming fields in visuals  

You can now rename fields for a specific visual.  This allows you to give an "alias" to the column in that specific visual while leaving the actual column 
name alone.  To rename a field in a specific visual, just double click it (or right click and choose ‘rename’):

Custom visuals store integration  

The custom visuals store has now been brought into Power BI Desktop.  From the ‘Home’ tab on the Ribbon, you can open the store, browse visuals 
and add them to your Desktop.  All the custom visuals that are listed in the Office store are available directly from the Desktop:

The field will be renamed everywhere it is used in the chart, including the tooltip.  Hovering over the name in the field well will show you the original 
name if you need it for reference.  If you want to go back to the original name, you can remove the field from the chart and add it back again.  As 
always, if you want to rename the field for your entire report, instead of in a single visual, you can do that by double clicking that field in the field list.

Once you click the’ From Store’ option in the ‘Custom visuals’ group, you’ll see a dialog showing all the visuals available in the Office store.  From here 
you can browse different visual types or search by name for a visual. Click any of the visuals to go to its details page, where you can see screenshots, a 
video, an overview of the visuals, and user reviews. Once you find a visual you want to use, all you need to do is click 'Add' to include it in your report.
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Relative date filters  

Having created the relative date slicer recently, Microsoft has provided the slicer in the filter pane as well.  This same functionality you have in the 
relative data slicer is now available for date filter cards as well.

Responsive layout for visuals (preview) 

Now this one is really cool.  As a lot of our users view visuals on all manner of screen sizes, it’s important to deliver great charts on a large screen while 
preserving as much of that richness as possible on a small screen too.  To address this challenge, Microsoft has created responsive visualizations, 
which change dynamically to display the maximum amount of data and insight, no matter the screen size.  It is similar to how the Ribbon is displayed 
in different screen settings / resolutions.

or

The Very Hungry Caterpillar visual
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When your visuals are set to be responsive, they will dynamically update as you resize them, removing padding and other sections of the chart as 
necessary to make sure the most important information, the data itself, is preserved.  This is particularly powerful when created phone reports and 
mobile dashboards. 

Right now, this feature is in preview for the following visual types:

	 •	 Stacked bar chart
	 •	 Stacked column chart
	 •	 Clustered bar chart
	 •	 Clustered column chart
	 •	 100% stacked bar chart
	 •	 100% stacked column chart
	 •	 Line chart
	 •	Area chart
	 •	 Stacked area chart
	 •	 Line and stacked column chart
	 •	 Line and clustered column chart
	 •	Waterfall chart
	 •	 Scatter chart

Even though this feature is still a preview, this new option will trigger automatically, without having to enable it in the ‘Options’ dialog.  You can turn 
it on / off using the ‘(Preview) Responsive’ option in the ‘General’ card of the formatting pane:

New waterfall chart option - breakdown  

A common question when analysing data is wanting to understand why something has increased or decreased.  To make this process easier, this update 
has added a new field well option to the waterfall chart, called breakdown.  When you put a dimension field in this new bucket, Power BI Desktop will 
show you what values in that field were the big causes of increase and decrease between each neighbouring category in the waterfall chart.

By default, this feature will show you the top five differences and an 'Other' bucket that groups all the other values together.  However, you are able to 
adjust how many values you want to see before grouping into an ‘Other’ bucket in the formatting pane viz.
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Custom visual updates: Drilldown Choropleth 

This sounds like a place in Wales.  It’s not though.  Drilldown Choropleth displays each location on a map filled with a colour based on the value for each 
location.  This is similar to the Shape map preview visual in that you use your own custom map files.  This gives you control over how the map looks.  You 
can use drill to move between geographical hierarchies, showing different map files at each level:

Custom visual updates: Drilldown Cartogram 

Similar to Drilldown Choropleth, but with a “bubble look”, this map has the same custom map files and drilldown features, but displays a circle for each 
location with the size and colour based on the values specified.

Custom visual updates: Drilldown Player 

The Drilldown Player visual lets you filter or highlight your report automatically.  You can add a categorical or numeric column to the visual and press 
play to see each value from the column applied to the rest of the report.  This visual supports hierarchies as well, so you can add multiple columns to 
the visual to support playing through multiple fields.  Using the ‘Edit interactions’ feature, you can control if the player will filter or cross-highlight the 
other visuals on your report.
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Custom visual updates: Certified custom visuals 

Custom visuals can now be “certified”!  We hate to point out that “certified” means to guarantee with 100% effectiveness.  We think they are talking 
about certification!  Anyway, certified custom visuals are custom visuals that conform to the best practices of custom visuals development as defined 
by Microsoft and verified by the Power BI custom visuals certification team.  You can always tell when a company has become too large when it starts 
creating these sorts of teams (no offence intended).  These best practices range from performance to security to usability.  Once a visual has been 
certified, it can be exported to PowerPoint and will show in subscription emails.

Quick Measures from the community

The Power BI community has been busy submitting ideas for new quick measures (along with its DAX!) to Microsoft.  They have integrated two of those 
measures so far into Power BI Desktop.  You can find these two new measures under the 'Text' category in the Quick measures dialog:

Star rating

This quick measure will visualise your data as a number of stars between a given minimum and maximum for your measure.  

The following visuals have been certified so far:

	 •	 Bullet Chart
	 •	 Chiclet slicer (we like this one!)
	 •	Dual KPI
	 •	 Timeline slicer.

If you want to be certified (!), feel free to get in touch with Microsoft…
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Concatenated list of values

This quick measure will concatenate you dimensions into a comma separated list.  You can also decide how many values will be concatenated before 
truncating it with an “etc.”  Grammar guardians turn in your graves now.

Bidirectional cross filtering for DirectQuery is now generally available

Microsoft released bidirectional cross filtering for DirectQuery models as a preview a few months ago: it’s now making it generally available for everyone 
(isn’t that what “generally available” means?).  This means that bidirectional cross filtering is generally available for both Import and DirectQuery models, 
including the use of bidirectional filtering for defining row level security.  

For those who don’t know (everyone?), bidirectional cross-filtering is a new feature for SQL Server 2016 Analysis Services and Power BI Desktop that 
allows modellers to determine how they want filters to flow for data using relationships between tables.  It’s complicated, but understood, it can help 
you solve the many-to-many linking problem between tables without writing complicated DAX formulae.

When using this feature, you need to consider the performance implications and it is recommended that if you don’t understand it, it may be safer to 
play with small datasets before going crazy.

Snowflake connector general availability

With this month’s update, the Snowflake connector is now Generally Available and working in the Power BI Service via the On-Prem Data Gateway. 

The Snowflake connector can be found under the ‘Database’ category within the ‘Get Data’ dialog.  It allows you to create reports based on Snowflake 
data, either by using Import or DirectQuery modes:

If you think you can do better, start writing your own measures now!
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Add Column from Examples further enhancements

Finally, there’s added support for “a few” additional Number and Date / Time / Timezone data transformations when using “Add Column from Examples”.  
We have dug into this a little bit and all we can see is the ability to change the time to local time.  Perhaps that’s what “a few” means.

Add Column by Example

With this update, there’s a new capability to the Query Editor that allows you to create a new column by specifying a set of examples of the desired 
output.  Based upon these examples, Excel automatically detects and applies the required transformations.

This is an innovative approach to defining query steps within the Query Editor, which simplifies the process if you are still relatively new to the software, 
as you no longer need to come up with an algorithm or develop some complex logic for how to transform or extract data from other columns or how to 
define those transformations in the Query Editor.  Essentially, it’s Flash Fill for Power Query!

Split Column (by Delimiter / Number of Characters) into rows

There’s a new option in the ‘Split Column by Delimiter’ and ‘Split Column by Number of Characters transformation’ dialogs that allows you to specify 
whether to split into new columns (OK, that’s “old school”) or split into new rows.

This new option can be found under the ‘Advanced Options’ section in these two dialogs:

The June updates finally came out – in July!!  They were too late for our last newsletter, but let’s go through them here.

For this month's updates for Get & Transform (Excel 2016) / Power Query (Excel 2010 and 2013), there's eight new updates:

	 •	Add Column by Example
	 •	 Split Column (by Delimiter / Number of Characters) into rows
	 •	Basic mode for Group By operation
	 •	 Extract Text Before / After / Between Delimiters
	 •	Unpivot Only Selected Columns
	 •	Combine Files experience — ability to reference first file as example
	 •	New Go to Column in Query Editor
	 •	 SAP HANA Connector — enhancements to Parameter Input UX.

Let’s take a look at each in turn.

June 2017 Updates for Get & Transform / Power Query add-in (this time for real!)
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Basic mode for Group By operation

The new ‘Basic’ mode in the ‘Group By’ transform dialog simplifies how you may group by a single column and define a single output column.  You can 
switch between ‘Basic’ and ‘Advanced’ modes within the ‘Group By’ dialog by selecting the desired option at the top of the dialog viz.

Extract Text Before / After / Between Delimiters

Also in this update, there’s a new option to extract all text before, after or between delimiters from a Text column.  These new commands are located 
under the ‘Extract’ drop-down menu on the ‘Transform’ and ‘Add Column’ tabs on the Query Editor Ribbon:

Unpivot Only Selected Columns

Another new transform was added under the ‘Unpivot Column’s menu in Query Editor that allows you to unpivot only the currently selected columns 
in the Query Editor preview.  This generates an explicit columns list in the current step so that the same set of columns is unpivoted on future refresh 
operations (i.e. the columns to be unpivoted are cited in the M code).
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In addition to the newly added ‘Unpivot Only Selected Columns’ option, do remember you can already apply one of the following commands from the 
Unpivot Columns menu:

	 •	Unpivot Columns: This operation will unpivot all columns except the non-selected ones.  This case is optimised for scenarios where new columns 	
		  that appear in the future need to be unpivoted as well.  For example, datasets where new columns represent data for new dates (e.g. monthly sales,  
		  weekly occurrences).
	 •	Unpivot Other Columns: This operation provides the same capability as ‘Unpivot Columns’ in terms of future behaviour with respect to new  
		  columns appearing in the table.  The main difference with ‘Unpivot Columns’ is that it allows you to select the columns that should not be unpivoted.   
		  This case helps you where the number of columns that should not be unpivoted is much smaller than the number of columns that should be 	
		  unpivoted, similar to the behaviour of ‘Remove Other Columns’ compared to ‘Remove Columns’.

Combine Files experience — ability to reference first file as example

‘Combine Files’ continues to be improved.  This latest update allows you to always reference the first file in a folder as the example file.  Before this 
update, you had to pick a specific file by name, which might cause errors in the future if such file is removed from the folder.

With this update, you can select ‘First file’ in the ‘Combine Files’ dialog, which will ensure that the first file in the folder is used as the example, regardless 
of the specific file name.

New Go to Column in Query Editor

When working with tables that have many columns, it is hard to scroll in the Query Editor preview to find the column that you want to apply 
transformations to.  This release provides a new ‘Go to Column’ command on the ‘Home’ tab of the Query Editor Ribbon that allows you to search within 
the list of columns and select the column more easily.
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SAP HANA Connector—enhancements to Parameter Input UX

The Parameter Input UX for the SAP HANA connector has been improved in a couple of ways:

	 •	 You can now filter down the list of parameters to only required parameters
	 •	Microsoft has moved away from drop-down menus for single / multi-selection input controls and started using a popup dialog for both scenarios.  	
		  This new dialog allows users to see both the ID and Caption for each parameter value, as well as search within the list of values by any of these two  
		  fields.  This makes it easier to provide input values, as opposed to before, which only allowed input IDs.

These updates are available as part of an Office 365 subscription.  If you have Excel 2010 or Excel 2013, you can also take advantage of these updates by 
downloading the latest Power Query for Excel add-in.

You can find out more about Power Query, Power Pivot and Power BI on one of our training courses.  Visit www.sumproduct.com/courses for more 
information and to book today.

For once, we can report on some Get & Transform updates on time!  Just before our printing deadline – and we mean just before! – Microsoft has 
announced further updates to data importing and shaping in Excel 2016.  Essentially, the Ribbon has been rearranged for the 12,000th time viz.

These updates are available as part of an Office 365 subscription beginning with Current Channel Version 1704 (Build 8067.2115).  Some readers may 
think these changes are old hat; indeed, this rearrangement has been around a while already on Insider builds.
However, there are some revisions that are definitely welcomed.  Aside from the common sources (text / CSV, web and Tables / ranges), there are 
the ‘Get Data’ dropdown menu and the highly useful ‘Recent Sources’.  
The former is similar to before:

Check out the ‘Legacy Wizards’ here – for those of you not in a rush to update the next big thing.  They’re not deprecated yet, although admittedly, 
they are getting more and more hidden (hint, hint).

The latter is new though.  Excel users often establish a set of frequently used sources they import data from.  With this update, you can easily create 
a query from one of your recently used data sources by clicking on the Data > Recent Sources command.  You can then browse through your recently 
connected sources, select one, and then click ‘Connect’ to continue with the import flow.

STOP PRESS!! July Updates for Get & Transform (Excel 2016) Only
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Another popular scenario involves sharing your workbook queries with 
other people in your organisation.  With this update, it is now possible 
to import and export queries via the Office Database Connection (ODC) 
mechanism.

To export a query definition into an ODC file, right click on a query in the 
‘Queries & Connections’ side pane and choose the ‘Export Connection 
File’ command.  The created ODC file will contain the definition of your 

query including the connectivity instructions to the data source and the 
transformation steps being applied on your data.

Once you receive an ODC file, you will be able to use it and import the 
query definition into your workbook.  To create query and import data 
using the existing ODC file, use the ‘Existing Connections’ dialog opened 
by clicking on the Data > Existing Connections button:

Finally, with this update, Microsoft has now introduced a consolidated management experience for workbook queries and connections.  In this new 
unified section for queries and connections, you can now access everything through the dedicated ‘Queries & Connection’ side pane.  To open the 
side pane, click the Data > Queries & Connections button:

mailto:contact@sumproduct.com
http://www.sumproduct.com


contact@sumproduct.com  | www.sumproduct.com  | +61 3 9020 2071 

Clicking on the ‘Queries’ tab at the top of the side pane allows you to 
browse and manage the available queries in your workbook.  Right-click 
on a query, you can access the query’s context menu allowing you to 
perform additional actions such as manage query properties, refresh 
query data from the underlying source, edit query transformations with 
Query Editor etc.

In a similar manner, clicking on the ‘Connections’ tab at the top of the side 
pane allows you to browse and manage the available legacy connections 
in your workbook that are associated with one of the legacy wizards 
such as legacy ‘From Text’, ‘From Analysis Services’ or ‘From Microsoft 
Query’.  Right-clicking on a connection accesses the connection’s context 
menu that allows you to refresh connection data from source, delete 
connection or manage connection properties.

Now this is more like it.  Finally, we get to functions used all of the time by your typical Excel user.  Not.

This function returns a bitwise ‘AND’ of two numbers.  For those of us without PhD’s in IT, this means that the value of each bit position 
(the corresponding number reading from right to left when represented in binary) is counted only if both parameter's bits at that 
position are 1.

The BITAND function employs the following syntax to operate:

BITAND(number1, number2)

The BITAND function has the following arguments:

	 •	 number1: this is required and must be in decimal form, greater than or equal to 0.
	 •	 number2: also required.  This too must be in decimal form and greater than or equal to 0.

The A to Z of Excel Functions: BITAND
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It should be further noted that: 

	 •	BITAND returns a decimal number
	 •	 the result is a bitwise 'AND' of its parameters
	 •	 the value of each bit position is counted only if both parameter's bits at that position are 1
	 •	 the values returned from the bit positions progress from right to left as powers of 2. The rightmost bit returns 1 (2^0), the bit to	
		  its left returns 2 (2^1), and so on
	 •	 if either argument is less than 0, BITAND returns the #NUM! error value
	 •	 if either argument is a non-integer or is greater than (2^48)-1, BITAND returns the #NUM! error value
	 •	 if either argument is a non-numeric value, BITAND returns the #VALUE! error value.

Here’s some examples:

And here’s another one of the most commonly used functions on the planet.  If the planet is Uranus.  This function returns a number shifted left by 
the specified number of bits.  For those of us who have social lives, this means that you first convert the number to binary and then add on a specified 
number of zeros before converting the new binary number back to a decimal number.

The BITLSHIFT function employs the following syntax to operate:

BITLSHIFT(number, shift_amount)

The BITLSHIFT function has the following arguments:

	 •	number: this is required, and must be an integer greater than or equal to 0
	 •	 shift_amount: this is also required.  The shift_amount must be an integer.

It should be further noted that: 

	 •	 shifting a number left is equivalent to adding zeros (0) to the right of the binary representation of the number.  For example, a two-bit shift to 	
		  the left on the decimal value 4 converts its binary value (100) to 10000, or 16 in decimal
	 •	 if either argument is outside their constraints, BITLSHIFT returns the #NUM! error value
	 •	 if number is greater than (2^48)-1, BITLSHIFT returns the #NUM! error value
	 •	 if the absolute value of shift_amount is greater than 53, BITLSHIFT returns the #NUM! error value
	 •	 if either argument is a non-numeric value, BITLSHIFT returns the #VALUE! error value
	 •	 a negative number used as the shift_amount argument shifts the number of bits to the right
	 •	 a negative number used as the shift_amount argument returns the same result as a positive shift_amount argument for the BITRSHIFT function.

The A to Z of Excel Functions: BITLSHIFT
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An example: 

Are you starting to get used to these functions now, well a BIT anyway (get it)?  This function returns a bitwise ‘OR’ of two numbers.  In this variant, 
this means that the value of each bit position (the corresponding number reading from right to left when represented in binary) is counted if any of 
the parameter's bits at that position are 1.

The BITOR function employs the following syntax to operate:

BITOR(number1, number2)

The BITOR function has the following arguments:
	 •	number1: this is required and must be in decimal form, greater than or equal to 0
	 •	number2: also required.  This must be in decimal form and greater than or equal to 0.

It should be further noted that: 

	 •	 the result is a bitwise 'OR' of its parameters
	 •	 in the result, each bit position is 1 if any of the parameter's bits at that position are 1
	 •	 the values returned from the bit positions progress from right to left as powers of 2.  The rightmost bit returns 1 (2^0), the bit to the left returns  
		  2 (2^1), and so on
	 •	 if either argument is outside their constraints, BITOR returns the #NUM! error value
	 •	 if either argument is greater than (2^48)-1, BITOR returns the #NUM! error value
	 •	 if either argument is a non-numeric value, BITOR returns the #VALUE! error value.

More examples: 

The A to Z of Excel Functions: BITOR
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It’s time to find thee antidote to the above BITLSHIFT function and you shouldn’t feel bitter (BITR?).  This function first converts the number to binary 
and then removes a specified number of digits from the right of the binary number, i.e. this function returns a number shifted right by the specified 
number of bits. 

The BITRSHIFT function employs the following syntax to operate:

BITRSHIFT(number, shift_amount)

The BITRSHIFT function has the following arguments:

	 •	Number: this is required and must be an integer greater than or equal to 0.
	 •	 shift_amount: also required.  This must be an integer.

It should be further noted that: 

	 •	 shifting a number right is equivalent to removing digits from the rightmost side of the binary representation of the number.  For example, a 	
		  two-bit shift to the right on the decimal value 13 converts its binary value (1101) to 11, or 3 in decimal
	 •	 if either argument is outside its constraints, BITRSHIFT returns the #NUM! error value
	 •	 if number is greater than (2^48)-1, BITRSHIFT returns the #NUM! error value
	 •	 if the absolute value of shift_amount is greater than 53, BITRSHIFT returns the #NUM! error value
	 •	 if either argument is a non-numeric value, BITRSHIFT returns the #VALUE! error value
	 •	 a negative number used as the shift_amount argument shifts the number of bits to the left
	 •	 a negative number used as the shift_amount argument returns the same result as a positive shift_amount argument for the BITLSHIFT function.

Penultimate example:

Our final function for this month returns a bitwise ‘XOR’ of two numbers (XOR was first introduced in Excel 2013 and at the current rate of publishing 
these articles we should get to this one by 2044).  Essentially, BITXOR converts two numbers to binary expressions and compares the digits at 
each position from right to left.  If the values are not equal, the function returns a 1 for that position (bit).  For each 1, its position is ascertained 
and converted to a power of 2 (2^0 for the rightmost position, 2^1 for the value to its left, 2^2 for the value to the left of this and so on).  These 
corresponding powers of two are then summed.

The BITXOR function employs the following syntax to operate:

BITXOR(number1, number2)

The BITXOR function has the following arguments:

	 •	number1: this is required and must be greater than or equal to 0.
	 •	number2: also required.  This must be greater than or equal to 0.

It should be further noted that: 

	 •	BITXOR returns a decimal number that is the result of the sum of a bitwise 'XOR' (exclusive XOR) of its parameters
	 •	 if either argument is outside its constraint, BITXOR returns the #NUM! error value
	 •	 if either argument is greater than (2^48)-1, BITXOR returns the #NUM! error value
	 •	 if either argument is a non-numeric value, BITXOR returns the #VALUE! error value
	 •	 in the result, each bit position is 1 if the values of the parameters at that bit position are not equal; in other words, one value is 0 and the other  
		  is 1.  For example, using BITXOR(5,3), 5 is expressed as 101 in binary and 3 as 11 in binary.  To help with comparison, you can consider 3 as 011.   
		  From right to left, the bit values at the three positions in this example are the same (1) only at the rightmost position.  A 'not equal' result returns  
		  a 1 for the second and third positions from the right, and an ‘equal’ result returns 0 for the rightmost position

The A to Z of Excel Functions: BITRSHIFT

The A to Z of Excel Functions: BITXOR
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Upcoming SumProduct Training Courses

Location Course Date Duration

Sydney Financial Modelling 1st - 2nd Aug 2017 2 days

Perth Power Pivot, Power Query and Power BI 7th - 9th Aug 2017 3 days

Adelaide Excel Tips & Tricks 14th Aug 2017 1 days

Adelaide Financial Modelling 15th - 16th Aug 2017 2 day

Melbourne Mergers and Acquisitions 21st - 24th Aug 2017 4 days

Brisbane Power Pivot, Power Query and Power BI 28th - 30th Aug 2017 3 days

Melbourne Excel Tips & Tricks 4th Sep 2017 1 day

Melbourne Financial Modelling 5th - 6th Sep 2017 2 days

Melbourne Power Pivot, Power Query and Power BI 12th - 14th Sep 2017 3 days

Sydney Excel Tips & Tricks 25th Sep 2017 1 day

	 •	 values of 1 returned from the bit positions progress from right to left as powers of 2. The rightmost bit returns 1 (2^0), the bit to the left returns 	
	 	 2 (2^1), and so on
	 •	using the same example, 0 is returned for the rightmost bit position because it is a 0, 2 (2^1) is returned for the second bit position from the 	
	 	 right (a 1 value), and 4 (2^2) is returned for the leftmost bit (also a 1 value). The total is 6, in decimal representation.

Here's the final illustration:
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Link to Others
These newsletters are not intended to be 
closely guarded secrets.  Please feel free 
to forward this newsletter to anyone you 
think might be interested in converting to 

“the SumProduct way”.

If you have received a forwarded 
newsletter and would like to receive 
future editions automatically, please 

subscribe by completing our newsletter 
registration process found at the foot of 
any www.sumproduct.com web page.

Any Questions?
If you have any tips, comments or queries 
for future newsletters, we’d be delighted 
to hear from you. Please drop us a line at 

newsletter@sumproduct.com.

Our Services
We have undertaken a vast array of 
assignments over the years, including:
· 	 Business planning
· 	 Building three-way integrated 		
	 financial statement projections
· 	 Independent expert reviews
· 	 Key driver analysis
· 	 Model reviews / audits for internal 		
	 and external purposes
· 	 M&A work
· 	 Model scoping
· 	 Power BI, Power Query & Power Pivot
· 	 Project finance
· 	 Real options analysis
· 	 Refinancing / restructuring
· 	 Strategic modelling
· 	 Valuations
· 	 Working capital management
If you require modelling assistance of any 
kind, please do not hesitate to contact us 
at contact@sumproduct.com.

Training
SumProduct offers a wide range of 
training courses, aimed at finance 
professionals and budding Excel experts. 
Courses include Excel Tricks & Tips, 
Financial Modelling 101, Introduction to 
Forecasting and M&A Modelling. 

Drop us a line at training@sumproduct.com 
for a copy of the brochure or download  
it directly from
http://www.sumproduct.com/training.

Check out our 
more popular 
courses in 
our training 
brochure:

Key Strokes
Each newsletter, we’d like to introduce you to useful keystrokes you may or may not be aware of.  We’ve finally finished the function 
keys – Mac users will be pleased:

There are over 540 keyboard shortcuts in Excel.  For a comprehensive list, please download our Excel file a
www.sumproduct.com/thought/keyboard-shortcuts. Also, check out our new daily Excel Tip of the Day feature on the 
www.sumproduct.com homepage.

Keystroke What it does

F12 Save As

CTRL + F12 Open

CTRL + ALT + F12 Thai dictionary (!)

CTRL + SHIFT + F12 Print

SHIFT + F12 Save

Have you heard about the 
SumProduct Referral programme? 
If you successfully introduce us to a 
client we will pay you 10% of the net 
profits of the engagement won upon 
receipt of client payment. Sounds like 
a pretty good deal to us!

Terms and conditions apply.  Referrer 
must be over 18 years of age, able 
to issue an invoice and not be an 
employee, director, agent or other 
related party of the client engaged.  
For further information, drop us a line 
at  contact@sumproduct.com.  We 
hope to hear from you!

Referral Programme

Sydney Financial Modelling 26th - 27th Sep 2017 2 days

Sydney Power Pivot, Power Query and Power BI 16th - 18th Oct 2017 3 days

Melbourne Excel Tips & Tricks 23rd Oct 2017 1 day

Melbourne Financial Modelling 24th - 25th Oct 2017 2 days

Sydney Visual Basic for Applications 6th Nov 2017 1 day

Sydney Excel Tips & Tricks 13th Nov 2017 1 day

Sydney Financial Modelling 14th - 15th Nov 2017 2 days

Melbourne Power Pivot, Power Query and Power BI 4th - 6th Dec 2017 3 days

Melbourne Excel Tips & Tricks 11th Dec 2017 1 day

Melbourne Financial Modelling 12th - 13th Dec 2017 2 days
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