
Remember shared workbooks?  Everyone opened an Excel workbook at 
the same time, made their changes and then none of them saved?  Well, 
it’s back...  Microsoft announced recently that it is enabling co-authoring in 
Excel on Windows desktops for Office Insiders Fast.  This allows you to know 
who else is working with you in a spreadsheet, see where they’re working 
and view changes automatically within seconds.  It is still being tested, so 
Microsoft encourages early adopters to continue using feedback channels 
to improve the experience before making it available more broadly.  
Co-authoring is already available in Excel Online, Excel on Android, too.  
Now that we have to see.

Before co-authoring, you would get locked out of an Excel file and would 
not be able to edit it if you left the file open on another machine, or 
if another user had it open at the same time.  We’ve all suffered from 
that.  Now, Microsoft has created the ability to always access your file for 
editing whether you left it open on another machine or other colleagues 
have it open at the same time.  No more lockouts on Excel files (and 
scant version control either)!    

Co-authoring in Excel on Windows desktops also allows you to see where 
others are editing at the same time as you in a spreadsheet.  It does 
need AutoSave switched on for the features to work fully – and that’s 

not something modellers necessarily want to do.  You may need to think 
about this before exploring this functionality fully.

To use co-authoring in Excel on Windows desktops, you must:

	 •	Be an Office 365 subscriber and opted into the Fast level of the 		
		  Office Insider program 
	 •	Have Version 8017.1000 or later installed
	 •	 Save your file to SharePoint Online, OneDrive or OneDrive for 		
		  Business
	 •	Work with another user who is on a co-author enabled platform
	 •	 Share your file with others in the Insiders program.

It should be stressed that you do not require the updated OneDrive 
for Business sync client (that will be a relief to all of those who have 
absolutely no idea what I am talking about).  As long as the file lives in 
the Cloud, co-authoring will work.  It does not matter if you are using a 
sync client or not.  If you load from your local sync folder instead, Excel 
will still realise it comes from the Cloud and co-authoring should still 
work.  (When we say “Cloud” by the way, we mean SharePoint Online, 
OneDrive or OneDrive for Business.)
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We have lots to share this month… Excel’s shared workbook makes 
a comeback, with the enhanced return of co-authoring.  It never really worked before: will it work this time?  The jury is out!  There’s also 
lots to share on the Power BI and Power Query fronts with lots of updates to share with you too.  And Microsoft wants to share a new 
add-in with you too: Script Lab for the JavaScript API developer in you (yes, I am talking to both of you!).

Talking of Power Query, we have our usual Power Query Pointer and even explain how to get it in this month’s Reader’s 
Question.

The A to Z of Excel Functions gets ‘Beta’ this month (get it?) and we retain our continued infatuation with the function 
keys in Keyboard Shortcuts, finally making it to the ones that make your calculations calculate.  

So, don’t keep this newsletter a secret – share it around!

Until next month.

Sharing is Caring
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Furthermore, you can co-author with others not in the Insiders program.  
However, they will not be able to take advantage of co-authoring on 
Excel on Windows desktop and must use another supported version 
(Excel Online, Excel on Android or Windows Mobile) instead.

As mentioned above, AutoSave is critical to this functionality.  In Excel 
2016 for Office 365 subscribers, you may have noticed AutoSave in the 
upper-left corner.  AutoSave is enabled when a file is stored on OneDrive, 
OneDrive for Business, or SharePoint Online.  It automatically saves your 
changes to the cloud as you are working, so be careful.  The idea is that if 
other people are working on the same file, AutoSave lets them see your 
changes in just a matter of seconds.

To use AutoSave in Excel in this way, you must:

	 •	Be an Office 365 subscriber and opted into the Fast level of the 		
		  Office Insider program
	 •	Have Version 8017.1000 or later installed (again!)
	 •	Use .xlsx, .xlsm, or .xlsb files. If your file isn’t in this format, open 	
		  the file and then click File > Save As > Browse > Save as type.  You 	
		  should change the format to .xlsx, .xlsm, or .xlsb for this to work
	 •	 Save your file to a shared location.

In Excel on Windows desktops, Office 365 subscribers might notice an 
AutoSave option in the upper-left corner.  AutoSave is enabled when 
a file is stored on the Cloud.  It automatically saves your changes to 
the cloud as you are working.  If other people are working on the same 
file, it lets them see your changes almost instantly.  When co-authoring 

with other people, AutoSave will save every few seconds (that’s a little 
scary…).  This time may vary depending upon what you are working on.

To get started, upload a workbook to a supported, shared Cloud location 
such as SharePoint Online, OneDrive or OneDrive for Business.  Then, 
you will need to share your workbook with others.  If you clicked the 
‘Share’ button, people will receive an email message inviting them to 
open the file.  They can click the link to open the workbook, a web 
browser will open, and the workbook will open in Excel Online.  To use 
co-authoring in Excel on Windows desktop, click Edit Workbook > Edit 
in Excel. However, these users will need a version of Excel that supports 
co-authoring too. 

At the time of writing, co-authoring is currently supported for all 
customers in Excel Online, Excel on Android and Excel Mobile on 
Windows.  Co-authoring is currently available in Excel on Windows 
desktops for Office 365 subscribers in the Fast level of the Office Insider 
program only.  It’s also available in Excel on iOS for Office Insiders too.  
If the people you are collaborating with you do not have a supported 
version of one of these apps, they can co-author using Excel Online by 
clicking Edit Workbook > Edit in Browser instead.

That is apparently it.  Once you’ve shared your workbook with others, 
you can begin to edit in the workbook at the same time, and when you’re 
co-authoring using Excel on Windows desktop, you’ll know you're co-
authoring if you see pictures of people in the Ribbon.  This assumes they 
have uploaded their photos though!

When you are co-authoring, you can see each other's changes in a matter 
of seconds and when co-authoring in Excel on Windows desktop or Excel 
Online you'll see other people's selections in a coloured box around the 
cell they’re working in, represented with different colours.  This allows 
you to quickly determine where others are working to avoid working in 
the same cell at the same time. 

When using Excel on Windows desktop, if you want to jump to where 
someone is working, just click on their picture or initials, and then click 
the ‘Go to’ option.  As mentioned above, you might see other people's 

selections in different colours.  This happens when you are both using 
either Excel on Windows desktops or Excel Online and everyone has 
AutoSave turned on.  If they're using another version you won't see their 
selections, but their changes will appear as they are working, perfect 
for anonymous micromanagers.  If you see other people's selections in 
different colours, they'll show up as blue, purple and so on.  However, 
your selection will always be green.  And on other people’s screens, their 
own selections will be green as well.  If you lose track of who’s who, rest 
your cursor over the selection, and the person’s name will be revealed.  
Simples!

Please don’t create coloured charts like this – yellow is “Rent and Utilities” in the pie chart but 2009 in the Histogram!  Use 
SumProduct to help guide you through producing charts – not Microsoft!!
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To co-author and see changes made by others, everyone needs to use a version of the Excel app that supports co-authoring.  Excel for Android, Excel 
for iOS, Excel Mobile, and Excel 2016 for Office 365 subscribers are the versions that currently support co-authoring. As stated above, if they don’t 
have a supported version, they can always use Excel Online in their web browser by clicking Edit Workbook > Edit in Browser. If that doesn't solve 
the problem, try one or more of the following:

	 •	Be patient!  Sometimes it takes some time for Excel and the Cloud to communicate with each other
	 •	 Tell everyone to click the ‘Enable Editing’ button if it appears
	 •	Make sure everyone who is working in Excel 2016 for Office 365 subscribers has AutoSave on in the upper-left corner of the Excel window
	 •	Make sure those who are working in Excel for Android have AutoSave on.  They can turn it on by tapping File > Gear button > AutoSave
	 •	Make sure those who are working in Excel for iOS have AutoSave on.  They can turn it on by tapping File… > AutoSave
	 •	Make sure the file is not read-only
	 •	On a Windows PC, open the file and go to File > Info. Resolve any errors that may be shown there.

Have fun experimenting!

Office 365 has got some good news for you - if you make a habit of saving your files (not just Excel ones) to One Drive, One Drive for 
Business or SharePoint (no, we don't either, but...).

New, behind-the-scenes improvements to Office 365 allows you to look back at how a file has evolved over time - or more likely, if you 
are like us and hit the wrong keyboard shortcut from time to time - it also allows you to retrieve and restore older versions you happen 
to have saved over.  It's okay, we've all bought that t-shirt.

To restore, simply:

	 1.	Open the file you were working on
	 2.	Near the far right end of the Ribbon, click the Activity button (highlighted in the graphic) to see a list of all of the historical versions 
		   in the Activity pane - but watch out, you won't see this button if you're not working on One Drive of some sort or SharePoint
	 3.	Click a version to open and view it in a separate window
	 4.	To restore it, click Restore in the message bar at the top of the opened version.

This will have the effect of saving your current file as a new version and then replacing this file with the contents of the version you 
chose to restore.

Now, this would be nice if this worked for non-Cloud files too (Microsoft, are you listening!?)...

Keeping Track of Changes
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Last month, we showed how similar CSV (comma separated values) files can be extracted and appended to the same query.  This time, we consider 
the scenario where we have many similar CSV files in the same folder.  Instead of appending each one, we can extract all the files from a specified 
folder.  In this example, we have ten expense files in a folder called PQ_StandardExpenses.  In a blank workbook, we opt to create a new query using 
the ‘From File’ Option, and drop down to select ‘From Folder’ – a simple browse window appears, and having chosen the correct folder, the meta 
data is displayed as shown below:

At this point, we could choose to load these files and we’d be done, but editing allows the data to be transformed, and some safety features to be added. 

In this case, all the files have the extension CSV, but it is sensible to plan for some kind person putting an excel workbook in the folder and messing 
up future refreshes.  At the same time, we can also allow for users typing in 'csv' rather than 'CSV' when they create their files. 

Selecting the extension column, right-clicking gives the option to ‘Transform’ to lowercase:

At the top is a standard filter arrow: clicking on this reveals a number of options to transform the data in the column.  The ‘Text Filter’ allows selections 
matching or not matching the specified text – in this case we choose to match ‘.csv’ (note that the full stop is required). The query is now protected from 
stray workbooks and will include files with .csv and .CSV extensions.  Simple!

In order to transform the data in the files, we need to see the table contents, and not just the metadata.  Next to the content column header is an icon 
which appears for binary files, and allows the binary to be combined – the            icon.

Pressing the button with this icon makes the contents of each table appear under the table headings:

Each month we’ll reproduce one of our articles on Power Query (Excel 2010 and 2013) / Get & Transform (Excel 2016) from www.sumproduct.com/
blog.  If you wish to read more in the meantime, simply check out our Blog section each Wednesday.  This month we look at extracting all the files 
from the same folder.

Power Query Pointers
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On the ‘HOME’ tab, in the ‘Transform’ group, there is an option to ‘Use First Row as Headers’. This works well, but we have other header rows that we 
need to remove.  One way to do this is to deliberately put an error in these rows so we can select and remove the errors.   

Change the column type on the amount row to currency by selecting the currency column.  Then, on the ‘HOME tab in the ‘Transform’ group the top 
option Data Type is initially set to ‘Text’ because Power Query has recognised that some of the data in the column is text.  Changing it to ‘Currency’ is 
fine for the rows with actual amounts in, but produces errors for the headings.  Right-clicking the amount column gives the option to ‘Remove Errors’ viz.

Finally, we can replace blanks with nulls and down fill as we did with the single table.  Then, close and load to see all the data in a workbook:

Extracting from a folder is an efficient way to upload multiple expense files in a similar format, but what if someone sends in a CSV file that has been 
configured differently?  We deal with a simple example of unpivoting data next month…
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Get & Transform (Excel 2016) / the Power Query add-in (Excel 2010 and 2013) have had their monthly updates put through.   
April’s improvements cover five new data transformation and connectivity features.

These updates include the following new or improved data connectivity and transformation features:

	 •	 Support for the same file extensions in Text and CSV connectors
	 •	ODBC and OLE DB connectors: support for ‘Select Related Tables’
	 •	 Enhanced Folder connector: support for ‘Combine Binaries’ from the ‘Data Preview’ dialog box
	 •	New ‘Change Type Using Locale’ option in ‘Column Type’ drop-down menu inside the Query Editor
	 •	New ‘Insert Step After’ option in ‘Steps’ pane inside the Query Editor.

Support for the same file extensions in Text and CSV connectors

With this update, Microsoft has revised the list of supported file extensions in ‘From Text’ and ‘From CSV’ connectors.  Now, you can 
browse and select any text (*.txt), comma-separated value (*.csv) or formatted text space delimited (*.prn) file as the first step of the 
import flow for both connectors.  Alternatively, you can switch to the ‘All files’ (*.*) filter option and select to import data from any 
other unlisted file:

ODBC and OLE DB connectors: support for ‘Select Related Tables’

When using the ODBC and OLE DB connectors, the latest update has enabled the ‘Select Related Tables’ button in the Navigator dialog 
box.  This option, already available for other relational data sources, allows you to select tables that are directly related to the set of 
already selected tables in the Navigator dialog:

April 2017 Updates for Get & Transform / Power Query add-in

mailto:contact@sumproduct.com
http://www.sumproduct.com


contact@sumproduct.com  | www.sumproduct.com  | +61 3 9020 2071 

Enhanced Folder connector: support for ‘Combine Binaries’ from the ‘Data Preview’ dialog box

This latest update has made it easier for customers to access the ‘Combine Binaries’ feature by allowing you to combine multiple files 
directly from the folder ‘Data Preview’ dialog within the ‘Get Data’ flow, without having to go into the Query Editor.

Further, it should be noted that various multiple options (e.g. ‘Combine’, ‘Combine & Load’) allow you to further refine your data 
before loading it into the worksheet or Data Model:

New ‘Change Type Using Locale’ option in ‘Column Type’ 
drop-down menu inside the Query Editor

In the Query Editor, it is possible to see and modify column types by using 
the ‘Column Type’ drop-down menu in the preview area.  With this release, 
the ‘Change Type Using Locale’ option has now been added to this drop-
down menu (previously available by right-clicking the column header and 
then selecting Change Type > Using Locale).  This option allows you to specify 
the desired column type and locale to use for the conversion, which affects 
how text values will be recognised and converted to other data types, such as 
dates, numbers, etc.

New ‘Insert Step After’ option in the ‘Steps’ pane inside the 
Query Editor

With this update, Microsoft has also a new context menu option in the Query 
Editor window to insert new steps in existing queries.  The ‘Insert Step After’ 
option lets you insert a new custom step right after the currently selected step, 
which can be the final step or any previous step within the query.

You can find out more about Power Query, Power Pivot and Power BI on one 
of our training courses.  Visit https://www.sumproduct.com/courses for more 
information and to book today.
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It’s not only Power Query.  April saw a raft of new features - some in Preview - for Power BI for Desktop.  Updates included enhancements to data 
connectivity, query editing, matrix reporting and, er, Spanish.

In particular, desperate times may call for desperate measures, so we must live in quick times, as Microsoft introduces Quick measures instead.  
These measures allow you to create measures in an instant based upon 19 different calculations (e.g. sum, average, max, min) across five different 
categories (aggregation, filters and baselines, time intelligence, running totals and mathematical operations).

In summary, other than quick measures, the updates also include the following features:

	 •	Rename axis titles
	 •	Redshift connector: beta support and publish to Power BI service
	 •	 Enhancement of the parameter input experience for SAP HANA and BW connectors
	 •	Add column by example
	 •	 Split column (by delimiter / number of characters) into rows
	 •	Basic mode for "Group by"
	 •	Go to column.

The following are included in "Preview" mode (i.e. the final versions may vary in both operation and interface):

	 •	Q&A in Spanish
	 •	New matrix visual enhancements, such as column sorting, column resizing and word wrapping
	 •	Quick measures
	 •	 Show value as...
	 •	 Connect to datasets in the Power BI service.

Let’s take a look at each in turn.
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Power BI Desktop: April Updates

Rename axis titles

If your field names aren’t the easiest to follow, or your chart layout needs more explanation, you can now rename your axis titles.  This option is with 
the other title options under the axis card in the formatting pane:

Redshift connector: beta support and publish to Power BI service

Microsoft has made the Amazon Redshift connector available as a beta version in 
this release, so you no longer need to enable it as a Preview feature.  The Redshift 
connector can be found under the Database category within the ‘Get Data’ dialog 
box: >

Amazon Redshift-based reports have been supported in the Power BI service since 
March.  Now, the Publish button has finally been enabled in Power BI Desktop, so 
you can publish your Redshift-based reports directly from Power BI Desktop.
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Enhancement of the parameter input experience for SAP HANA and BW connectors

The Parameter Input user experience – what Microsoft refers to as “UX” in Gobbledygook – has been enhanced for SAP HANA and BW in a couple 
of ways:

	 •	 There is now an ability to filter down the list of parameters to “only required parameters”

	 •	 Improvements have also been made to the single / multi-selection input controls.  This means no more dropdown menus and “hello pop-up 	
		  dialog box”.  This new feature allows you to see both the ID and Caption for each parameter value, as well as search within the list of values by 
		  any of these two fields.  

Add column by example

April added a new smart data exploration capability to the Query Editor that seeks to learn from your examples.  Based on your examples of the 
desired output, Power BI will detect the transformations required and create a new column.  This is an innovative approach to defining query steps 
within the Query Editor that simplifies the process for beginners as they no longer need to come up with “a strategy” for how to transform or extract 
data from other columns, or how to define those transformations in the Query Editor.  Now that’s a good idea in our opinion!

Split column (by delimiter / number of characters) into rows

There’s a new option within the “Split Column By Delimiter” and “Split Column by Number of Characters” transformation dialogs that allows you to 
specify whether to split into new columns (that’s the default behaviour) or split into new rows.

Microsoft boasts that they are “…just getting started with this feature…” and plan to make improvements incrementally in subsequent releases.   
You can find a list of all currently supported data transformations available from the ‘Help’ link in the command bar while using this feature.  
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 This new option can be found under the “Advanced Options” section within these two dialog boxes.

Basic mode for "Group by"

A Basic mode has been added to the ‘Group By’ transform dialog that simplifies the user interface (UI) for you to group by a single column and define 
a single output column.  You can switch between Basic and Advanced modes within the ‘Group By’ dialog by selecting the desired option at the top 
of the dialog:

Go to column

A Basic mode has been added to the ‘Group By’ transform dialog that simplifies the user interface (UI) for you to group by a single column and define 
a single output column.  You can switch between Basic and Advanced modes within the ‘Group By’ dialog by selecting the desired option at the top 
of the dialog:
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Q&A in Spanish

You would have thought with the advent of BAHTTEXT that Thai would be the next language cab off the rank.  But you’d be wrong.  You have no idea 
how excited I am to announce that Spanish will be the next language for Power BI – unless you knew that I wasn’t excited.  Jokes aside, this is a very 
important step for Microsoft as it allows greater access to Power BI for non-English speakers.

In order to use Q&A in Spanish, you must first mark the language of your model as Spanish.  To do this, you first must turn on the preview feature by 
checking Spanish language support for Power BI Q&A under File > Options and settings > Preview features.

Once the feature is on, you’ll find a Language option in the ‘Modeling’ tab of the ‘Relationship’ view:

New matrix visual enhancements, such as column sorting, column resizing and word wrapping

March saw the release of a Preview of a new matrix visual.  April has added three updates to this Preview: 

	 •	Column sorting: you may sort the matrix now by the grand total and row headers ascending or descending, just as you could with the original 	
		  matrix
	 •	Resizing: just hover over the area between the two columns and your cursor will change to indicate you can click and drag to resize
	 •	Word wrapping: you can also word wrap column headers, row headers and values in the matrix preview.  Each one can be turned on in the 	
		  formatting pane under the corresponding card: column headers, row headers, and values.

Once your model language is set to Spanish, you can now publish this report to the Power BI service and be able to ask any question you want in 
Spanish:

It does beg the question though: why isn’t the last screenshot in Spanish?  Perhaps that should be your first question…
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There are many plans afoot to bring even more features to the popular matrix (have you seen the movie Matrix Revolutions?). For example, 
Microsoft has announced it is presently working on:

	 •	Updating the table visual to support cross highlighting
	 •	Adding control over visibility of individual subtotals
	 •	 Supporting URL icons.

In the dialog, you can pick any of the 19 different calculations to perform 
on the selected measure.  Depending upon the calculation, you will have 
different required parameters you’ll need to fill in.  You can also change 
the fields being used in the calculation using the field list on the right half 
of the dialog: >

Quick measures

April’s star feature is arguably the major update to the ‘Quick Calcs’ 
experience.  Once you turn the preview on by selecting ‘Quick measures’ 
under File > Options and settings > Preview features, you’ll see two new 
options for numerical columns and measures: Show value as and Quick 
measures.  These options will replace the previous Quick Calcs option in 
the field menu.

Using quick measures is a very fast way to create new measures based 
on measures and numerical columns in your table.  This means you can 
now deliver expert level calculations with no Data Analytical eXpressions 
(DAX) knowledge.  These new measures are now part of your model and 
can be used in any of your charts.  This means you can use them as a 
great learning tool or as a starting place for more advanced calculations 
since the automatically generated DAX is available to you.

You can create measures based on 19 different calculations across 5 
different categories:

	 •	Aggregate within category: These calculations let you apply 		
		  different aggregates at different levels in your data.  For example, 	
		  you could sum revenue up to the month level and then take an 		
		  average of that total to display annually

	 •	Filters and baselines: These calculations allow you to calculate 		
		  values for a specific category in a column, or compare values to a 	
		  specific baseline.  For example, you could calculate your sales for 	
		  just a specific category of your products
	 •	Time intelligence: If you need a measure that shows period-to- 
		  date 	or period-over-period values, the time intelligence 		
		  calculations let you do this.  DAX has many built-in functions that 	
		  these quick measures make simple to use
	 •	Running total: This calculation is similar to the YTD (year to date) 	
		  calculation, but lets you apply a running total over any field, not just  
		  dates
	 •	Mathematical operations: These calculations run simple  
		  mathematical functions, which can become powerful when 		
		  chained together.
You can create a quick measure by selecting Quick measures from the 
field menu, either in the field well of a chart or from the field list.

mailto:contact@sumproduct.com
http://www.sumproduct.com


contact@sumproduct.com  | www.sumproduct.com  | +61 3 9020 2071 

Show value as...

As mentioned above, once you turn the preview on by selecting ‘Quick measures’ under File > Options and settings > Preview features, you’ll see 
two new options for numerical columns and measures: Show value as and Quick measures.  Let’s look at the first one now.

Show value as is a quick way to change the way your values appear in a chart or table.  These correspond to what was previously in the Quick Calcs 
dialog.  Since you no longer need to open a dialog, it is now very quick to update how your values show in any given chart.

Connect to datasets in the Power BI service

You can now connect to a dataset that exists on the Power BI service.  This feature is great when you are part of a team and you all want to work off 
the exact same model.  You can craft your model only once, publish it to the Power BI service to create a dataset, and then everyone can create other 
Power BI Desktop reports off of it.  You’ll find this new connector under Get Data > Online Services > Power BI service.

You will see a list of all the workgroups you are a part of.  Expand one and you’ll see all the datasets that you have edit access to.  This includes any 
datasets in your workspace and datasets in shared workspaces.
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Select a dataset and you will be live connected to that model in the 
Cloud.  You can now create a new report and publish it up to the service 
to share out.  Of course, you can always download the file again if you 
ever need to.

Since this is a live connection, you won’t have permission to do any 
modelling and cannot join the data with any other sources.  To do these 
type of changes, you will need to make them in the source file and 
republish to the service for other reports to consume.

This is a preview feature, so you will need to turn it on in by selecting 
‘Power BI Service Live Connection’ under File > Options and settings > 
Preview features.

SumProduct's very own Tim Heng will be attending Microsoft's Data 
Insights Summit in Seattle on Monday 12 June and will be reporting back 
on these and future new features coming to a Power BI theatre near you 
very soon.

This brings me back to my old Statistics lectures.  You’d ask your 
tutor which function to use for a given scenario and she would 
compare various tools and conclude, “well, BETA DIST function 
than dat one” (groan – how often do I have to edit this rubbish? 
-Ed).

In probability theory and statistics, the beta distribution is a 
family of continuous probability distributions defined on the 
interval [0, 1] parametrised by two positive shape parameters, 
denoted by α (alpha) and β (beta), that appear as exponents of 
the random variable and control the shape of the distribution.  It 
has nothing to do with either the beta function (Euler integral) 
used in other areas of mathematics or the beta cited as the scalar 
in the Capital Asset Pricing Model.

The beta distribution has been applied to model the behavior of 
random variables limited to intervals of finite length in a wide 

variety of disciplines.  For example, it has been used as a statistical 
description of allele frequencies in population genetics, time 
allocation in project management / control systems, sunshine 
data, variability of soil properties, proportions of the minerals in 
rocks in stratigraphy and heterogeneity in the probability of HIV 
transmission.  Who’d have thought statistics and Excel could be 
so interesting?

In Bayesian inference, the beta distribution is the conjugate prior 
probability distribution for the Bernoulli, binomial, negative 
binomial and geometric distributions.  For example, the beta 
distribution can be used in Bayesian analysis to describe initial 
knowledge concerning probability of success such as the 
probability that a space vehicle will successfully complete a 
specified mission.  The beta distribution is a suitable model for 
the random behavior of percentages and proportions.

The A to Z of Excel Functions: BETA.DIST
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The usual formulation of the beta distribution is also known as 
the beta distribution of the first kind, whereas beta distribution 
of the second kind is an alternative name for the beta prime 
distribution.

The BETA.DIST function returns the beta distribution, which is 
commonly used to study variation in the percentage of something 
across samples, such as the fraction of the day people spend 
watching television or writing articles like this.  Be careful: there 
is a similar function called BETADIST which is slightly different 
(more below).

The BETA.DIST function employs the following syntax to operate:

BETA.DIST(x,alpha,beta,cumulative,[A],[B])

The BETA.DIST function has the following arguments:

	 •	x: required.  This represents the value between A and B at 	
		  which to evaluate the function
	 •	alpha: also required.  This is a parameter of the distribution
	 •	beta: required.  This is also a parameter of the distribution
	 •	 cumulative: required.  This is a logical value that determines  
		  the form of the function.  If cumulative is TRUE, BETA.DIST  

		  returns the cumulative distribution function; if it is FALSE, it 	
		  returns the probability density function
	 •	A: this is optional.  This is a lower bound to the interval of x
	 •	B: this is also optional.  This is an upper bound to the 		
		  interval of x.

It should be further noted that:

	 •	 If any argument is nonnumeric, BETA.DIST returns the  
		  #VALUE! error value
	 •	 If alpha ≤ 0 or beta ≤ 0, BETA.DIST returns the #NUM!  
		  error value
	 •	 If x < A, x > B, or A = B, BETA.DIST returns the #NUM!  
		  error value

	 •	 If you omit values for A and B, BETA.DIST uses the standard 	
		  cumulative beta distribution, so that A = 0 and B = 1

	 •	 This function first appeared in Excel 2010 and is not 		
		  backwards compatible.  It is essentially a more flexible 	
		  version of its predecessor, BETADIST.

Here’s an example: 

The BETADIST function returns the cumulative beta probability density function.  The beta distribution is commonly used to study variation in the 
percentage of something across samples, such as the fraction of the day people spend watching television or writing articles like this.  Be careful: 
there is a similar function called BETA.DIST which is slightly different (see above).

The A to Z of Excel Functions: BETADIST
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The BETADIST function employs the following syntax to operate:

BETADIST(x,alpha,beta,[A],[B])

The BETADIST function has the following arguments:

	 •	x: required.  This represents the value between A and B at which to evaluate the function
	 •	alpha: also required.  This is a parameter of the distribution
	 •	beta: required.  This is also a parameter of the distribution
	 •	A: this is optional.  This is a lower bound to the interval of x
	 •	B: this is also optional.  This is an upper bound to the interval of x.

It should be further noted that:

	 •	 If any argument is nonnumeric, BETADIST returns the #VALUE! error value
	 •	 If alpha ≤ 0 or beta ≤ 0, BETADIST returns the #NUM! error value
	 •	 If x < A, x > B, or A = B, BETADIST returns the #NUM! error value
	 •	 If you omit values for A and B, BETADIST uses the standard cumulative beta distribution, so that A = 0 and B = 1.

Here is an example: 

Essentially, BETADIST is the slightly less flexible version of BETA.DIST and represents the TRUE variant of the function introduced in Excel 2010.

The BETA.INV function returns the inverse of the beta cumulative probability density function (BETA.DIST).  Be careful: there is a 
similar function called BETAINV which is slightly different (more below).

If probability = BETA.DIST(x,...TRUE), then BETA.INV(probability,...) = x.  The beta distribution can be used in project planning to 
model probable completion times given an expected completion time and variability.

The BETA.INV function employs the following syntax to operate:

BETA.INV(probability,alpha,beta,[A],[B])

The BETA.INV function has the following arguments:

	 •	probability: required.  This represents a probability associated with the beta distribution
	 •	alpha: also required.  This is a parameter of the distribution
	 •	beta: required.  This is also a parameter the distribution
	 •	A: optional.  This is a lower bound to the interval of x
	 •	B: this is also optional.  This is an upper bound to the interval of x.

It should be further noted that:
	 •	 If any argument is nonnumeric, BETA.INV returns the #VALUE! error value
	 •	 If alpha ≤ 0 or beta ≤ 0, BETA.INV returns the #NUM! error value
	 •	 If probability ≤ 0 or probability > 1, BETA.INV returns the #NUM! error value
	 •	 If you omit values for A and B, BETA.INV uses the standard cumulative beta distribution, so that A = 0 and B = 1
	 •	 This function first appeared in Excel 2010 and is not backwards compatible.  It is essentially a more flexible version of its 
predecessor, BETAINV.

Given a value for probability, BETA.INV seeks that value x such that BETA.DIST(x, alpha, beta, TRUE, A, B) = probability. Thus, precision 
of BETA.INV depends upon the precision of BETA.DIST.

The A to Z of Excel Functions: BETA.INV
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Here’s an example: 

Similar to the above function, the BETAINV function returns the inverse of the cumulative beta probability density function for a specified beta 
distribution. That is, if probability = BETADIST(x,...), then BETAINV(probability,...) = x. The beta distribution can be used in project planning to model 
probable completion times given an expected completion time and variability.

It should be noted that this function has been replaced with one or more new functions from Excel 2010 onwards (BETA.INV) that may provide 
improved accuracy and whose names better reflect their usage.  Although this function is still available for backward compatibility, you should 
consider using the new functions from now on, because this function may not be available in future versions of Excel.

For more information about the new function, see the BETA.INV function from last time.

The BETAINV function employs the following syntax to operate:

BETAINV(x,alpha,beta,cumulative,[A],[B])

The BETAINV function has the following arguments:

	 •	probability: required.  This represents a probability associated with the beta distribution
	 •	alpha: also required.  This is a parameter of the distribution
	 •	beta: required.  This is also a parameter the distribution
	 •	A: optional.  This is a lower bound to the interval of x
	 •	B: this is also optional.  This is an upper bound to the interval of x.

It should be further noted that:

	 •	 If any argument is nonnumeric, BETAINV returns the #VALUE! error value
	 •	 If alpha ≤ 0 or beta ≤ 0, BETAINV returns the #NUM! error value
	 •	 If probability ≤ 0 or probability > 1, BETAINV returns the #NUM! error value
	 •	 If you omit values for A and B, BETAINV uses the standard cumulative beta distribution, so that A = 0 and B = 1.

Please see my example below: 

Do you fell BETA off now..?

The A to Z of Excel Functions: BETAINV
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May is a busy month for us.  It kicks off with the Unlock Excel event and various Excel training over the first two weeks, taking in 
Melbourne, Brisbane and Sydney in Australia, followed by Auckland (New Zealand) and Kuala Lumpur (Malaysia).  And that’s just the 
confirmed travelling!

If you would like to catch up with us, drop us a line at contact@sumproduct.com and we’ll try to swing by.  If you’re elsewhere, we 
might be on our way soon – with journeys lined up to London, Perth and Seattle for June.  More details soon…

Out and About in May

Every month we welcome new readers to our fairly established newsletter, so this month’s question is entirely reasonable: “…I see you mention a lot 
of useful things with Power Query.  I have Excel, but don’t seem to have Power Query – how do I get it?”.

You have to be careful about the term “Power Query”.  In its infinite wisdom (probably an oxymoron), Microsoft has renamed Power Query as “Get 
& Transform” in all flavours of Excel 2016 and it can be found easily on the ‘Data’ tab:

For Excel 2010 and Excel 2013, you have to download it.  The latest version can be found at https://www.microsoft.com/en-ca/download/details.
aspx?id=39379 although for Excel 2010, it is understood that it is only “officially supported” if you have software assurance.  

Do ensure you have administrative rights and that you download the right version: 32bit (x86) or 64bit (x64).  This has to be the same version as the 
version of Microsoft Office (not Windows) installed on your system.  It’s easy to detect.  In Excel, go to File > Account > About Excel.  The version is 
verified easily:

To activate it, go to File > Options > Add-ins, then select ‘COM Add-ins from the ‘Manage’ section and click on the ‘Go…’ button:

Reader’s Question
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Finally, check the ‘Microsoft Power Query for Excel’ add-in and you are away!

There’s usually new Power Query updates monthly and we mention these in our newsletter as they arise.  They can be a double-edged sword though.  
Sometimes, you think you have the software all figured out and Microsoft goes and moves it all!

There is another complication too.  If you have downloaded Power Query for Excel 2010, there is only one version, but for Excel 2013 and higher 
(re-badged ‘Get & Transform’ in Excel 2016 as mentioned earlier), there are two versions:

	 •	Power Query Premium: All Power Query features.  This is presently available for Professional Plus, Office 365 ProPlus or Excel Standalone only
	 •	Power Query Public: Available for all other Office Desktop Stock Keeping Units (SKUs).   Presently, this includes all Power Query features, except  
		  for the following:

	 	 o	 Active Directory
	 	 o	 Azure-based data sources
	 	 o	 Corporate Power BI Data Catalog
	 	 o	DB2
	 	 o	Dynamics CRM

Clear as mud..?

	 	 o	 Salesforce
	 	 o	 SAP Business Objects
	 	 o	 SharePoint Lists
	 	 o	 Sybase
	 	 o	 Teradata.

	 	 o	 Exchange
	 	 o	HDFS
	 	 o	MySQL
	 	 o	Oracle
	 	 o	 PostgreSQL

Microsoft said they would do it and now they 
have kept their promise with the release of 
Script Lab, an add-in for Excel (and other 
applications) described as a "Microsoft Garage" 
project (isn't that a type of '80's music?).

New Excel Add-In Script 
Lab Launched
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Upcoming SumProduct Training Courses

Location Course Date Duration

Melbourne Excel Tips & Tricks 29th May 2017 1 day

Melbourne Financial Modelling 30th - 31st May 2017 2 days

Melbourne Introduction to Financial Forecasting 1st Jun 2017 1 day

Perth Excel Tips & Tricks 12th Jun 2017 1 day

Perth Financial Modelling 13th - 14th Jun 2017 2 days

Sydney Excel Tips & Tricks 13th Jun 2017 1 day

Sydney Financial Modelling 14th Jun 2017 1 day

Melbourne Power Pivot, Power Query and Power BI 19th - 21st Jun 2017 3 days

Brisbane Excel Tips & Tricks 26th Jun 2017 1 day

Brisbane Financial Modelling 27th - 28th Jun 2017 2 days

Melbourne Excel Tips & Tricks 3rd Jul 2017 1 day

Melbourne Financial Modelling 4th - 5th Jul 2017 2 days

Sydney Visual Basic for Applications 10th Jul 2017 1 day

Sydney Power Pivot, Power Query and Power BI 17th - 19th Jul 2017 3 days

Adelaide Power Pivot, Power Query and Power BI 24th - 26th Jul 2017 3 days

Sydney Excel Tips & Tricks 31st Jul 2017 1 day

Sydney Financial Modelling 1st - 2nd Aug 2017 2 days

Perth Power Pivot, Power Query and Power BI 7th - 9th Aug 2017 3 days

Adelaide Excel Tips & Tricks 14th Aug 2017 1 days

Adelaide Financial Modelling 15th - 16th Aug 2017 2 day

Melbourne Mergers and Acquisitions 21st - 24th Aug 2017 4 days

Brisbane Power Pivot, Power Query and Power BI 28th - 30th Aug 2017 3 days

Melbourne Excel Tips & Tricks 4th Sep 2017 1 day

Script Lab is a tool for anyone who wants to learn about writing 
add-ins for Excel, Word or PowerPoint.  The focus is the Office 
JavaScript API, but Microsoft also mentions that you can "...code 
snippets that can include... HTML, CSS, and references to libraries 
and data on the web..." as well.

Microsoft are keen to push the JavaScript API, as they see it as 
the technology needed for building Office add-ins that run across 
platforms.  Whether you’re an experienced Office developer and 
you want to quickly prototype a feature or you’ve never tried 
writing code for Office and you just want to play with a sample 
and tweak it to learn more, this provides a "starter playground".

Script Lab has three main features:

1.	 Code in a pane beside your spreadsheet.  IntelliSense 		
		  shows suggestions while you type so you can easily  
		  discover and use the Office JavaScript objects and methods.  	
		  If you don’t want to start from scratch there are plenty of 	
		  samples preinstalled with Script Lab.  Your snippets can use 	
		  any TypeScript features like async / await and convenient 	
		  tools like arrow functions and template strings.  Script Lab 	
		  uses the Monaco editor, the same tech that powers VS  
		  Code, so it’s familiar to many

2.	 Run the code in another pane beside the editor.  Execution 	
		  can include logic, API calls to Office, UI in the pane, and 	
		  even output to a console.  Every time you make a code 	
		  change you can refresh the editor and run the new version  
		  in seconds

3.	 Share your snippets through GitHub.  If you create a snippet 	
		  you’d like to share, you can use Script Lab to save it then 	
		  send the link to someone else to try it and tweak it on their 	
		  computer.  The Import feature lets you load other people’s 	
		  snippets.

You can install Script Lab right now for free from the Office Store. 
It works for Excel, Word, and PowerPoint on Office 2013 and 
later, Office Online and Office for Mac.

The source code is open to the community at https://github.com/
OfficeDev/script-lab.
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Sydney Address:	 SumProduct Pty Ltd, Suite 52, Level 10, 88 Pitt Street, Sydney, NSW 2000
New York Address:	 SumProduct Pty Ltd, 48 Wall Street, New York, NY, USA 10005
London Address:	 SumProduct Pty Ltd, Office 7, 3537 Ludgate Hill, London, EC4M 7JN, UK
Melbourne Address:	SumProduct Pty Ltd, Level 9, 440 Collins Street, Melbourne, VIC 3000
Registered Address:	SumProduct Pty Ltd, Level 6, 468 St Kilda Road, Melbourne, VIC 3004

Link to Others
These newsletters are not intended to be 
closely guarded secrets.  Please feel free 
to forward this newsletter to anyone you 
think might be interested in converting to 

“the SumProduct way”.

If you have received a forwarded 
newsletter and would like to receive 
future editions automatically, please 

subscribe by completing our newsletter 
registration process found at the foot of 
any www.sumproduct.com web page.

Any Questions?
If you have any tips, comments or queries 
for future newsletters, we’d be delighted 
to hear from you. Please drop us a line at 

newsletter@sumproduct.com.

Our Services
We have undertaken a vast array of 
assignments over the years, including:
· 	 Business planning
· 	 Building three-way integrated 		
	 financial statement projections
· 	 Independent expert reviews
· 	 Key driver analysis
· 	 Model reviews / audits for internal 		
	 and external purposes
· 	 M&A work
· 	 Model scoping
· 	 Power BI, Power Query & Power Pivot
· 	 Project finance
· 	 Real options analysis
· 	 Refinancing / restructuring
· 	 Strategic modelling
· 	 Valuations
· 	 Working capital management
If you require modelling assistance of any 
kind, please do not hesitate to contact us 
at contact@sumproduct.com.

Training
SumProduct offers a wide range of 
training courses, aimed at finance 
professionals and budding Excel experts. 
Courses include Excel Tricks & Tips, 
Financial Modelling 101, Introduction to 
Forecasting and M&A Modelling. 

Drop us a line at training@sumproduct.com 
for a copy of the brochure or download  
it directly from
http://www.sumproduct.com/training.

Check out our 
more popular 
courses in 
our training 
brochure:

Key Strokes
Each newsletter, we’d like to introduce you to useful keystrokes you may or may not be aware of.  We’re still going through the 
function keys – this time, with the one everyone knows, the F9 function key:

There are over 540 keyboard shortcuts in Excel.  For a comprehensive list, please download our Excel file a
www.sumproduct.com/thought/keyboard-shortcuts. Also, check out our new daily Excel Tip of the Day feature on the 
www.sumproduct.com homepage.

Keystroke What it does

F9 Calculate now

CTRL + F9 Minimise window

SHIFT + F9 Calculate active sheet

CTRL + ALT + F9 Recalculate (full)

CTRL + ALT + SHIFT + F9 Recalculate (full rebuild – the “drains up” recalculation)

Have you heard about the 
SumProduct Referral programme? 
If you successfully introduce us to a 
client we will pay you 10% of the net 
profits of the engagement won upon 
receipt of client payment. Sounds like 
a pretty good deal to us!

Terms and conditions apply.  Referrer 
must be over 18 years of age, able 
to issue an invoice and not be an 
employee, director, agent or other 
related party of the client engaged.  
For further information, drop us a line 
at  contact@sumproduct.com.  We 
hope to hear from you!

Referral Programme

Melbourne Financial Modelling 5th - 6th Sep 2017 2 days

Melbourne Power Pivot, Power Query and Power BI 12th - 14th Sep 2017 3 days

Sydney Excel Tips & Tricks 25th Sep 2017 1 day

Sydney Financial Modelling 26th - 27th Sep 2017 2 days

Sydney Power Pivot, Power Query and Power BI 16th - 18th Oct 2017 3 days

Melbourne Excel Tips & Tricks 23rd Oct 2017 1 day

Melbourne Financial Modelling 24th - 25th Oct 2017 2 days

Sydney Visual Basic for Applications 6th Nov 2017 1 day

Sydney Excel Tips & Tricks 13th Nov 2017 1 day

Sydney Financial Modelling 14th - 15th Nov 2017 2 days

Melbourne Power Pivot, Power Query and Power BI 4th - 6th Dec 2017 3 days

Melbourne Excel Tips & Tricks 11th Dec 2017 1 day

Melbourne Financial Modelling 12th - 13th Dec 2017 2 days
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