
It was too late for our last newsletter, but late October saw Microsoft release its latest Power BI Desktop update, which probably contained the most 
feature updates yet.  Several new reporting features have been added, including a date slicer, the ability to snap to grid, grouping and a top N filter.

By area, the list of updates by category includes:

	 •		  Report View

			   o	 Date slicer
			   o	 Report gridlines and snap to grid (preview)
			   o	 Data label improvements
			   o	 Map formatting options
			   o	 Improved date axis range formatting

	 •	 	 Analytics

			   o	 Grouping
			   o	 Binning
			   o	 Top N filter
			   o	 Include / exclude data points
			   o	 R-powered custom visuals

	 •	 	 Data Connectors

			   o	 Microsoft Dynamics 365 for Financials
			   o	 OLEDB
			   o	 Mixpanel

NEWSLETTER #49 - December 2016

So now we are four! Wow, if someone had told us back when we started we could keep a monthly 
newsletter in Excel going four years later, I am sure someone would have commented we must lead pretty dull lives, ha ha.

Erm…

This month, we document updates for both Power BI and Excel 2016 (chart maps anyone?), report back on November’s 
Excel MVP Summit, provide further information on the upcoming Financial Modelling book, mention the annual Christmas 
Quiz (cash prizes!!) and continue our series on the A to Z of Excel Functions (will we ever get out of the A’s??).

That’s it until next year.  Seasons greetings to you all. Liam Bastick, Managing Director, SumProduct

Power BI Desktop Latest Update
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	 •		  Data Connectors

	 	 	 o	 Microsoft Dynamics 365 for Financials
	 	 	 o	 OLEDB
	 	 	 o	 Mixpanel

	 •	 	 Query Editing Improvements

	 	 	 o	 Support for table parameters in “Invoke Function” dialog

	 •	 	 Other Improvements

	 	 	 o	 Diagnostic information in the “About” dialog.

A summary of the major updates, can be found in Microsoft’s video here.

Date Slicer
Slicers are a great way for report authors to give their users a tool to quickly slice and dice the data they are seeing in a report.  A common request 
is that end users want to more easily filter a report based on dates.  In this latest release, existing slicers have been improved to do just that with a 
new slicer layout called date slicer.

To add a date slicer is very simple.  You use the standard slicer, and add a date field to it.  When you do this, by default the slicer shows as a date slicer 
that lets you set the start and end date for your date.  You can either use the sliders to set the dates or pick the date using a calendar.
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You can also change the mode to Before or After if you only need to control the last or first date used on your report page:

or switch back to the standard List view:

More details about th  data slicer may be found here.
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Report gridlines and snap to grid (preview)
A critical task for authoring a professional Power BI report is to make sure your visuals are lined up and look organised.  While you could do this in 
the past by manually entering in x and y coordinates on each visual or using the arrow keys to nudge visuals into place, anyone who has done this 
mind-numbing activity knows it is both a time-consuming and thankless task. 

It’s good then that Microsoft has released a preview of gridlines and snap to grid in Power BI Desktop.  This feature will allow you to enable gridlines 
on your report canvas while authoring, as well as the option to enable snapping to those gridlines.

To enable the preview feature, navigate to File > Options & Settings > Options > Preview Features. Check the “Gridlines and Snap to Grid” box and 
then restart the Desktop.

You’ll find the gridlines and snap to grid options in the View tab of the Ribbon.  You can choose to turn on one or both options to help you arrange 
your charts.

More details about gridlines and snap to grid can be found here.
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Data label improvements
In this release of Power BI Desktop, Microsoft has added several new data label capabilities to column, bar, and waterfall charts to help you design 
your visuals with labels.  For example, if you try to turn on data labels and none show, the software will highlight this immediately and proactively 
suggest some ways to fix this.

For column charts, you now have the option to change the orientation of your data labels between horizontal and vertical. This will help you fit longer 
data labels when you have less space for columns.

In addition, for bar, column, and waterfall charts, you can also change the position of the data labels so they will show up at specific locations.
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Finally, for bar and column charts that have a continuous axis, you can control how dense the data labels are, so you can show less or more data 
labels on the visual:

Again, more details about the data label improvements may be found here.

More details about the map improvements can be found here.

Map formatting options
There are two new formatting options added to the Bing Maps visual to help you customise your maps.  Depending on your data, the bubble sizes on 
the Bing Map control can sometimes end up being very small and hard to see.  The latest update adds a new card in the formatting pane on the map 
visual that allows you to control the size of the bubbles.

Improved date axis range formatting
When you have a measure or date on an axis, you can modify the start and end value of the axis in the formatting pane.  With this release, the 
start and end dates of your axis may now be selected by using a date picker. This makes setting your axis range much easier and faster than it was 
previously.  We like simple.

The maps already contain a feature where the zoom level of the map adjusts to show all the data on the map in the best way it can.  However, 
sometimes depending on the data, you might want to specify your own zoom level.  The late October update added the capability to disable auto 
zoom on the map and filled map visuals.  This will allow you to set the zoom level and have it stick, even if you are cross-highlighting the data using 
other visuals or slicers on the report.

Further details about the data axis range improvement may be found here.
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Grouping
In this release of Power BI Desktop, Microsoft has introduced the ability to group up points on your visual to help you more easily explore and analyse 
related categories.  To use the feature, select one or more points on a visual using CTRL + CLICK, right click one of the points, and select Group from 
the context menu:

When the group is created, it is automatically added to the legend section of your visual as well as the field list.  You can also find the new grouped 
field in the field list and use this new field just like any other field in visuals, including using it as the axis in charts.

You can edit existing groups by right clicking an already created group and selecting Edit Groups… from the context menu:
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In this dialog, you can create, manage and remove groups.  You can also decide whether non-grouped categories should be “bucketed” into another 
group or if they should remain ungrouped.

You can also create a new group from scratch using the right click menu and selecting Group...

You can also now create a group from the Field Well:
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Binning
In addition to grouping categories together, you can also now use binning on numerical and time fields.  
For example, if you have a SalesAmount field in your data and you want to see the user satisfaction 
across different sale sizes, you can use binning to create these sale size groups.  You can access binning 
by right clicking on the field and clicking Group…

In the dialog, you can define the bin size:

When done, it’s automatically added the field list, and you can start using this new grouping in your visuals. 

More details about binning are available here.

More details about grouping may be found here.

When you do this, it replaces the field in the axis with the new group:
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Top N filter
When analysing a dataset, you often want to look at categorical data and understand which are your best categories and which are your worst.  With 
this release, a new filter type called “Top B” has been added for categorical filters:

Include / exclude data points
When exploring your data, it’s often useful to focus on a specific set of points such as outliers that you’d like to investigate further.  In addition, 
you may want to remove specific points because you simply don’t want to focus on them.  You can now select one or more points and right click to 
include or exclude points in your visual.

Include will filter out all points except for those you’ve chosen to include.  Exclude will filter out the points you’ve chosen to exclude.  It’s not rocket 
science!

In the filter pane, you’ll see how many points 
have been excluded or included. When you 
expand the filter card, you’ll be able to see 
which points those were and can remove 
them from the filter.

You can specify that you’d like to filter by the Top or Bottom number of categories, sorted by a specific measure.  You will find the Top N filter in the 
filter pane as a Filter Type option for the category field you want to filter down.  You add the measure you want to filter with by dragging it into the 
By value bucket:

Yet again, more details about top N are available here.

More details about Include and Exclude are 
available here.
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Include / exclude data points
Power BI's R visuals integration adds advanced analytical depth and endless visualization flexibility to your Power BI reports.  These reports can then 
be viewed by all business users on the Power BI web service, not just R experts.  However, it still requires expertise in writing R scripts to create these 
reports.  

Not any more.  

With this release, Microsoft has simplified the custom visual experience to work with R visuals. Now, you can simply download a pre-built  
R-powered custom visual from the custom visual's gallery instead of having to build it yourself. R-powered custom visuals may be downloaded from 
http://app.powerbi.com/visuals under the R-powered visuals tab.

When you select a visual in the custom visuals gallery, you can download the visual or a sample .pbix file using the visual:

Once you have downloaded the visual you want to use to your computer, you can load it into the Desktop using the normal 
custom visual import experience:
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If the visual needs special R packages, the Desktop will prompt you to install them:

From here, you can use it just like a normal visual to do advanced analytics on your data. Once your report is completed, you can publish and share 
it out with your colleagues:
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Note that to use R visuals in the Power BI Desktop, you will need to install one of two R engines, either CRAN 3.3.1 or MRO 3.3.1.  You won't need to 
install anything to use them in the Power BI web service.

Once you select this connector, you can specify an OData URL and, optionally, a Company to navigate to available data:

Microsoft Dynamics 365 for Financials
One of the new connectors in this update allows you to import data from a Dynamics 365 for Financials accounts.  Should you have such an account, 
the connector can be found under the “Online Services” category:
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OLEDB
This update also enables connectivity to OLEDB drivers via the new OLEDB connector.  In addition to the wide range of out-of-the-box sources already 
supported, OLEDB greatly increases the number of sources that can be plugged into Power BI.  The new OLEDB connector can be found under the 
“Other” category within the “Get Data” dialog:

The connector dialog allows you to specify a connection string and, optionally, a SQL statement to execute.  If no SQL statement is specified, you will 
be taken into the Navigator dialog, where you can browse and select one or multiple tables available via the OLEDB driver.

Once this connector is selected, you can specify credentials to use for authentication.  Both Organizational Account and Basic (username/password) 
credential types are supported.
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Mixpanel
There is a new connector for Mixpanel, apparently one of the leading product analytics platforms available.  This new connector allows users to pull 
mobile and web analytics data from their Mixpanel accounts, in order to visualize it and create reports within Power BI.  The new Mixpanel connector 
can be found under the “Online Services” category in the “Get Data” dialog:

Once you select this connector, you can specify credentials (API Secret & Password) to use for authentication:

This allows you to browse available data in your accounts, in the form of tables or parameterised functions, that can be brought into Power BI.
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More details about the new data connectors are available here.

Support for table parameters in “Invoke Function” dialog
This update also enhances the “Invoke Function” experience to support parameters of type "Table".  When invoking a function that accepts a 
table parameter, either a built-in or user-defined function, you will be able to select an existing table query as the input value to the function.   
The following screenshot shows the “Invoke Function” experience for a built-in function, such as Table.Transpose:

This capability is also supported in the “Invoke Custom Function” dialog, allowing you to reference table queries when invoking their own defined 
functions.
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More details about table parameters supported in the Invoke Function dialog can be found here.

Well Tolstoy would have been proud of that “little list”.  If you are a regular user of Power BI, do remember that you can all still vote for other features 
that you would like to see in the Power BI Desktop by visiting www.powerbi.com.  And if you are not an experienced user but would like to find out 
more (including venturing on a training course) feel free to drop us a line at contact@sumproduct.com.

More details about the improved diagnostic information are available here.

Diagnostic information in the “About” dialog
You can now easily copy your session ID and diagnostic info to your clipboard.  You can find this diagnostic information under File > Help > About.  
This is very useful if you require the assistance of Microsoft’s support team.

Now this is more like it.  We finally get to one of those useful Excel functions you simply cannot live without.  The ARABIC function converts a Roman 
numeral to an Arabic numeral (that means “number” in English).

The ARABIC function employs the following syntax to operate:

ARABIC(text)

	 •	 text: this is a string enclosed in quotations marks or a reference to a cell containing text.  An example of an empty string is (“”). 

Please note:

	 •	 If Text is not valid, ARABIC will return an #VALUE! error value

	 •	Any value returned as #VALUE! error value includes numbers, date and text that is not a valid Roman numeral

The A to Z of Excel Functions: ARABIC
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	 •	 If an empty string is used as an input value, a value of 0 (zero) will be returned

	 •	 The largest number that can be returned is 255,000, allowing the maximum length of the argument to be 255 characters

	 •	When the text argument is ignored.  MXMVII evaluates to the same result (1997) as “MXMVII”

	 •	Although a negative Roman number is non-standard, evaluation of a negative Roman numeral is supported, provided it is entered as a text 	
	 	 string.  Insert the negative sign before the Roman text, such as “-MMXI”

	 •	 Leading and trailing spaces are ignored in the syntax

	 •	 The ARABIC function performs the opposite action for the ROMAN function, albeit it is a little more versatile as ROMAN only calculates positive 	
	 	 integers no greater than 3,999.

Here are some examples:

When used, the AREAS function returns the number of areas in a reference.  An area is a range of continuous cells or a single cell.  If a range is made 
up of contiguous cells, the range number is based on the number of separate references (please see the second example below).  

We’re not 100% sure where you might use this though other than in a newsletter series covering all of Excel’s functions…

The AREAS function employs the following syntax to operate:

AREAS(reference)

	 •		  reference: a reference to a cell or range of cells and can refer to multiple areas.  If you wish to specify several references as a single argument,  
			   then you must include extra set of parentheses so that Microsoft Excel will not interpret the comma as a field separator.

Some examples:

The A to Z of Excel Functions: AREAS

The A to Z of Excel Functions: ASC
For double-byte character set (DBCS) languages, the ASC function changes full-width (double-byte) characters (katakana) to half-width (single-byte) 
characters.

The ASC function employs the following syntax to operate:

ASC(text)

The ASC function has the following argument only:

	 •		  text: this is required.  The text or a reference to a cell that contains the text you want to change.  If text does not contain any full-width 	
			   letters, text is not changed.

The opposite function, converting half-width (single-byte) characters to full-width (double-byte) characters (katakana), is the WIDECHAR(text) 
function.  Our regular blog series will probably get to this function about 14 years from now 

Some ideas:

=ASC("SumProduct") equals "SumProduct"

=ASC("                      ") equals "           "

=ASC(“E X C E L ”) equals “EXCEL”
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November sees some new and improved features for Excel 2016.  You might not see them straight away – it will depend upon what version of Excel 
2016 you have.  Presently, the following feature updates are available to Office 365 subscribers only.  Firstly, they will first roll out to Office Insider 
participants, and later to consumer and commercial Office 365 subscribers.  If you have an Office 365 subscription, you still need to make sure you 
have the latest version of Office.

The updates include:

	 •	New map charts
		  You can create a map chart to compare values and show categories across geographical regions.  This feature may be used when you have 	
		  geographical regions in your data, like countries / regions, states, provinces, counties or postal codes.  

 
 
 
 

	 •	New icons available on the Insert tab 
		  That's not all.  If you find yourself needing to insert an icon that conveys a certain idea or concept, check out the Icon button on the Insert tab.  	
		  You can choose a category like people, technology, or sports and then click the icon that represents the idea or concept you have in mind.

	 •	Quickly save to recent folders 
		  Now this one we do like (and about time too)!  This feature has been highly requested: Go to File > Save As > Recent, and you’ll see a list of 	
		  recently accessed folders that you can save to.  This will save us nearly 30 seconds a day!

	 •	Accessibility improvements 
		  Microsoft had also have improved its support for Narrator and other assistive technology that lets you read cells, create tables, sort data and 	
		  more

	 •	 Share your workbooks with others
		  If you are sharing your workbook using OneDrive, OneDrive for Business, or SharePoint, you can do all your sharing without leaving the  
		  comforts of Excel.  All you have to do is click on the 'Share' button in the top right corner of the Ribbon, send as an attachment and select 	
		  'Send a PDF'.  

November Updates for Excel 2016
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We mentioned a while ago that SumProduct author Liam Bastick had a book coming out shortly.  Thank 
you to all those of you who have enquired about it subsequently.  It was originally scheduled for a 
November release but due to circumstances beyond our control, publication has been put back to the 
new year.

They say every cloud has a silver lining and that’s certainly true here.  With the unexpected delay, it has 
given us time to re-write certain areas and add new ideas. The book was originally based on our hugely 
successful Financial Modelling training course and we can promise it will now be even more packed 
with useful tips and tricks, key layout ideas and stupid jokes.  Uh oh, there goes the sales pitch…

Book Update

As long as Liam Bastick remains an Excel Most Valuable Professional 
(MVP), November means a trip to the hallowed halls of Redmond 
(Washington State) for five days to go and liaise with the Excel product 
team about what’s coming in the near future and what’s on the mid-term 
horizon.  It was especially interesting this year given we think there might 
have been some sort of election going on...

This year’s sessions were particularly fruitful as several MVPs (including 
Liam) were involved in focus groups to discuss key issues / problems 
Microsoft were working on.  Obviously, most of the discussions are 
confidential, but some of the time was spent on showcasing what’s 
around the corner for Excel.  One such new feature has already been 
made public – the new chart maps which you can read about elsewhere 
in this newsletter.  We’ll break news on other features as we are allowed 
to do so.  Watch this space!

November MVP Summit Update

Pictured above: Many of the Excel MVPs as they queued for the toilet.

SumProduct, in conjunction with the Chartered Institute of Management Accountants (CIMA), is pleased to 
announce the annual Xmas quiz, although we gather it may be renamed this year in order to meet with more 
universal appeal.  It’s open to everyone, not just accountants.  Check out the Excel challenge – with prizes 
– in the December issue of CIMA’s Insight magazine.  Unfortunately, due to the deadlines surrounding this 
newsletter, we cannot provide a URL at this stage.  We suggest you check the Blog and News sections of our 
website (www.sumproduct.com) for full details once the quiz goes “live”.

Good luck!

Christmas Quiz Challenge

Early December sees us in London for client meetings, presentations on Power BI and Excel Tricks & Tips (5 and 6 December) for Microsoft at the 
Global Training Camp and possibly taking in the finals of ModelOff as well (we’re still waiting on our invite there…).  Congratulations to last year’s 
winner and fellow Aussie Joseph Lau who has made it through to the Final 20 yet again!

If you are in the area (see here for further details), drop in and say hello.  If you’d like to meet up, let us know beforehand by emailing us at  
contact@sumproduct.com.

London Activities
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Link to Others
These newsletters are not intended to be 
closely guarded secrets.  Please feel free 
to forward this newsletter to anyone you 
think might be interested in converting to 

“the SumProduct way”.

If you have received a forwarded 
newsletter and would like to receive 
future editions automatically, please 

subscribe by completing our newsletter 
registration process found at the foot of 
any www.sumproduct.com web page.

Any Questions?
If you have any tips, comments or queries 
for future newsletters, we’d be delighted 
to hear from you. Please drop us a line at 

newsletter@sumproduct.com.

Our Services
We have undertaken a vast array of 
assignments over the years, including:
· 	 Business planning
· 	 Building three-way integrated 		
	 financial statement projections
· 	 Independent expert reviews
· 	 Key driver analysis
· 	 Model reviews / audits for internal 		
	 and external purposes
· 	 M&A work
· 	 Model scoping
· 	 Power BI, Power Query & Power Pivot
· 	 Project finance
· 	 Real options analysis
· 	 Refinancing / restructuring
· 	 Strategic modelling
· 	 Valuations
· 	 Working capital management
If you require modelling assistance of any 
kind, please do not hesitate to contact us 
at contact@sumproduct.com.

Training
SumProduct offers a wide range of 
training courses, aimed at finance 
professionals and budding Excel experts. 
Courses include Excel Tricks & Tips, 
Financial Modelling 101, Introduction to 
Forecasting and M&A Modelling. 

Drop us a line at training@sumproduct.com 
for a copy of the brochure or download  
it directly from
http://www.sumproduct.com/training.

Check out our 
more popular 
courses in 
our training 
brochure:

Location Course Date Duration

Sydney Power Pivot, Power Query and Power BI 12th - 14th Dec 2016 3 days

Sydney Visual Basic and Excel 15th Dec 2016 1 day

Melbourne Financial Modelling for Mergers and 
Acquisitions 6th - 9th Feb 2017 4 days

Sydney Excel Tips and Tricks 6th Feb 2017 1 day

Sydney Financial Modelling 7th - 8th Feb 2017 2 days

Melbourne Power Pivot, Power Query and Power BI 20th - 22nd Feb 2017 3 days

Toronto Financial Modelling 6th - 7th Mar 2017 2 days

Toronto Power Pivot, Power Query and Power BI 8th - 10th Mar 2017 3 days

New York Financial Modelling 13th - 14th Mar 2017 2 days

New York Power Pivot, Power Query and Power BI 15th - 17th Mar 2017 3 days

Melbourne Financial Modelling 22nd - 23rd Mar 2017 2 days

Sydney Power Pivot, Power Query and Power BI 24th - 26th Mar 2017 3 days

Upcoming SumProduct Training Courses

Key Strokes
Each newsletter, we’d like to introduce you to useful keystrokes you may or may not be aware of.  This month we decided we’d continue 
going through the function keys with the F4 function key:

There are over 540 keyboard shortcuts in Excel.  For a comprehensive list, please download our Excel file a
www.sumproduct.com/thought/keyboard-shortcuts. Also, check out our new daily Excel Tip of the Day feature on the 
www.sumproduct.com homepage.

Keystroke What it does

F4 (in spreadsheet) Redo

F4 (in Edit mode) Toggle anchoring ($ references)

ALT + F4 Close application

CTRL + F4 Close window

SHIFT + F4 Find next (from most recent search)

ALT + SHIFT + F4 Close application (again!)

CTRL + ALT + F4 Close application (sensing a theme yet?)

CTRL + SHIFT + F4 Find previous (from most recent search)

CTRL + ALT + SHIFT + F4 Close application (just why do we need so many alternatives?)

Have you heard about the SumProduct 
Referral programme? If you successfully 
introduce us to a client we will pay you 10% 
of the net profits of the engagement won 
upon receipt of client payment. Sounds like 
a pretty good deal to us!

Terms and conditions apply.  Referrer must 
be over 18 years of age, able to issue an 
invoice and not be an employee, director, 
agent or other related party of the client 
engaged.  For further information, drop us a 
line at  contact@sumproduct.com.  We hope 
to hear from you!

Referral Programme

mailto:contact@sumproduct.com
http://www.sumproduct.com
http://www.sumproduct.com
mailto:newsletter@sumproduct.com
mailto:contact@sumproduct.com
mailto:training%40sumproduct.com?subject=
http://www.sumproduct.com/training
http://www.sumproduct.com/thought/keyboard-shortcuts
http://www.sumproduct.com
mailto:contact%40sumproduct.com?subject=

