
NEWSLETTER #44 - July 2016

I think this is a record… it’s been a busy six months for SumProduct.   
We have a few announcements to make, with a new Blog section on the website, two new offices in New York and 
London and a move into larger premises in Sydney.  Things are definitely on the up and up!  All this news adds up to our 
largest newsletter ever.

We also take a look at further improvements to Power Query (Excel 2010 and 2013) / Get & Transform (Excel 2016), 
discuss the new Office Insider Fast programme, look back at the recent accounting events and the Amsterdam Excel 
Summit and, in the first of a five-part series, take a look at some of the pertinent specifications and limitations of Excel.

With the usual keyboard shortcuts and links to updated training and other resources, it’s a gargantuan beast of a 
newsletter this month.

Until next month. Liam Bastick, Managing Director, SumProduct

We promised you new features on the web site and 
our latest update sees a new Blog section, which 
went live back in early June.  Hopefully, some of 
you have already paid us a visit.  We are planning 
to find something to blog about every Monday, 
Wednesday and Friday, with various useful titbits, 
including what’s going on in our world, an on-
going A to Z of Excel Functions serial (ACCRINTM 
is simply to die for, he lied) and call-outs for 
ideas / suggestions.  For would-be developers / 
marketers, please feel free to drop us a line with 
any suggestions at contact@sumproduct.com.  
We can’t promise we can mention everything, but 
we promise to take a look.

Talking of the A to Z of Excel Functions, we thought we’d reproduce the 
first one here to show you what you are missing if you’re not checking 
out Blog.  If we reproduce one a month, we might take a while to get to 
Z though…

The ABS Function
When the ABS function is applied it returns the absolute value of a cell.  
The absolute value is the number is the value excluding sign (i.e. the 
notation that determines whether it is positive or negative).  Think of it 
as a useful way to determine the distance between two points, ignoring 
direction.

The syntax is very simple:			 

				    =ABS(number)

Please see the examples below:

For those who may get an error back from the ABS function, it is possible 
that that the number you used was actually a text value: ensure the 
number is numeric.	

Something to Blog about

The A to Z of Excel Functions: ABS
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SumProduct is excited to announce the opening of our New York office at long last!  With various training work and past clients in the US, our new 
New York office allows us to better connect and assist our current and future American clients.

If New York wasn’t enough, SumProduct’s plans for world domination continue with a London office too.  In order to make SumProduct’s services 
more available to our UK and European clients, we are moving in to the City of London too.

And if New York and London wasn’t enough…
SumProduct has also decided that Sydney needed more room for a growing team and have re-located to a new Sydney office.  As of the July 1, you 
can now find us at Suite 52, 88 Pitt Street Sydney. For those of you who may know our previous office location, you’d know that we are quite literally 
moving down and around the corner.

New York Office

London Office

Sydney Office

Our office is located at 48 Wall Street, in 
between Federal Hall and the New York Stock 
Exchange.
For all enquiries please see our contact details:
Address:
48 Wall Street, New York, NY
USA 10005
Phone:
+1 347 344 5778

For all enquiries please see our contact details:
Address:
Office 7, 35-37 Ludgate Hill  
London, EC4M 7JN, UK
Phone:
+44 20 3769 6936

For all enquiries please see our contact details: 
Address:
Suite 52, Level 10, 88 Pitt Street 
Sydney, NSW 2000
Phone:
+61 2 8599 7504

Now which one is Liam’s boat (yeah, right)..?

For anyone who isn’t familiar with Sydney CBD, SumProduct will be situated between George Street and Castlereagh Street, near the Reserve Bank 
of Australia, Martin Place Station, Channel 7 and the NSW Treasury.
In Sydney alone, we’ve had the pleasure of working with some great companies that include National Australia Bank, the NSW Treasury and 
Helmsman.  We endeavour to continue providing high quality work for current and future clients. 
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Too late for our June newsletter, Microsoft released a further 10 updates and improvements for Get & Transform in Excel 2016 and the Power Query 
add-in (Excel 2010 / 2013).  For Excel 2016, these updates are available as part of an Office 365 subscription.  However, if you work in Excel 2010 or 
Excel 2013 you too can take advantage of the new updates by downloading the latest Power Query for Excel add-in.  Allow us to take you through 
the latest improvements.

2. Convert Duration 
Values to Years
Another improvement is now 
having the ability to calculate 
total years based on a 
Duration type column.  This 
is found within the Duration 
drop-down menu is the new 
feature “Total Years”.  When 
in use, the logic applied is 
capable of dividing the total 
number of days by 365.

3. Keep Duplicates
Keep Duplicates is a new 
feature allowing users to 
keep only the rows with 
duplicated values on the 
selected column(s).  Prior to 
this update, users could only 
“Remove Duplicates”.  To use 
this new update simply go to 
your Ribbon and select Home 
-> Remove Duplicates split 
button and then select the 
Keep Duplicates command.

Get & Transform Transformed Again

1. Remove blanks via 		
Column Filter menu
A new data filtering option has 
been added, now allowing you 
to remove all rows where the 
value for the current column is 
either null or empty.  To access 
this new feature, simply select 
the Column Filter menu  
drop-down: >
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4. Hints for “sample input 
values” in the “Change 
Type with Locale”  
dialog box
Users can change the type of 
column, taking into account 
the Locale or regional settings 
/ formats in which the data is 
being represented.  To do this, 
it must be by setting the Locale 
value for the entire workbook 
(under Data -> New Query 
-> Query Options -> Current 
Workbook -> Data Load).  This 
can also be customised for each 
specific “Change Type” step in 
the queries.

5. Support for whitespace 
and line feeds in the 
Query Editor preview
Within the Query Editor 
preview, support for visualising 
whitespaces in data cells has 
been added. This includes 
any whitespace characters, 
including line feeds.  You can 
select “Show Whitespace”, 
which is the new default, or not 
show it (old behaviour) from the 
View tab on the Query Editor 
Ribbon.

6. Ability to disable 
previews from Navigator 
window
A disable preview option has 
been added to the Navigator 
dialog box. This ensures users 
can reduce the number of calls 
being made to the data source 
in order to retrieve these 
previews.

Within the “Change Type with Locale” dialog box (accessible by right-clicking on a column header in the Query 
Editor preview then selecting Change Type -> Using Locale…), users can also now get a few “sample values” for 
the expected input format when selecting a specific data type and locale.
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7. Technical name support in the Navigator window
A new option has been to the Navigator dialog that allows users to switch between “physical name” and “technical name”.  Some data sources 
support the notion of a “technical name” for objects within the source.  The intent of a “technical name” (which is the new behaviour) is to provide 
a more meaningful name for the user connecting to the data source than the “physical name” (previous behaviour) for the object.

8. Rename queries 
directly from the Queries 
pane in the Query Editor
Users can now rename queries 
directly from the Queries pane 
inside the Query Editor.  To do 
this, simply select and right-click 
the query and select Rename, 
or double-click the query name, 
or select it and press F2.

9. Support for Command 
Timeout in the UX
With this update, users are now 
able to specify a Command 
Timeout value (in minutes) 
when connecting to database 
sources. This is a significant 
experience improvement 
since, before this update, this 
customization was only possible 
via custom formula authoring.
This new Command Timeout 
option can be found under the 
“Advanced options” section in 
data source dialogs.

Power Query allows users to combine data from multiple data sources 
into a single workbook.  When dealing with multiple data sources, it is 
possible for users to define queries that require sending data from one 
data source to another data source.  To prevent accidental disclosure 
of private or enterprise data, Power Query provides a feature called 
“Privacy Levels”.  This feature allows users to specify the Privacy Level 
(Public, Organizational or Private) for each data source that they connect 
to when trying to combine data from multiple sources.  Based upon 
the selected Privacy Level, Power Query will ensure that data from a 
Private source is not sent to any other sources and that data from an 
Organizational source is only sent to sources within the organisation.
In some cases, this privacy enforcement can get in the way for users 
who want to define some data combinations that bypass this Privacy 
feature.  Another potential effect of Privacy Levels is that, when 
combining data from multiple sources that are not supposed to  
send data between them due to their Privacy Levels, Power Query 
will compensate and download the data locally to perform the data 
combination in a secure way.  This could result in a performance 
degradation due to the fact that data would have to be cached locally from 
all sources implied and combined in-memory.  For those cases, users have 
the ability to ignore Privacy Levels as a “current workbook” setting.

However, given that this option was only available per file and per user, 
it would require a user to enable this option for each workbook they 
would like to leverage.  In addition, ignoring this privacy protection needs 
to be approved by each user of the workbook, so someone opening an 
.xlsx file from a different user in their computer would have to either 
provide Privacy Levels for the data sources involved on the report or 
manually disable this feature in the Options dialog (under Query Options 
-> Current Workbook -> Privacy section).
 In this release, Microsoft has introduced a new setting to allow 		
users and enterprises to pick one of the following behaviours:	
	 •	 Always combine data according to your Privacy Level settings for  
		  each source—This new option allows a user to “enforce” that 		
		  Privacy Levels are taken into account for every .xlsx file on their 		
		  machine, regardless of whether the “Current Workbook” Privacy 	
		  Level setting is enabled or disabled
	 •	 Combine data according to each file’s Privacy Level settings.  This 	
		  is the default behaviour and matches the Power Query behaviour in 	
		  previous releases
	 •	 Always ignore Privacy Level settings—This new option allows a user 	
		  to always bypass Privacy Level settings for every .xlsx file in their 	
		  machine, regardless of the Current Workbook setting.

10. Set to disable Privacy Level prompts at machine level (including Registry Key)
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These options are available to the user under the Query Options dialog box:

Microsoft notes that the newest set of updates are powerful, fast and boast easy data gathering and shaping.  These updates can be found under 
the Get & Transform section on the Data Ribbon as a part of an Office 365 subscription.  

We actually got it into this newsletter (only just, mind you!!).  June 21 saw Microsoft issue a further four new or improved features:

	 • 	Conditional Columns
	 • 	Column type indicator in Query Editor preview column headers
	 • 	Reorder Queries and Query Groups inside Query Editor via drag and drop gestures
	 • 	Query Management menu in Query Editor.

In case you hadn’t quite had enough of Power Query this month, allow us to detail these newcomers too…

STOP PRESS – A further four updates for Power Query / Get & Transform

1. Conditional Columns
With this update, Microsoft is trying to make it easier for users to 
create new columns in their queries based on values from a different 
column.  A typical use case for this includes creating a set of “buckets” 
or “categories” based on ranges from a continuous value column.  For 
example, you might wish to categorise students’ marks as “Grade A”, 
“Grade B”, “Grade C”, “Grade D” and “Grade E”.  
Previously, this could be achieved by creating Custom Columns and 
capturing the conditional logic with a set of “IF THEN ELSE” statements.  

Anyone who has ever had to maintain these types of calculations will 
appreciate that this can very soon become extremely complex to author, 
update and edit as logic is refined and / or amended.
Starting with this update, users can now define a set of rules and output 
values for the new column based on values in other columns within their 
tables.  This can be achieved via the new Conditional Columns dialog, 
available in the Query Editor under the “Add Column” tab on the Ribbon.
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2. Column type indicator 
in Query Editor preview 
column headers
Microsoft has now added 
column type indicators in 
column headers within 
the Query Editor preview.  
These new column type 
indicators allow you to quickly 
understand the types for 
each of the columns in your 
table, as well as being able to 
change them to another type 
by clicking on these indicators 
or by using the previously 
available Ribbon options (Data 
Type drop-down menu at the 
Home tab on the Ribbon or 
Detect Type command under 
the Transform tab).

3. Reorder Queries and 
Query Groups inside 
Query Editor via drag 
and drop gestures
Users can also now easily 
reorder queries and query 
groups within the Queries pane 
inside Query Editor by selecting 
one or multiple objects and 
dragging and dropping them 
into the desired destination.  
This can be used to reorder 
items within a given group (or 
top level) and also to move 
objects into a query group.
Adding drag and drop gestures 
to the Queries pane inside 
Query Editor greatly improves 
the user experience for 
reorganizing queries and query 
groups, which was previously 
only possible via Context Menu 
options.

4. Query Management 
menu in Query Editor
With this update, Microsoft 
has announced they are 
“exposing” a new “Manage” 
drop-down menu for a query 
within the Query Editor Home 
tab on the Ribbon.  We hope 
they don’t get arrested for it.  
This menu exposes common 
management operations 
for a query, such as Delete, 
Duplicate and Reference.

Phew. Any more updates will 
have to wait until the next 
newsletter!!
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June has been a busy month for SumProduct in the accounting 
world Down Under.  Four presentations (two on Power Pivot, one on 
financial modelling and another on key Excel functions) have been 
presented to members and students of the Chartered Accountants 
[of] Australia and New Zealand (CAANZ), Certified Practising 
Accountants (CPA) and the Chartered Institute of Management 
Accountants (CIMA) in several locations, including Perth and 
Melbourne.  But it doesn’t stop there.  We have more sessions 
anticipated in the next few months in Auckland, Brisbane, Darwin, 
London and Sydney.  And that’s just for accountants.
Whilst SumProduct specialises in the accounting, analytical, Excel, 
modelling and training needs of finance professionals, we are 
also happy to present at other events in various industries and 
academia worldwide.  If you are interested in such a presentation, 
as long as you are happy to stump up travel costs and allow us to 
circulate our business cards, we are happy to present.  We have 
laptops and passports, will travel.  If interested, drop us a line at  
contact@sumproduct.com.

(No?) Accounting for Taste

There is nothing wrong with your computer.  Do not attempt to adjust the Excel settings.  
Microsoft is now in control of the transmission.  They control the horizontal and the vertical.  
They can deluge you with a thousand errors, or expand one single cell to crystal clarity and 
beyond.  Excel can shape your vision to anything your imagination can conceive.  For the next 
paragraph, Excel will control all that you see and hear as we take you to the Outer Limits of Excel.

Not quite sure how many copyrights were breached in that last parody, but you get the idea.  One 
question we often get asked is about the limitations and specifications of Excel. In the first of a 
five-part series, this month we look at PivotTable and PivotChart specifications and limitations.

The Outer Limits, Episode 1

Feature Maximum Limit

Calculated item formulas in a PivotChart report Limited by available memory

Calculated item formulas in a PivotTable report Limited by available memory

Items displayed in filter drop-down lists 10,000 (Excel 2007 and later); 1,000 previously

Length for a relational PivotTable string 32,767 characters

Length of the MDX name for a PivotTable item 32,767 characters

PivotTable reports on a sheet Limited by available memory

Report filters in a PivotChart report 256 (although this may be limited by available memory)

Report filters in a PivotTable repor 256 (although this may be limited by available memory)

Row or column fields in a PivotTable report Limited by available memory

Unique items per field 1,048,576

Value fields in a PivotChart report 256

Value fields in a PivotTable report 256

Calculated item formulas in a PivotChart report Limited by available memory
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The third Amsterdam Excel Summit took place back in late May but 
was too late to be reported upon in last month’s newsletter.  This 
two-day summit proved to be successful and included many insightful 
presentations from various Excel experts / MVPs.
From Israel, Microsoft’s Excel team program manager Yigal Edery 
opened the Summit and spoke in detail about the Excel Power BI tools 
and what users should expect in the future.  Attendees then heard from 
our own Excel Summit South presenter Jon Peltier, who explained how 
to automate tedious charting chores using a bit of VBA.  Fellow Excel 
Summit Southerner Charles Williams then explained “all that is evil” 
functions.  Henk Vlootman then changed the tone as he demonstrated 
how to set up a Power Pivot model.  Up next, long-time MVP Bob Umlas, 
the master of Excel tips and tricks, shared his knowledge to illustrate to 
attendees how to apply various cool tricks to your everyday Excel work. 
Finally, Guy Hunk (cool name!), another Program Manager from the 

Microsoft Israel team, gave the audience a Power Query demonstration 
highlighting the software’s current capabilities.
The second day was essentially an Excel Charting and Dashboard 
Masterclass this time around.  It began with David Hoppe, a runner-
up of the 2014 Chandoo Dashboard contest, speaking to the audience 
about how he constructs his own dashboards.  Jon Peltier, Charting 
Guru extraordinaire, then added his two cents on how charts should be 
developed.  Tony de Jonker continued the theme by discussing objects 
on charts.
In summary, this year’s Amsterdam Excel Summit continued its fine 
tradition of useful topics presented by experts.  If you missed out this 
year, the Summit will return to Amsterdam in May 2017, just after the 
Excel Summit South returns to the Australia / New Zealand region. Keep 
your eyes peeled for confirmed dates for both.

If you are a commercial Office 365 subscriber who would 
like early access to Microsoft’s new features, then this may 
be something worth considering.  As mentioned in earlier 
newsletters, Office Insider is a preview program for Office 
365 users.  This easy-to-install upgrade will allow you access 
to the new Office innovations.  Office Insider is available on 
Windows, desktop and mobile, for both Mac and Android.  
It’s now available in two versions: Fast and Slow.
So, what’s the difference between Insider Fast and Insider 
Slow?  Insider Slow is the option that was originally offered 
to Mac users (no comment, ha ha), working most efficiently 
for users who want early access to a fully supported Office 
2016 for Mac build.  In the past one or two new releases 
have been released each month.

Pictures courtesy of Jan Karel Pieterse

Office Insider – Fast or Slow?

Have you heard about the SumProduct Referral programme? If you successfully introduce 
us to a client we will pay you 10% of the net profits of the engagement won upon receipt of 
client payment. Sounds like a pretty good deal to us!
Terms and conditions apply.  Referrer must be over 18 years of age, able to issue an invoice 
and not be an employee, director, agent or other related party of the client engaged.  For 
further information, drop us a line at contact@sumproduct.com.  We hope to hear from you!

Referral Programme

Office Insider Fast is a new option, aimed for Insiders who want to the use the builds as soon as they are available.  Users who choose this option will 
be in the driving seat to assist improving quality and influence features.  Insider Fast will prove most effect for those who don’t mind the risks inherent 
in using unsupported builds.  Moving forward, Microsoft plans to release Insider Fast updates to Mac Insiders on a weekly basis, however Microsoft 
may produce builds that don’t necessarily meet the quality bar.
To opt out of being an Office Insider, open any Office 2016 app. Click Help -> Check for Updates. The Microsoft AutoUpdate dialog box will appear: 
clear the Join the Office Insider program to get early access to new releases check box.  Do note that if the reason why you’re opting out is due to a 
blocking issue, please note you must uninstall Office 2016 and then reinstall.
Microsoft is encouraging users to provide them with any and all feedback. To tell them what you think click Tell Us What You Like or Tell Us What Can 
Be Better in the upper-left corner of any app. You could also post your feedback in the Office Insider Community.
For further information, or to install please follow this link Office Insider page here: https://products.office.com/en-AU/office-insider.

Amsterdam Excel Summit
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Sydney Address:	 SumProduct Pty Ltd, Suite 52, Level 10, 88 Pitt Street, Sydney, NSW 2000
New York Address:	 SumProduct Pty Ltd, 48 Wall Street, New York, NY, USA 10005
London Address:	 SumProduct Pty Ltd, Office 7, 3537 Ludgate Hill, London, EC4M 7JN, UK
Melbourne Address:	SumProduct Pty Ltd, Level 9, 440 Collins Street, Melbourne, VIC 3000
Registered Address:	SumProduct Pty Ltd, Level 6, 468 St Kilda Road, Melbourne, VIC 3004

Link to Others
These newsletters are not intended to be 
closely guarded secrets.  Please feel free 
to forward this newsletter to anyone you 
think might be interested in converting to 

“the SumProduct way”.

If you have received a forwarded 
newsletter and would like to receive 
future editions automatically, please 

subscribe by completing our newsletter 
registration process found at the foot of 

Any Questions?
If you have any tips, comments or queries 
for future newsletters, we’d be delighted 
to hear from you. Please drop us a line at 

newsletter@sumproduct.com.

Our Services
We have undertaken a vast array of 
assignments over the years, including:
· 	 Business planning
· 	 Building three-way integrated 		
	 financial statement projections
· 	 Independent expert reviews
· 	 Key driver analysis
· 	 Model reviews / audits for internal 		
	 and external purposes
· 	 M&A work
· 	 Model scoping
· 	 Power BI, Power Query & Power Pivot
· 	 Project finance
· 	 Real options analysis
· 	 Refinancing / restructuring
· 	 Strategic modelling
· 	 Valuations
· 	 Working capital management
If you require modelling assistance of any 
kind, please do not hesitate to contact us 
at contact@sumproduct.com.

Training
SumProduct offers a wide range of 
training courses, aimed at finance 
professionals and budding Excel experts. 
Courses include Excel Tricks & Tips, 
Financial Modelling 101, Introduction to 
Forecasting and M&A Modelling. 

Drop us a line at training@sumproduct.com 
for a copy of the brochure or download  
it directly from
http://www.sumproduct.com/training.

Check out our 
more popular 
courses in 
our training 
brochure:

Location Course Date Duration

Sydney Excel Tips and Tricks 8th Aug 2016 1 day

Sydney Financial Modelling 9th - 10th Aug 2016 2 days

Melbourne Excel Tips and Tricks 29th Aug 2016 1 day

Melbourne Financial Modelling 30th - 31th Aug 2016 2 days

Sydney Power of Power Pivot 19th - 20th Sept 2016 2 days

Melbourne Power of Power Pivot 4th - 5th Oct 2016 2 days

Perth Financial Modelling 10th - 11th Oct 2016 2 days

Brisbane Financial Modelling 20th - 21st Oct 2016 2 days

Darwin Excel Tips and Tricks 9th Nov 2016 1 day

Upcoming SumProduct Training Courses

Key Strokes
Each newsletter, we’d like to introduce you to useful keystrokes you may or may not be aware of.  This month we decided we’d be clear 
about deleting:

And these alternatives don’t begin address mouse-related solutions!
There are over 540 keyboard shortcuts in Excel.  For a comprehensive list, please download our Excel file a
www.sumproduct.com/thought/keyboard-shortcuts. Also, check out our new daily Excel Tip of the Day feature on the 
www.sumproduct.com homepage.

Keystroke What it does

BACKSPACE Edit and clear

DELETE Clear

SHIFT + DELETE Cut

CTRL + DELETE Clear

CTRL + ALT + DELETE Not used for anything important, ever…

CTRL + X Cut

F2 Edit
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