
NEWSLETTER #42 - May 2016

It ’s time to play 20 Questions this month 
as we play catch up on some readers’ questions.  You may have noticed that the last few months we’ve not responded to 
many due to fairly full newsletters.  So this month we thought we’d make it up to you!

That doesn’t mean we don’t mention anything else here though.  For those of you in Europe, the Amsterdam Excel 
Summit is nigh upon you and it’s not too late to grab a ticket and pick the brains of the Excel experts.  

We also take a high-level summary look at Zebra BI, a business intelligence tool for add-in, so with our usual mentions of 
training and keyboard shortcuts, hopefully there’s a little something for everyone.

Until next month.

Liam Bastick, Managing Director, SumProduct

This month we thought we’d play catch up on recent readers’ questions.  Here’s a 20/20 view of the Excel world…

20 Questions 

contact@sumproduct.com  | www.sumproduct.com  | +61 3 9020 2071 

www.sumproduct.com  |  www.sumproduct.com/thought

Question Answer

1 What is the maximum number of functions you 
nest in an Excel formula?

Excel 2003 and earlier allows seven nesting levels; Excel 2007 and later allows 64.  
We will only allow you two.  After this you will be taken outside and shot.
Nesting functions usually occur when the modeller is unaware there is a better  
function / formula to use.

2 How do you round a number to the nearest odd 
or even number?

Use the formulae

=ODD(ROUND(Number,0)) and =EVEN(ROUND(Number,0))

3 Is it possible to select all objects in a sheet 
simultaneously?

Yes:
 • Press the shortcut key F5 to open the ‘Go To’ dialog box
 • Click on the ‘Special…’ button
 • Select ‘Objects’ radio button
 • Click ‘OK’
 • All objects will get selected
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4 I notice if I enter ‘January’ in one cell and then 
‘February’ in the next cell and drag down (or 
across) the remaining months autofill.  Is it pos-
sible to do this with common lists used at my 
company?

Absolutely!  Assuming you are in Excel 2007 or later, go to ‘Excel Options’  
(ALT + T + O) and select ‘Advanced’ from the column menu.  Scroll down the main 
pane to ‘General’ and click on the ‘Edit Custom Lists…’ button.  Type in your list or 
import it from an Excel range and click the ‘Add’ button.  Done!

5 I cannot find where something is on the Ribbon 
– or even if it is there.  How can I find it and 
make it easier to find going forward?

Microsoft has developed a range of interactive guides such as those that can be 
found at https://www.microsoft.com/en-us/download/search.aspx?q=interactive+m
enu+to+ribbon+guide.

They are ok, but another useful resource often forgotten about is the Quick Access 
Toolbar.  Right-click on the Quick Access Toolbar in Excel and then choose  
‘Customize Quick Access Toolbar…’ from the shortcut menu (or else select ‘Excel  
Options, ALT + T + O and then ‘Quick Access Toolbar’ from the columnar menu).  
Select ‘All Commands’ from the ‘Choose commands from:’ drop down menu.  All 
commands will be listed alphabetically in the pane below the drop down box.  Seek 
out what you are looking for, highlight the command and press the ‘Add’ button.   
It will now be on your Quick Access toolbar for easy future access.

6 Is it possible to create a PivotTable from more 
than one source?

There are ways and means to wriggle around this problem.  It’s easy if the data is  
all in multiple ranges of the same workbook (simply use the hidden ‘wizard’,  
ALT + D + P) and select ‘Multiple consolidation ranges’.  However, it is simpler to 
use Power Pivot if you are using Excel 2010 or later.

Drop us a line at training@sumproduct.com for more details on Power Pivot.

7 I have accidentally created an add-in by  
saving one of my Excel files as an “add-in” 
type.  Going to Tools-> Add-Ins, I cannot seem 
to remove it.  How can it be deleted?

Easy.  Move the offending file to a different location temporarily whilst Excel is 
closed.  You may get an error message about this add-in upon opening Excel.  Then, 
open Excel and open the ‘Add-ins’ dialog box.  Check on the ‘phantom’ add-in.  Excel 
will say it cannot find it and ask whether you wish to delete it from the list.  Click 
‘Yes’ and then move your Excel file back to its original location.  All done.
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8 How can I make the text on my formula bar 
larger?

Go to ‘Excel Options’ (ALT + T + O), then select ‘General’ from the columnar menu.  
In the ‘When creating new workbooks’ section, change the font size.  You will need 
to restart Excel for the effects to take place.

9 How can I make all comments in the cells on a 
particular worksheet appear simultaneously?

This appears to be a little-known feature in Excel for some reason.  Go to the  
‘Review’ tab on the Ribbon and in the ‘Comments’ grouping select ‘Show All  
Comments’.

10 Can you embed videos in Excel? This is an unusual query, but yes, you can although we are not sure we recommend 
it.  Go the ‘Insert’ tab on the Ribbon and then click on ‘Object’ in the ‘Text’ grouping 
(obviously!).  Click on the ‘Create from File’ tab in the ‘Object’ dialog box and browse 
to the video.  Check the ‘Display as icon’ box (checking ‘Link to file’ links rather than 
embeds the video) and then click ‘OK’ (you can change the icon by pressing the 
‘Change icon…’ button).

Do note this make the Excel file very large!!
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11 I need to refer to every fourth row in a block of 
cells, e.g. cell A1 has the formula =A15, cell A2 
has the formula =A19, cell A3 has the formula 
=A23 and so on.  Is there a quick way to create 
these formulae without having to write out the 
calculation in each row?

Yes – and this technique works for any pattern where an equal number of rows is 
omitted each time.  Type an apostrophe in front of the formula in cell A1, so that 
it becomes ‘=A15.  Do the same for A2, i.e. the formula becomes ‘=A19.  Now copy 
these formulae down.  You will get ‘=A23, ‘=A27 and so on.  Now highlight all of 
these formulae and on the ‘Data’ tab, click on the ‘Text to Columns’ icon in the ‘Data 
Tools’ grouping.  When the dialog box appears, just click on the ‘Finish’ button.  It's 
as simple as that!

12 I use certain files all of the time, although they 
may not appear in my recent list.  Is there a 
quick way to access them without having to 
go File->Open and browse to the appropriate 
directory?

Yes.  Open the file in Excel and then return to what is known as the ‘backstage’  
area by clicking on the file tab.  You will now see your file in the list of recently 
opened files.  

You will see a ‘pin’ to the right of each file recently opened.  Click on this and it will 
‘pin’ this file so that it is always visible when you are selecting a file to open.

13 How can I find the first item in a list that is a 
case sensitive match for what I am searching 
for?

Use the formula 

{=MATCH(TRUE,EXACT(Criterion,List),0)}

This is entered as an array formula (CTRL + SHIFT + ENTER) – so braces are not 
manually entered.
Please see https://www.sumproduct.com/thought/index-match.html for further 
information.

14 How can I count the number of unique items in 
an Excel list?

Use the formula

=SUMPRODUCT((List<>"")/COUNTIF(List,List&""))

to count the number of unique items in the List.  For more information, please see 
https://www.sumproduct.com/thought/sumproduct-squared.html.

15 HHow can I create a list of the unique entries 
from a list in Excel which may contain dupli-
cates?

This is when you should use the ‘Advanced Filter’ in Excel, located in the ‘Sort & 
Filter’ grouping of the ‘Data’ tab.  

Depending upon whether your list has a heading or not, the ‘Advanced Filter’ may 
prompt you to elect whether the list contains a heading (to be ignored). 
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Select the Range and the Location where the unique list should be created.  Then, 
complete the dialog box as follows:

16 How can I get numbers in millions to appear in 
millions, numbers in thousands in thousands 
and others in units?

Use custom number formatting.  Click on the cells to be formatted and then use the 
keyboard shortcut CTRL + 1 to Format Cells.  Select ‘Custom’ on the ‘Number’ tab 
and use syntax such as

[>=1000000]#,##0,,“m”;[>=1000]#,##0,“k”;#,##0

For more information on number formatting, please refer to https://www.sumprod-
uct.com/thought/number-formatting.html.

17 How can I express a decimal as a fraction in 
Excel?

Use the formula

=TEXT(Decimal,“? ?/?”)

18 What is the quickest way to negate a set of 
input data?

Of course, you can always fall back on the formula =-Cell_Reference, but if you just 
want all of the inputs to be negated in one go, simply type -1 into a cell and then 
copy it.  Then, highlight the data you wish to negate and Paste Special as Values  
(ALT + E + S + V) using the Multiply operator.  Simple!

19 How do I find the third largest value in a set of 
data?

Use the LARGE function: =LARGE(Data,n) returns the nth largest value in the Data. 
SMALL works similarly but finds the nth smallest.

20 How do I find the sum of the first 10 items in a 
list even if the list may have rows inserted or 
deleted (i.e. it always sums the first 10)?

Assume the range to be summed initially is the selection A1:A10.  The formula

=INDIRECT(“A1:A10”)

will always sum this range regardless of how many rows are added or deleted.  

For more information on the INDIRECT function, please see https://www.sumprod-
uct.com/thought/being-direct-about-indirect.html.
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SumProduct recently had the opportunity to have a play with the relatively new Excel add-in, Zebra BI.  One of our Sydney based staff, Stefenie Long, 
took a look at it.
Zebra BI is a relatively new Excel add-in providing quick, efficient alternatives to Excel reporting in the form of graphs and charts. It essentially 
summarises data into three key components: Visualize, Report and Share.

Beginning with ‘Visualize’, this grouping allows you to first choose graphs 
quickly for data presentations. You simply highlight the data you wish 
to include, click on one of the icons in the ‘Visualize’ group and select 
a report.  In seconds you already have a functioning report and while 
detailed, is also very clear, making it easy for your audience to read.   

This functionality definitely appears aimed at the time-poor or those 
who struggled with Excel’s existing chart interfaces.
An advantage of Zebra BI is having the ability to quite literally put a graph 
together in seconds and have it looking presentation ready, e.g.

Visualize
Once downloaded, Zebra BI sits adds a tab to the Excel Ribbon allowing for easy access:

Not All Black and White with Zebra BI
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Another useful feature of Zebra BI is that it provides the ability to 
insert numbered or symbol referenced comments.  This feature is also 
found on in the ‘Report’ section of the Ribbon and allows for a smooth 
referencing system throughout your report.  Regardless of whether 

you need a referencing system hidden or would prefer it be obvious 
to your audience, this feature keeps your project looking clean when 
you’re needing to associate any necessary mentions in and throughout  
your report.

Report
We felt this interface took a little more understanding. After a few attempts 
it proved to work reasonably well for customising and personalising 
reporting.  For example, it may be company policy that all your reports 
be presenting in corporate colours or schemes or you could just be love 
playing around with colour combinations, given most of us have plenty 
of time to play with Excel (!). Whatever the case is, Zebra BI allows you to 
achieve these goals smoothly using the Edit function, which can be found 
when you right click on your report and select the paintbrush symbol.

Another option is to view Zebra BI’s ‘Default Styles’ via the Ribbon.  
Personalised colours and schemes can be saved conveniently for future 
use, should you choose to use them on a regular basis. We developed 
this customised report below by highlighting best sales for the year so 
far, which clearly becomes the focal point of the report:

mailto:contact@sumproduct.com
http://www.sumproduct.com


contact@sumproduct.com  | www.sumproduct.com  | +61 3 9020 2071 

Share
One issue that many people come across from time to time is exporting 
their work out of Excel. Spending time and effort on a report then having 
the formatting and figures distort on your page can definitely frustrate 
even the most patient of people. In the ‘Share’ group on the Zebra  

BI Ribbon there is an ‘Export’ function that allows you to export your 
work to a PDF or to PowerPoint.  It is worth noting that if you change 
or update any details on your Zebra BI report in Excel, your PowerPoint 
Presentation version will simultaneously update.  

It’s not long to go now.  Later this month, Thursday 26 May heralds the third Amsterdam Excel Summit.  A one-day event this year, this 
event will still be action-packed as attendees can:

 •  Improve your Power Query skills
 •  Learn how to customise the Ribbon for your workbooks and add-ins
 •  Get insights into how to build Excel models based on ranges and positions
 •  Understand how to create involved array formulae
 •  Get advice on Best Practice in Power Pivot
 •  See how to use VBA to customise charts
 •  Receive Excel Tips and Tricks, documentation and lots of valuable files.

Due to pre-existing client commitments we will not be able to attend this year, but it’s worth noting that gurus Jon Peltier, Jan 
Karel Pieterse, Roger Govier and Tony de Jonker will all be in attendance and that the Amsterdam Excel summit also features post-
conference training the day after.

For more information and to book, check out http://topexcelclass.com/index.php/amsterdam-excel-summit/ .

You can find out more about Zebra BI by visiting their website, www.zebrabi.com.  

Amsterdam Excel Summit

Monday 13 to Friday 17 June sees SumProduct on the road in Perth, Western Australia. Liam Bastick is making several presentations at local accounting 
conferences and anyone in the area is more than welcome to attend.  Please see http://www.cpaaustralia.com.au/training-and-events/conferences/
cpa-week/day-two (CPA Australia) and http://www.charteredaccountants.com.au/AcctAudit/Program (CAANZ) for more details.

However, if you cannot make these events, we’d be happy to catch up with you in any event, whether it’s to discuss a technical query, have an on-site 
presentation on some of the latest advancements in Excel or to discuss training / consulting needs.  Please drop our coordinator, Stefenie Long a line 
on stefenie.long@sumproduct.com.  Happy to have a catch up!

A Perch in Perth
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Sydney Address: SumProduct Pty Ltd, Suite 802, Level 8, 276 Pitt Street, Sydney NSW 2000
Melbourne Address: SumProduct Pty Ltd, Level 9, 440 Collins Street, Melbourne VIC 3000
Registered Address: SumProduct Pty Ltd, Level 6, 468 St Kilda Road, Melbourne VIC 3004

Link to Others
These newsletters are not intended to be 
closely guarded secrets.  Please feel free 
to forward this newsletter to anyone you 
think might be interested in converting to 

“the SumProduct way”.

If you have received a forwarded 
newsletter and would like to receive 
future editions automatically, please 

subscribe by completing our newsletter 
registration process found at the foot of 

Any Questions?
If you have any tips, comments or queries 
for future newsletters, we’d be delighted 
to hear from you. Please drop us a line at 

newsletter@sumproduct.com.

Our Services
We have undertaken a vast array of 
assignments over the years, including:
·  Business planning
·  Building three-way integrated   
 financial statement projections
·  Independent expert reviews
·  Key driver analysis
·  Model reviews / audits for internal   
 and external purposes
·  M&A work
·  Model scoping
·  Power BI, Power Query & Power Pivot
·  Project finance
·  Real options analysis
·  Refinancing / restructuring
·  Strategic modelling
·  Valuations
·  Working capital management
If you require modelling assistance of any 
kind, please do not hesitate to contact us 
at contact@sumproduct.com.

Training
SumProduct offers a wide range of 
training courses, aimed at finance 
professionals and budding Excel experts. 
Courses include Excel Tricks & Tips, 
Financial Modelling 101, Introduction to 
Forecasting and M&A Modelling. 

Drop us a line at training@sumproduct.com 
for a copy of the brochure or download  
it directly from

Check out our 
more popular 
courses in 
our training 
brochure:

Location Course Date Duration

Brisbane Excel Tips & Tricks 16th May 2016 1 day

Brisbane Financial Modelling 17th - 18th May 2016 2 days

Singapore Excel Tips & Tricks 23rd May 2016 1 day

Singapore Financial Modelling 24th - 25th May 2016 2 days

Singapore Power of Power Pivot 26th - 27th May 2016 2 days

Melbourne Excel Tips & Tricks 6th Jun 2016 1 day

Melbourne Financial Modelling 7th - 8th Jun 2016 2 days

Melbourne Mergers & Acquisitions Modelling 9th - 10th Jun 2016 2 days

Melbourne Power of Power Pivot 14th - 15th Jun 2016 2 days

Auckland Excel Tips & Tricks 20th Jun 2016 1 day

Auckland Financial Modelling 21st - 22nd Jun 2016 2 days

Upcoming SumProduct Training Courses

Key Strokes
Each newsletter, we’d like to introduce you to several useful keystrokes you may or may not be aware of.  This month, we thought we 
would start a NEW:

And these alternatives don’t begin address mouse-related solutions!
There are over 540 keyboard shortcuts in Excel.  For a comprehensive list, please download our Excel file a
www.sumproduct.com/thought/keyboard-shortcuts. Also, check out our new daily Excel Tip of the Day feature on the 
www.sumproduct.com homepage.

Keystroke What it does
ALT + SHIFT + F1 Insert new sheet

CTRL + ALT + F1 Insert new macro sheet

CTRL + ALT + F3 New name

F11 Insert chart on new sheet

CTRL + F11 Insert new macro sheet

CTRL + N New workbook
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