
Our Newsletter turns 10 this month
and to celebrate, we’re turning on the style (quite literally), see what F10 
actually does and announce the winner of the recent “Most Useless Function  
in Excel” competition. And guess what? It’s not the VLOOKUP function much  
as I believe it should be… Enjoy! 

Gone Too Soon

Formats versus styles
The terms ‘format’ and ‘style’ are often used interchangeably, but in 
the world of Excel they are not the same thing.  To see this, select any 
cell in Excel and apply the shortcut keystroke CTRL + 1.  This shortcut 
brings up the ‘Format Cells’ dialog box:

Excel has six format properties: Number, Alignment, Font, Border, 
Patterns and Protection. A style is simply a pre-defined set of these 
various formats.  With a little forethought, these styles can be set up 
and applied to a worksheet cell or range very easily.

Creating your own styles is straightforward with Excel’s Style dialog box:

	 •	 In Excel 2003 (and earlier), go to Format--> Style (ALT + O + S).

	 •	 In Excel 2007 (and later), go to the Home tab, click the arrow 	 	
		  in the bottom right corner and then select ‘New Cell Style…’  
	 	 (ALT + N):

Either way, the dialog box appears:

Example

Consider we create an assumption format for entering data in dollars. 
First, select a cell or range of cells. Then, call up the above dialog box. 
The dropdown box (highlighted above) can be edited. We’ll change the 
name to ‘Dollar Assumptions” and click the ‘Modify’ button (Excel 2003 
and earlier) or the ‘Format’ button (Excel 2007 and later).

The Format Cells dialog box reappears:

	 •	 Number: select the Currency category, with zero decimal 		
		  places and apply the ‘$’ symbol

	 •	 Alignment: Horizontal – Right (Indent) with zero indent

	 •	 Patterns: select an ‘easy-on-the-eye’ colour such as pale green

	 •	 Protection: uncheck the Locked check box (allows the cell to be 	 	
	 	 changed in a protected worksheet)

	 •	 Click ‘OK’ to return to the Style dialog box.

We start this month’s newsletter with sad news.  With a heavy heart, we are sad to announce the passing of friend 

and colleague Mike Glover, responsible for SumProduct’s web design and newsletter, who tragically drowned 

recently whilst on holiday with his family.  Words are insufficient at a time like this; our deepest sympathies go out 

to his wife Kylie and young family.  Rest In Peace, Mike.  We shall all miss you.
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Note that no formats have been ascribed for Font or Border in this 
example. We don’t want the style to control (that is, overwrite) these 
properties, so the ‘Style includes’ check boxes for these two format 
properties should be unchecked:

 
 

By clicking ‘OK’ or ‘Add’, the cell or range has now been formatted with 
the ‘Dollar Assumptions’ style.

Now that this style has been added, in Excel 2007 / later you simply 
select the range and then click on the style in the Styles gallery on the 
Home tab.

Applying styles in Excel 2003 (and earlier) is just as simple once you 
have made a customisation.

For pre Excel 2007, you can call up the Style dialog box and then choose 
the appropriate style and click ‘OK’. This is a little cumbersome. It is 
easy to incorporate this Style dropdown box onto an existing toolbar 
and dispense with several of these steps.

By right-clicking on any toolbar or using the shortcut (ALT + T + C), call 
up the Customize dialog box and select the Commands tab, then the 
Format category.

 

 
 

Choose the Style dropdown using the left-click on the mouse and drag it 
onto an existing toolbar of your choice (then close the dialog box).

Easy!

Updating and retaining styles

The difference between Formats and Styles becomes obvious when you 
realise you want to change (update) a style. Just select one of the cells 
that the style is attached to and call up the Style dialog box in the usual 
way, modifying the style as required. Click ‘OK’ when finished. Note that 
every cell in the open workbook that uses this style has automatically 
updated. Once you start using styles, you will never look back!

You will only want to set up styles once. When you’re finished, simply 
save the file as a template using File --> Save As (you may wish to delete 
or remove formatted cells first so that you have a blank workbook). Using 
File --> New (or Office Menu --> New --> My Templates in Excel 2007 and 
later) will call up your saved styles.
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Most Useless Excel Function
Long, long ago in Excel fora far, far away (well, earlier this year 
anyway), a call went out to Excel users and gurus alike to vote for 
what they believed was the most useless function ever in Excel. 
Given this began pre-Excel 2013, our current favourite – BITAND 
(look it up) – was deemed ineligible.

The crowd favourite was FACTDOUBLE, a function I am sure most  

 
readers will have used on less than zero occasions. This superstar  
of the modelling world returns the double factorial of a number (?).

Microsoft does like making terms up on occasion and we can’t help 
thinking this might be one such instance. Mathematicians amongst 
you will know that the factorial function (denoted by ‘!’) only works 
with integers and is the product of all non-negative integers less 
than or equal to integer selected, e.g. ≥

3! = 3 x 2 x 1 = 6

7! = 7 x 6 x 5 x 4 x 3 x 2 x 1 = 5,040

We thought FACTDOUBLE would therefore work as follows:

FACTDOUBLE(3) = 3!! = (3 x 2 x 1)! = 6! = 6 x 5 x 4 x 3 x 2 x 1 = 720

But no.

If n is odd, FACTDOUBLE(n) = n (n-2) (n-4)…3 x 1

If n is even, FACTDOUBLE(n) = n (n-2) (n-4)…4 x 2, e.g.

FACTDOUBLE(7) = 7 x 5 x 3 x 1 = 105

FACTDOUBLE(8) = 8 x 6 x 4 x 2 = 384

and therefore (!?) in Excel 2013 FACTDOUBLE(BITAND(13,25)) = 945

In fact, it will even work with non-negative 
decimals, the value is simply truncated so 
that it becomes a whole number.

Having said all this, since it was 
announced, various Excel users 
have been challenging each other 
to come up with a rationale for 
this function. Apparently, it is 
necessary to compute the 
odds of winning in Texas 
Hold ‘Em (obviously!) so it 
isn’t a function without 
use after all…
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Complex Formula of the Month
Financial modelling requires several skills. Aside from a good 
understanding of Excel, an ability to solve problems, a strong technical 
knowledge in accounting, statistics, taxation and valuation theory 
amongst other areas, it’s useful to have at hand the right formulae for 
the right circumstance.

In a very ad hoc series (trust us, this will be very ad hoc!), we submit 
for your perusal a formula you may not be aware of that does have a 
practical use for those working in finance.

In a fiercely competitive market, managers are often trying to work out 
what is the maximum discount they can offer for a product in order to 
incentivise debtors paying without eroding profits and / or market share 
significantly.

To this end, ladies and gentlemen, we present Hill and Reiner’s formula 
from 1979 which suggested the optimum maximum discount that should 
be made.≥

After our April newsletter (and in light of our continuing discussions about the pro’s 
and con’s of Excel 2013), we’ve received a few queries from modellers struggling 
to change the chart type of an individual data series in a chart with more than one 
set of data.

Before Excel 2013, users were able to change individual data series to a different 
chart type by selecting them, and then clicking Chart Tools -> Options -> Change 
Chart Type. Excel would then change the chart type of the selected data series 
only. However, Excel 2013 has arguably become too clever for its own good. If you 
proceed in this manner in the latest version of Excel, you will discover that the 
spreadsheet software will automatically change the chart type for all data series 
in the chart.

Now, this could be a blessing or a curse. Assuming you wish to only change the 
chart type for a selected data series, you must first change your chart to a combo 
chart. To do this, select the chart in order to show the ‘Chart Tools’ on the Ribbon, 
then click ‘Change Chart Type’ on the ‘Design’ tab, and pick ‘Combo chart’. Then 
you can proceed in the usual way.

A Warm and Fuzzy Welcome
Ever tried to connect two data sets where the identifier is not precisely the same for 
the two tables?  If this strikes a familiar chord with you, you have probably tried to 
perform “fuzzy matching”, whereby modellers seek to link two similar data entries, 
e.g. “SumProduct Pty Limited” should be connected to “sum product ltd”.

Launched just recently, the Fuzzy Lookup Add-In for Excel was developed by 
Microsoft Research and performs fuzzy matching of textual data in Microsoft Excel.  
It can be used to identify fuzzy duplicate rows within a single table or to fuzzy join  
similar rows between two different tables. The matching is robust to a wide variety of 
errors including spelling mistakes, abbreviations, synonyms and added / missing data. 

While the default configuration works well for a wide variety of textual data, such 
as product names or customer addresses, the matching may also be customised for 
specific domains or languages too. 

The add-in is available for Excel 2010 onwards and along with an example Excel file  
and high-level instructions, you can download it from the Microsoft website:  
http://www.microsoft.com/en-us/download/details.aspx?id=15011.

We expect to see all of our clients incorporating this into their budgeting models in the very near future. Or maybe not.

[Jokes aside, SumProduct has incorporated a variant of this calculation into several recent cash flow forecasting models for our clients.  
If you’d like to find out more about how this might help and apply to you, drop us a line at contact@sumproduct.com.]

Excel Gotchas
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Please forward
These newsletters are not intended 
to be closely guarded secrets. Please 
feel free to forward this newsletter to 
anyone you think might be interested.

If you have received a forwarded 
newsletter and would like to receive 
future editions automatically, please 

subscribe by completing our newsletter 
registration process found at the foot of 
any www.sumproduct.com web page.

Any questions?
If you have any tips, comments or queries 
for future newsletters, we’d be delighted 
to hear from you. Please drop us a line at 

newsletter@sumproduct.com.

Our services
We have undertaken a vast array of 
assignments over the years, including:
· 	 Business planning
· 	 Building three-way integrated 		
	 financial statement projections
· 	 Independent expert reviews
· 	 Key driver analysis
· 	 Model reviews / audits for internal 		
	 and external purposes
· 	 M&A work
· 	 Model scoping
· 	 Project finance
· 	 Real options analysis
· 	 Refinancing / restructuring
· 	 Strategic modelling
· 	 Valuations
· 	 Working capital management

If you require modelling assistance 
of any kind, please do not hesitate to 
contact us at contact@sumproduct.com.

Training
SumProduct offers a wide range of 
training courses, aimed at finance 
professionals and budding Excel experts. 
Courses include Excel Tricks & Tips, 
Financial Modelling 101, Introduction to 
Forecasting and M&A Modelling. 

Email us at training@sumproduct.com 
for a copy of the brochure or download  
it directly from
http://www.sumproduct.com/training.

Check out our 
more popular 
courses in our 
training brochure:

Excel Thinks Inside The Box
It’s official. After months of needing a PhD in Astrophysics 
to work out which version of Office 2013 you might need, 
for those considering Office 2013, you can now purchase a 
retail SKU that includes Power Pivot and Power View. Excel 
2013 Standalone SKU will now include the add-ins when 
installed.

For those who may be seething that they have already 
purchased Excel 2013 Standalone and don’t
have these useful add-ins, don’t worry. The next time 
Office updates via Click-to-Run, Excel 2013 will update for 
these add-ins.

Common sense has prevailed!

Upcoming SumProduct training courses
Perth 2nd - 5th Sep: Financial Modelling for Mergers & Acquisitions

Perth 6th Sep: Introduction to Power Pivot

Hong Kong 23rd - 27th Sep: Structuring Mining Project Finance Models

Kuala Lumpur 2nd - 3rd Oct: Valuation Modelling (Extended)

Melbourne 10th - 11th Oct: Power of Power Pivot

South Africa 21st - 25th Oct: Structured Mining Project Finance Models

Sydney 28th - 29th Oct: Power of Power Pivot

Brisbane 30th - 31st Oct: Power of PowerPivot

Hong Kong 26th - 29th Nov: Strategic Planning, Budgeting and Forecasting

Key Strokes

Keystroke What it does

F10 Activate menus

SHIFT + F10 Activate context menus (same as right-click)

CTRL + F10 Toggle maximised / restored window

Each newsletter, we’d like to introduce you to several useful keystrokes 
you may or may not be aware of. Given we have turned 10 this newsletter, 
we concentrate on F10 this time out and show you how to manipulate 
Excel in ways that even the most hardened keyboard user often reverts to 
the mouse for:

There are over 540 keyboard shortcuts in Excel. For a 
comprehensive list, please download our Excel file at 
http://www.sumproduct.com/thought/keyboard-shortcuts.


